]> git.pld-linux.org Git - packages/python-backports_abc.git/blob - python-backports_abc.spec
- release 2 (by relup.sh)
[packages/python-backports_abc.git] / python-backports_abc.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_with     python3 # CPython 3.x module [all functionality present in 3.5+]
6
7 Summary:        Backport of recent additions to the 'collections.abc' module
8 Summary(pl.UTF-8):      Backport ostatnich rozszerzeń modułu 'collections.abc'
9 Name:           python-backports_abc
10 Version:        0.5
11 Release:        2
12 License:        PSF
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.python.org/simple/backports_abc
15 Source0:        https://files.pythonhosted.org/packages/source/b/backports_abc/backports_abc-%{version}.tar.gz
16 # Source0-md5:  7d1936ec183a3586290adf60f6f96764
17 URL:            https://github.com/cython/backports_abc
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.5
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-modules >= 1:3.2
25 BuildRequires:  python3-modules < 1:3.5
26 %endif
27 Requires:       python-modules >= 1:2.5
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Backport of recent additions to the 'collections.abc' module.
33
34 %description -l pl.UTF-8
35 Backport ostatnich rozszerzeń modułu 'collections.abc'.
36
37 %package -n python3-backports_abc
38 Summary:        Backport of recent additions to the 'collections.abc' module
39 Summary(pl.UTF-8):      Backport ostatnich rozszerzeń modułu 'collections.abc'
40 Group:          Libraries/Python
41 Requires:       python3-modules >= 1:3.2
42 Requires:       python3-modules < 1:3.5
43
44 %description -n python3-backports_abc
45 Backport of recent additions to the 'collections.abc' module.
46
47 %description -n python3-backports_abc -l pl.UTF-8
48 Backport ostatnich rozszerzeń modułu 'collections.abc'.
49
50 %prep
51 %setup -q -n backports_abc-%{version}
52
53 %build
54 %if %{with python2}
55 %py_build %{?with_tests:test}
56 %endif
57
58 %if %{with python3}
59 %py3_build %{?with_tests:test}
60 %endif
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %if %{with python2}
66 %py_install
67
68 %py_postclean
69 %endif
70
71 %if %{with python3}
72 %py3_install
73 %endif
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %if %{with python2}
79 %files
80 %defattr(644,root,root,755)
81 %doc CHANGES.rst README.rst
82 %{py_sitescriptdir}/backports_abc.py[co]
83 %{py_sitescriptdir}/backports_abc-%{version}-py*.egg-info
84 %endif
85
86 %if %{with python3}
87 %files -n python3-backports_abc
88 %defattr(644,root,root,755)
89 %doc CHANGES.rst README.rst
90 %{py3_sitescriptdir}/backports_abc.py
91 %{py3_sitescriptdir}/__pycache__/backports_abc.cpython-*.py[co]
92 %{py3_sitescriptdir}/backports_abc-%{version}-py*.egg-info
93 %endif
This page took 0.099057 seconds and 3 git commands to generate.