]> git.pld-linux.org Git - packages/python-backports.functools_lru_cache.git/blob - python-backports.functools_lru_cache.spec
- updated to 1.6.4
[packages/python-backports.functools_lru_cache.git] / python-backports.functools_lru_cache.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Sphinx documentation
4 %bcond_without  tests   # unit tests
5
6 %define         pypi_name       backports.functools_lru_cache
7
8 Summary:        Backport of functools.lru_cache from Python 3.3
9 Summary(pl.UTF-8):      Backport functools.lru_cache z Pythona 3.3
10 Name:           python-%{pypi_name}
11 Version:        1.6.4
12 Release:        1
13 License:        MIT
14 Group:          Libraries/Python
15 #Source0Download: https://pypi.org/simple/backports.functools_lru_cache/
16 Source0:        https://files.pythonhosted.org/packages/source/b/backports.functools_lru_cache/%{pypi_name}-%{version}.tar.gz
17 # Source0-md5:  8fed424f30bf9554235aa02997b7574c
18 URL:            https://github.com/jaraco/backports.functools_lru_cache
19 BuildRequires:  python-modules >= 1:2.6
20 BuildRequires:  python-setuptools
21 BuildRequires:  python-setuptools_scm >= 3.4.1
22 BuildRequires:  python-toml
23 %if %{with tests}
24 BuildRequires:  python-pytest >= 4.6
25 %endif
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.714
28 %if %{with doc}
29 BuildRequires:  python3-jaraco.packaging >= 8.2
30 BuildRequires:  python3-rst.linker >= 1.9
31 BuildRequires:  sphinx-pdg-3
32 %endif
33 Requires:       python-backports
34 Requires:       python-modules >= 1:2.6
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Backport of functools.lru_cache from Python 3.3.
40
41 %description
42 Backport functools.lru_cache z Pythona 3.3.
43
44 %package apidocs
45 Summary:        API documentation for Python backports.functools_lru_cache module
46 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona backports.functools_lru_cache
47 Group:          Documentation
48
49 %description apidocs
50 API documentation for Python backports.functools_lru_cache module.
51
52 %description apidocs -l pl.UTF-8
53 Dokumentacja API modułu Pythona backports.functools_lru_cache.
54
55 %prep
56 %setup -q -n %{pypi_name}-%{version}
57
58 %build
59 %py_build
60
61 %if %{with tests}
62 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
63 %{__python} -m pytest tests
64 %endif
65
66 %if %{with doc}
67 cd docs
68 sphinx-build-3 -b html . _build/html
69 %endif
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %py_install
75
76 %py_postclean
77
78 %{__rm} $RPM_BUILD_ROOT%{py_sitescriptdir}/backports/__init__.*
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc CHANGES.rst LICENSE README.rst
86 %{py_sitescriptdir}/backports/functools_lru_cache.py[co]
87 %{py_sitescriptdir}/%{pypi_name}-%{version}-py*.egg-info
88
89 %if %{with doc}
90 %files apidocs
91 %defattr(644,root,root,755)
92 %doc docs/_build/html/{_static,*.html,*.js}
93 %endif
This page took 0.05423 seconds and 3 git commands to generate.