]> git.pld-linux.org Git - packages/python-backports-ssl_match_hostname.git/blob - python-backports-ssl_match_hostname.spec
7dc0a1794de674b9ac7e0325ba899c8c440cf5ce
[packages/python-backports-ssl_match_hostname.git] / python-backports-ssl_match_hostname.spec
1 %define         module_name     backports.ssl_match_hostname
2 Summary:        The ssl.match_hostname() function from Python 3
3 Summary(pl.UTF-8):      Funkcja ssl.match_hostname() z Pythona 3
4 Name:           python-backports-ssl_match_hostname
5 Version:        3.5.0.1
6 Release:        1
7 License:        PSF v2
8 Group:          Libraries/Python
9 # Source0Download: https://pypi.python.org/simple/backports.ssl-match-hostname/
10 Source0:        https://pypi.python.org/packages/source/b/backports.ssl_match_hostname/%{module_name}-%{version}.tar.gz
11 # Source0-md5:  c03fc5e2c7b3da46b81acf5cbacfe1e6
12 URL:            https://bitbucket.org/brandon/backports.ssl_match_hostname
13 BuildRequires:  python-modules >= 1:2.4
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.714
16 Requires:       python-backports
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 The Secure Sockets layer is only actually secure if you check the
22 hostname in the certificate returned by the server to which you are
23 connecting, and verify that it matches to hostname that you are trying
24 to reach.
25
26 But the matching logic, defined in RFC2818, can be a bit tricky to
27 implement on your own. So the ssl package in the Standard Library of
28 Python 3.2 now includes a match_hostname() function for performing
29 this check instead of requiring every application to implement the
30 check separately.
31
32 This backport brings match_hostname() to users of earlier versions of
33 Python. The actual code inside comes verbatim from Python 3.2.
34
35 %description -l pl.UTF-8
36 Warstwa bezpiecznych gniazd (Secure Sockets Layer) jest naprawdę
37 bezpieczna tylko jeśli sprawdza się nazwę hosta w certyfikacie
38 zwracanym przez serwer, z którym się łączy i weryfikuje, że zgadza się
39 ona z pożądaną nazwą hosta.
40
41 Ale logika dopasowująca, zdefiniowana w RFC2818, może być nietrywialna
42 do zaimplementowania samemu. Dlatego też pakiet ssl biblioteki
43 standardowej Pythona 3.2 zawiera teraz funkcję match_hostname(), która
44 wykonuje to sprawdzenie zamiast wymagania implementacji w każdej
45 aplikacji.
46
47 Ten backport udostępnia match_hostname() użytkownikom wcześniejszych
48 wersji Pythona. Sam kod pochodzi bez zmian z Pythona 3.2.
49
50 %prep
51 %setup -qn %{module_name}-%{version}
52
53 %{__mv} backports/ssl_match_hostname/*.txt .
54 touch backports/ssl_match_hostname/README.txt
55
56 %build
57 %py_build
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 %py_install
62 %py_postclean
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc README.txt LICENSE.txt
70 %{py_sitescriptdir}/backports/__init__.py[co]
71 %{py_sitescriptdir}/backports/ssl_match_hostname
72 %{py_sitescriptdir}/backports.ssl_match_hostname-%{version}-py*.egg-info
This page took 0.044924 seconds and 2 git commands to generate.