]> git.pld-linux.org Git - packages/python-babel.git/blob - python-babel.spec
9bbd68bbddb05f197fe41be94af689fd8e26f2cc
[packages/python-babel.git] / python-babel.spec
1 # TODO
2 # - lang tag /usr/share/python*/site-packages/babel/localedata/*
3 #
4 # Conditional build:
5 %bcond_without  apidocs         # do not build and package API docs
6
7 %define         pkgname babel
8 Summary:        Babel Python library
9 Summary(pl.UTF-8):      Biblioteka Babel do Pythona
10 Name:           python-%{pkgname}
11 Version:        0.9.6
12 Release:        1
13 License:        BSD-like
14 Group:          Development/Languages/Python
15 Source0:        ftp://ftp.edgewall.com/pub/babel/Babel-%{version}.tar.gz
16 # Source0-md5:  f0edcad03dfdb5505f337ef1a7690325
17 URL:            http://babel.edgewall.org/
18 BuildRequires:  python-devel
19 BuildRequires:  python-devel-tools
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.219
22 %pyrequires_eq  python-modules
23 Obsoletes:      python-Babel
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Babel is a Python library that provides an integrated collection of
29 utilities that assist with internationalizing and localizing Python
30 applications (in particular web-based applications).
31
32 %package apidocs
33 Summary:        Python Babel API documentation
34 Group:          Documentation
35
36 %description apidocs
37 Python Babel API documentation.
38
39 %prep
40 %setup -q -n Babel-%{version}
41
42 mv doc/api apidoc
43
44 %build
45 %{__python} setup.py build
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 %{__python} setup.py install \
50         --optimize=2 \
51         --root=$RPM_BUILD_ROOT
52
53 %py_postclean
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc COPYING README.txt doc/*
61 %attr(755,root,root) %{_bindir}/pybabel
62 %dir %{py_sitescriptdir}/babel
63 %{py_sitescriptdir}/babel/*.dat
64 %{py_sitescriptdir}/babel/*.py[co]
65 %dir %{py_sitescriptdir}/babel/localedata
66 # TODO: %lang tag
67 %{py_sitescriptdir}/babel/localedata/*.dat
68 %dir %{py_sitescriptdir}/babel/messages
69 %{py_sitescriptdir}/babel/messages/*.py[co]
70 %{py_sitescriptdir}/*.egg-info
71
72 %if %{with apidocs}
73 %files apidocs
74 %defattr(644,root,root,755)
75 %doc apidoc/*
76 %endif
This page took 0.155527 seconds and 2 git commands to generate.