]> git.pld-linux.org Git - packages/python-async.git/blob - python-async.spec
- release 4 (by relup.sh)
[packages/python-async.git] / python-async.spec
1 %define         module  async
2 Summary:        Async Framework
3 # Name must match the python module/package name (as in 'import' statement)
4 Name:           python-%{module}
5 Version:        0.6.1
6 Release:        4
7 License:        BSD
8 Group:          Development/Languages/Python
9 Source0:        http://pypi.python.org/packages/source/a/async/%{module}-%{version}.tar.gz
10 # Source0-md5:  6f0e2ced1fe85f8410b9bde11be08587
11 URL:            https://github.com/gitpython-developers/async
12 BuildRequires:  python-devel
13 BuildRequires:  python-distribute
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.710
16 Requires:       python-modules
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Async is a framework to process interdependent tasks in a pool of
21 workers.
22
23 %prep
24 %setup -q -n %{module}-%{version}
25
26 %build
27 %py_build
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 %py_install
32
33 %{__rm} -r $RPM_BUILD_ROOT%{py_sitedir}/async/{AUTHORS,README,test}
34
35 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
36 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
37 %py_postclean
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %files
43 %defattr(644,root,root,755)
44 %doc AUTHORS README
45 %dir %{py_sitedir}/async
46 %dir %{py_sitedir}/async/mod
47 %{py_sitedir}/async/*.py[co]
48 %{py_sitedir}/async/mod/*.py[co]
49 %attr(755,root,root) %{py_sitedir}/async/mod/*.so
50 %{py_sitedir}/async-*.egg-info
This page took 0.08327 seconds and 3 git commands to generate.