]> git.pld-linux.org Git - packages/python-apsw.git/blob - python-apsw.spec
130fbc459119a31fcf1789d6516a60b635d41703
[packages/python-apsw.git] / python-apsw.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 %define         module  apsw
8 %define         sqlite_ver 3.8.5
9
10 Summary:        Another Python SQLite Wrapper
11 Summary(pl.UTF-8):      Another Python SQLite Wrapper - jeszcze jeden pythonowy wrapper dla SQLite
12 Name:           python-%{module}
13 Version:        3.8.5
14 Release:        13
15 License:        Free
16 Group:          Libraries/Python
17 Source0:        https://github.com/rogerbinns/apsw/archive/%{version}-r1.tar.gz
18 # Source0-md5:  09eb9f39d7cf9d320ee8e89f9e9ab7ea
19 URL:            http://rogerbinns.github.io/apsw/
20 BuildRequires:  rpmbuild(macros) >= 1.710
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  sqlite3-devel >= %{sqlite_ver}
23 BuildRequires:  unzip
24 %if %{with python2}
25 BuildRequires:  python-devel
26 BuildRequires:  python-distribute
27 %endif
28 %if %{with python3}
29 BuildRequires:  python3-devel
30 BuildRequires:  python3-distribute
31 BuildRequires:  python3-modules
32 %endif
33 Requires:       python-modules
34 Requires:       sqlite3 >= %{sqlite_ver}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 APSW provides an SQLite 3 wrapper that provides the thinnest layer
39 over SQLite 3 possible. Everything you can do from the C API to SQLite
40 3, you can do from Python. Although APSW looks vaguely similar to the
41 DBAPI, it is not compliant with that API and instead works the way
42 SQLite 3 does.
43
44 %description -l pl.UTF-8
45 APSW udostępnia wrapper SQLite 3 dostarczający najcieńszą jak to tylko
46 możliwe warstwę ponad SQLite 3. Wszystko co można zrobić z poziomu API
47 C SQLite 3 można zrobić także z poziomu Pythona. Chociaż APSQ wygląda
48 dosyć podobnie do DBAPI, nie jest kompatybilne z tym API, natomiast
49 działa tak, jak SQLite 3.
50
51 %package -n python3-%{module}
52 Summary:        -
53 Summary(pl.UTF-8):      -
54 Group:          Libraries/Python
55 Requires:       sqlite3 >= %{sqlite_ver}
56
57 %description -n python3-%{module}
58 APSW provides an SQLite 3 wrapper that provides the thinnest layer
59 over SQLite 3 possible. Everything you can do from the C API to SQLite
60 3, you can do from Python. Although APSW looks vaguely similar to the
61 DBAPI, it is not compliant with that API and instead works the way
62 SQLite 3 does.
63
64 %description -n python3-%{module} -l pl.UTF-8
65 APSW udostępnia wrapper SQLite 3 dostarczający najcieńszą jak to tylko
66 możliwe warstwę ponad SQLite 3. Wszystko co można zrobić z poziomu API
67 C SQLite 3 można zrobić także z poziomu Pythona. Chociaż APSQ wygląda
68 dosyć podobnie do DBAPI, nie jest kompatybilne z tym API, natomiast
69 działa tak, jak SQLite 3.
70
71 %package apidocs
72 Summary:        %{module} API documentation
73 Summary(pl.UTF-8):      Dokumentacja API %{module}
74 Group:          Documentation
75
76 %description apidocs
77 API documentation for %{module}.
78
79 %description apidocs -l pl.UTF-8
80 Dokumentacja API %{module}.
81
82 %prep
83 %setup -q -n %{module}-%{version}-r1
84
85 %build
86 %if %{with python2}
87 %py_build %{?with_tests:test}
88 %endif
89
90 %if %{with python3}
91 %py3_build %{?with_tests:test}
92 %endif
93
94 %if %{with doc}
95 cd docs
96 %{__make} -j1 html
97 rm -rf _build/html/_sources
98 %endif
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %if %{with python2}
104 %py_install
105
106 %py_postclean
107 %endif
108
109 %if %{with python3}
110 %py3_install
111 %endif
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %if %{with python2}
117 %files
118 %defattr(644,root,root,755)
119 %doc LICENSE README.rst
120 %attr(755,root,root) %{py_sitedir}/*.so
121 %if "%{py_ver}" > "2.4"
122 %{py_sitedir}/%{module}-*.egg-info
123 %endif
124 %endif
125
126 %if %{with python3}
127 %files -n python3-%{module}
128 %defattr(644,root,root,755)
129 %doc LICENSE README.rst
130 %{py3_sitedir}/%{module}*.so
131 %{py3_sitedir}/%{module}-%{version}*-py*.egg-info
132 %endif
133
134 %if %{with doc}
135 %files apidocs
136 %defattr(644,root,root,755)
137 %doc docs/_build/html/*
138 %endif
This page took 0.097162 seconds and 2 git commands to generate.