]> git.pld-linux.org Git - packages/python-application.git/blob - python-application.spec
039c2857da17c492ccbfc4ac626248f9bec9e928
[packages/python-application.git] / python-application.spec
1 %define         module  application
2 Summary:        Basic building blocks for python applications
3 Name:           python-%{module}
4 Version:        1.3.1
5 Release:        2
6 License:        LGPL
7 Group:          Development/Languages/Python
8 Source0:        http://pypi.python.org/packages/source/p/python-application/%{name}-%{version}.tar.gz
9 # Source0-md5:  615d670fcda2aa5a01de7bc12baa1fdf
10 URL:            http://pypi.python.org/pypi/python-application
11 BuildRequires:  python-devel >= 1:2.5
12 BuildRequires:  rpm-pythonprov
13 BuildRequires:  rpmbuild(macros) >= 1.710
14 Requires:       python-modules
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 This package is a collection of modules that are useful when building
20 python applications. Their purpose is to eliminate the need to divert
21 resources into implementing the small tasks that every application
22 needs to do in order to run successfully and focus instead on the
23 application logic itself.
24
25 The modules that the application package provides are:
26
27 1. process - UNIX process and signal management. 2. python - python
28 utility classes and functions. 3. configuration - a simple interface
29 to handle configuration files. 4. log - an extensible system logger
30 for console and syslog. 5. debug - memory troubleshooting and
31 execution timing. 6. system - interaction with the underlying
32 operating system. 7. notification - an application wide notification
33 system.
34
35 %prep
36 %setup -q
37
38 %build
39 %py_build
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 %py_install
44
45 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
46 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
47 %py_postclean
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc ChangeLog NEWS README
55 %dir %{py_sitescriptdir}/%{module}
56 %{py_sitescriptdir}/%{module}/*.py[co]
57 %dir %{py_sitescriptdir}/%{module}/configuration
58 %{py_sitescriptdir}/%{module}/configuration/*.py[co]
59 %dir %{py_sitescriptdir}/%{module}/debug
60 %{py_sitescriptdir}/%{module}/debug/*.py[co]
61 %dir %{py_sitescriptdir}/%{module}/log
62 %{py_sitescriptdir}/%{module}/log/*.py[co]
63 %dir %{py_sitescriptdir}/%{module}/log/extensions
64 %{py_sitescriptdir}/%{module}/log/extensions/*.py[co]
65 %dir %{py_sitescriptdir}/%{module}/log/extensions/twisted
66 %{py_sitescriptdir}/%{module}/log/extensions/twisted/*.py[co]
67 %dir %{py_sitescriptdir}/%{module}/python
68 %{py_sitescriptdir}/%{module}/python/*.py[co]
69 %{py_sitescriptdir}/*-*.egg-info
This page took 0.228163 seconds and 2 git commands to generate.