]> git.pld-linux.org Git - packages/python-appdirs.git/blob - python-appdirs.spec
bb1a2269b8b536493c2836ecfe08cc72debbf6b4
[packages/python-appdirs.git] / python-appdirs.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5 %bcond_without  tests   # do not perform "setup.py test"
6 %bcond_without  setuptools # build without setuptools (for bootstraping)
7 #
8 Summary:        Python 2 module to choose appropriate application directories
9 Summary(pl.UTF-8):      Moduł Pythona 2 do wyboru właściwych katalogów aplikacji
10 Name:           python-appdirs
11 Version:        1.4.3
12 Release:        3
13 License:        MIT
14 Group:          Development/Languages/Python
15 #Source0Download: https://pypi.python.org/simple/appdirs
16 Source0:        https://files.pythonhosted.org/packages/source/a/appdirs/appdirs-%{version}.tar.gz
17 # Source0-md5:  44c679904082a2133f5566c8a0d3ab42
18 URL:            https://github.com/ActiveState/appdirs
19 %if %{with python2}
20 BuildRequires:  python-devel >= 1:2.6
21 %{?with_setuptools:BuildRequires:      python-setuptools}
22 %if %{with tests} && "%{py_ver}" < "2.7"
23 BuildRequires:  python-unittest2
24 %endif
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3-devel >= 1:3.2
28 %{?with_setuptools:BuildRequires:      python3-setuptools}
29 %endif
30 BuildRequires:  rpm-pythonprov
31 BuildRequires:  rpmbuild(macros) >= 1.714
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 appdirs is a module that helps you choose an appropriate:
37  - user data dir
38  - user config dir
39  - user cache dir
40  - site data dir
41  - site config dir
42  - user log dir
43
44 %description -l pl.UTF-8
45 appdirs to moduł pomagający wybrać właściwy katalog dla:
46  - danych użytkownika
47  - konfiguracji użytkownika
48  - pamięci podręcznej użytkownika
49  - danych systemu
50  - konfiguracji systemu
51  - logów użytkownika
52
53 %package -n python3-appdirs
54 Summary:        Python 3 module to choose appropriate application directories
55 Summary(pl.UTF-8):      Moduł Pythona 3 do wyboru właściwych katalogów aplikacji
56 Group:          Development/Languages/Python
57
58 %description -n python3-appdirs
59 appdirs is a module that helps you choose an appropriate:
60  - user data dir
61  - user config dir
62  - user cache dir
63  - site data dir
64  - site config dir
65  - user log dir
66
67 %description -n python3-appdirs -l pl.UTF-8
68 appdirs to moduł pomagający wybrać właściwy katalog dla:
69  - danych użytkownika
70  - konfiguracji użytkownika
71  - pamięci podręcznej użytkownika
72  - danych systemu
73  - konfiguracji systemu
74  - logów użytkownika
75
76 %prep
77 %setup -q -n appdirs-%{version}
78
79 %build
80 %if %{with python2}
81 %py_build %{?with_tests:test}
82 %endif
83
84 %if %{with python3}
85 %py3_build %{?with_tests:test}
86 %endif
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %if %{with python2}
92 %py_install
93
94 %py_postclean
95 %endif
96
97 %if %{with python3}
98 %py3_install
99 %endif
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %if %{with python2}
105 %files
106 %defattr(644,root,root,755)
107 %doc CHANGES.rst LICENSE.txt README.rst
108 %{py_sitescriptdir}/appdirs.py[co]
109 %{py_sitescriptdir}/appdirs-%{version}-py*.egg-info
110 %endif
111
112 %if %{with python3}
113 %files -n python3-appdirs
114 %defattr(644,root,root,755)
115 %doc CHANGES.rst LICENSE.txt README.rst
116 %{py3_sitescriptdir}/appdirs.py
117 %{py3_sitescriptdir}/__pycache__/appdirs.cpython-*.py[co]
118 %{py3_sitescriptdir}/appdirs-%{version}-py*.egg-info
119 %endif
This page took 0.067275 seconds and 2 git commands to generate.