]> git.pld-linux.org Git - packages/python3-absl.git/blob - python-absl.spec
eb135d7cac172af57aabef57ff77ffa21cc07515
[packages/python3-absl.git] / python-absl.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Abseil Python Common Libraries
7 Summary(pl.UTF-8):      Wspólne biblioteki Abseil dla Pythona
8 Name:           python-absl
9 Version:        0.9.0
10 Release:        5
11 License:        Apache v2.0
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/absl-py/
14 Source0:        https://files.pythonhosted.org/packages/source/a/absl-py/absl-py-%{version}.tar.gz
15 Patch0:         no-version.patch
16 # Source0-md5:  4ba3484409252ec502b08f8ef8e48ab4
17 URL:            https://github.com/abseil/abseil-py
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.7
20 BuildRequires:  python-setuptools
21 %endif
22 %if %{with python3}
23 BuildRequires:  python3-modules >= 1:3.4
24 BuildRequires:  python3-setuptools
25 %endif
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.714
28 Requires:       python-modules >= 1:2.7
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Abseil Python is a collection of Python library code for building
34 Python applications. The code is collected from Google's own Python
35 code base, and has been extensively tested and used in production.
36
37 %description -l pl.UTF-8
38 Abseil Python to biblioteka Pythona będąca zbiorem kodu do tworzenia
39 aplikacji pythonowych. Kod bibliotek został zebrany z własnego kodu
40 Google'a w Pythonie, obszernie przetestowany i jest używany
41 produkcyjnie.
42
43 %package -n python3-absl
44 Summary:        Abseil Python Common Libraries
45 Summary(pl.UTF-8):      Wspólne biblioteki Abseil dla Pythona
46 Group:          Libraries/Python
47 Requires:       python3-modules >= 1:3.4
48
49 %description -n python3-absl
50 Abseil Python is a collection of Python library code for building
51 Python applications. The code is collected from Google's own Python
52 code base, and has been extensively tested and used in production.
53
54 %description -n python3-absl -l pl.UTF-8
55 Abseil Python to biblioteka Pythona będąca zbiorem kodu do tworzenia
56 aplikacji pythonowych. Kod bibliotek został zebrany z własnego kodu
57 Google'a w Pythonie, obszernie przetestowany i jest używany
58 produkcyjnie.
59
60 %prep
61 %setup -q -n absl-py-%{version}
62 %patch0 -p1
63
64 %build
65 %if %{with python2}
66 %py_build
67 %endif
68
69 %if %{with python3}
70 %py3_build
71 %endif
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %if %{with python2}
77 %py_install
78
79 %py_postclean
80 %endif
81
82 %if %{with python3}
83 %py3_install
84 %endif
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %if %{with python2}
90 %files
91 %defattr(644,root,root,755)
92 %doc README.md
93 %{py_sitescriptdir}/absl
94 %{py_sitescriptdir}/absl_py-%{version}-py*.egg-info
95 %endif
96
97 %if %{with python3}
98 %files -n python3-absl
99 %defattr(644,root,root,755)
100 %doc README.md
101 %{py3_sitescriptdir}/absl
102 %{py3_sitescriptdir}/absl_py-%{version}-py*.egg-info
103 %endif
This page took 0.069491 seconds and 2 git commands to generate.