]> git.pld-linux.org Git - packages/python-TwistedWeb2.git/blob - python-TwistedWeb2.spec
- release 3 (by relup.sh)
[packages/python-TwistedWeb2.git] / python-TwistedWeb2.spec
1 %define         module  TwistedWeb2
2 %define         major   8.1
3 %define         minor   0
4
5 Summary:        Web library for Twisted
6 Summary(pl.UTF-8):      Biblioteka Web dla Twisted
7 Name:           python-%{module}
8 Version:        %{major}.%{minor}
9 Release:        3
10 License:        MIT
11 Group:          Libraries/Python
12 Source0:        http://tmrc.mit.edu/mirror/twisted/Web2/%{major}/%{module}-%{version}.tar.bz2
13 # Source0-md5:  e34b48edf6fef075bd41ddbd215aed32
14 URL:            http://twistedmatrix.com/trac/wiki/TwistedWeb2
15 BuildRequires:  ZopeInterface
16 BuildRequires:  python-TwistedCore >= 2.4.0
17 BuildRequires:  python-devel >= 1:2.5
18 BuildRequires:  rpm-pythonprov
19 Requires:       python-TwistedCore >= 2.4.0
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Twisted Web2 is a web application server written in pure Python, with
24 APIs at multiple levels of abstraction to facilitate different kinds
25 of web programming.
26
27 %description -l pl.UTF-8
28 Twisted Web2 to serwer aplikacji WWW napisany w czystym Pythonie z API
29 o wielu poziomach abstrakcji, mających ułatwić różne rodzaje
30 programowania WWW.
31
32 %package doc
33 Summary:        Documentation for TwistedWeb2
34 Summary(pl.UTF-8):      Dokumentacja do TwistedWeb2
35 Group:          Libraries/Python
36 Requires:       %{name} = %{version}-%{release}
37
38 %description doc
39 Offline documentation for TwistedWeb2.
40
41 %description doc -l pl.UTF-8
42 Dokumentacja offline do TwistedWeb2.
43
44 %package examples
45 Summary:        Example programs for TwistedWeb2
46 Summary(pl.UTF-8):      Programy przykładowe do TwistedWeb2
47 Group:          Libraries/Python
48 Requires:       %{name} = %{version}-%{release}
49
50 %description examples
51 This package contains example programs for TwistedWeb2.
52
53 %description examples -l pl.UTF-8
54 Ten pakiet zawiera przykładowe programy dla TwistedWeb2.
55
56 %prep
57 %setup -q -n %{module}-%{version}
58
59 %build
60 CFLAGS="%{rpmcflags}"
61 export CFLAGS
62 python setup.py build_ext
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_examplesdir}/%{name}-%{version}}
67
68 %py_install \
69         --install-purelib=%{py_sitedir} \
70         --root=$RPM_BUILD_ROOT \
71         --optimize=2
72
73 %py_postclean
74
75 cp -a doc/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc LICENSE README
83 %{py_sitedir}/*.egg-info
84 %{py_sitedir}/twisted/web2
85 %{py_sitedir}/twisted/plugins/twisted_web2.py[co]
86
87 #%files doc
88 #%defattr(644,root,root,755)
89
90 %files examples
91 %defattr(644,root,root,755)
92 %{_examplesdir}/%{name}-%{version}
This page took 0.068355 seconds and 3 git commands to generate.