]> git.pld-linux.org Git - packages/python-PyYAML.git/blob - python-PyYAML.spec
026f03b345405759176c9a20e6f93ea3aa6cd1e4
[packages/python-PyYAML.git] / python-PyYAML.spec
1 #
2 # TODO:
3 #       - the name should be python-yaml (used via 'import yaml')
4 #
5 %define         module          PyYAML
6 %define         module_dir      yaml
7 #
8 Summary:        YAML parser and emitter module for Python
9 Summary(pl.UTF-8):      Analizator i generator formatu YAML dla języka Python
10 Name:           python-%{module}
11 Version:        3.10
12 Release:        1
13 License:        MIT
14 Group:          Libraries/Python
15 Source0:        http://pyyaml.org/download/pyyaml/%{module}-%{version}.tar.gz
16 # Source0-md5:  74c94a383886519e9e7b3dd1ee540247
17 URL:            http://pyyaml.org/
18 BuildRequires:  python-devel
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.219
21 BuildRequires:  yaml-devel
22 %pyrequires_eq  python-modules
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 YAML is a data serialization format designed for human readability and
27 interaction with scripting languages. PyYAML is a YAML parser and
28 emitter for Python.
29
30 PyYAML features a complete YAML 1.1 parser, Unicode support, pickle
31 support, capable extension API, and sensible error messages. PyYAML
32 supports standard YAML tags and provides Python-specific tags that
33 allow to represent an arbitrary Python object.
34
35 PyYAML is applicable for a broad range of tasks from complex
36 configuration files to object serialization and persistance.
37
38 %description -l pl.UTF-8
39 YAML jest formatem serializacji danych czytelnym dla człowieka,
40 zaprojektowanym do interakcji w językach skryptowych. PyYAML jest
41 analizatorem i generatorem tego formatu dla języka Python.
42
43 PyYAML posiada obsługę pełnej analizy YAML 1.1, Unicode, serializację
44 poprzez piklowanie, rozszerzalne API oraz zrozumiałe komunikaty
45 błędów. Obsługuje standardowe znaczniki YAML i dostarcza nowe,
46 specyficzne dla języka Python, pozwalające na reprezentację jego
47 obiektów.
48
49 PyYAML może być użyty w szerokiej gamie zastosowań, od złożonych
50 plików konfiguracyjnych po serializację i przechowywanie obiektów.
51
52 %prep
53 %setup -q -n %{module}-%{version}
54
55 %build
56 %{__python} setup.py --with-libyaml build
57
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63
64 %{__python} setup.py install \
65         --optimize=2 \
66         --root=$RPM_BUILD_ROOT
67
68 %py_postclean
69 install examples/yaml-highlight/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc README
77 %dir %{py_sitedir}/%{module_dir}
78 %attr(755,root,root) %{py_sitedir}/_yaml.so
79 %{py_sitedir}/%{module_dir}/*.py[co]
80 %if "%{py_ver}" > "2.4"
81 %{py_sitedir}/*.egg-info
82 %endif
83 %{_examplesdir}/%{name}-%{version}
This page took 0.045102 seconds and 2 git commands to generate.