]> git.pld-linux.org Git - packages/python-PyXML.git/blob - python-PyXML.spec
8bf056acc318c04e3e81102eb3999d7b3b7d3f4d
[packages/python-PyXML.git] / python-PyXML.spec
1 %define         module  PyXML
2 Summary:        Python/XML package
3 Summary(pl.UTF-8):      Pakiet Python/XML
4 Name:           python-%{module}
5 Version:        0.8.4
6 Release:        10
7 License:        BeOpen Python Open Source License
8 Group:          Libraries/Python
9 Source0:        http://downloads.sourceforge.net/pyxml/%{module}-%{version}.tar.gz
10 # Source0-md5:  1f7655050cebbb664db976405fdba209
11 Patch0:         %{name}-as_is_keyword_in_py26.patch
12 URL:            http://pyxml.sourceforge.net/
13 BuildRequires:  expat-devel >= 1:1.95.8
14 BuildRequires:  python >= 1:2.5
15 BuildRequires:  python-devel
16 BuildRequires:  python-modules
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.219
19 %pyrequires_eq  python-modules
20 Requires:       expat >= 1:1.95.8
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The PyXML package is a collection of libraries to process XML with
25 Python. It contains, among other things
26 - xmlproc: a validating XML parser.
27 - sgmlop: a C helper module that can speed-up xmllib.py and sgmllib.py
28   by a factor of 5.
29 - PySAX: SAX 1 and SAX2 libraries with drivers for most of the
30   parsers.
31 - 4DOM: A fully compliant DOM Level 2 implementation.
32 - javadom: An adapter from Java DOM implementations to the standard
33   Python DOM binding.
34 - pulldom: a DOM implementation that supports lazy instantiation of
35   nodes.
36 - marshal: a module with several options for serializing Python
37   objects to XML, including WDDX and XML-RPC.
38 - unicode: a helper module for Python 1.5 users who need conversions
39   between UTF-8 and ISO-8859-?.
40
41 %description -l pl.UTF-8
42 Pakiet PyXML jest zestawem bibliotek do obsługi XML-a z poziomu
43 Pythona. Zawiera między innymi:
44 - xmlproc: analizator sprawdzający poprawność XML-a;
45 - sgmlp: pomocniczy moduł w C przyspieszający działanie xmllib.py i
46   sgmllib.py pięciokrotnie;
47 - PySAX: biblioteki SAX1 i SAX2 ze sterownikami do większości
48   analizatorów składniowych;
49 - 4DOM: w pełni kompatybilna implementacja DOM Level 2;
50 - javadom: adapter z implementacji DOM w Javie do standardowego DOM w
51   Pythonie;
52 - pulldom: implementacja DOM obsługująca leniwe tworzenie instancji
53   węzłów;
54 - marshal: moduł z różnymi opcjami do serializacji obiektów Pythona w
55   XML-u, w tym WDDX i XML-RPC;
56 - unicode: pomocniczy moduł dla użytkowników Pythona 1.5, którzy;
57   potrzebują konwersji między UTF-8 a ISO-8859-?.
58
59 %package examples
60 Summary:        Examples of Python/XML
61 Summary(pl.UTF-8):      Przykłady do Python/XML
62 Group:          Development/Languages/Python
63 %pyrequires_eq  python
64 Requires:       %{name} = %{version}-%{release}
65
66 %description examples
67 Examples of Python/XML.
68
69 %description examples -l pl.UTF-8
70 Przykłady do Python/XML.
71
72 %prep
73 %setup -q -n %{module}-%{version}
74 %patch0 -p1
75
76 %build
77 CC="%{__cc}" \
78 CFLAGS="%{rpmcflags}" \
79 %{__python} setup.py build \
80         --with-libexpat=%{_prefix} \
81         --ldflags=-lexpat
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
86 %{__python} setup.py install \
87         --optimize=2 \
88         --root=$RPM_BUILD_ROOT
89
90 %py_postclean
91
92 cp -a demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %doc doc ANNOUNCE CREDITS LICENCE README* TODO
100 %attr(755,root,root) %{_bindir}/xmlproc_parse
101 %attr(755,root,root) %{_bindir}/xmlproc_val
102 %{py_sitedir}/_xmlplus
103 %{py_sitedir}/PyXML-*.egg-info
104
105 %files examples
106 %defattr(644,root,root,755)
107 %{_examplesdir}/%{name}-%{version}
This page took 0.101826 seconds and 2 git commands to generate.