]> git.pld-linux.org Git - packages/python-PyKDE4.git/blob - python-PyKDE4.spec
60431334e35b9ba31a06bdb522ab608cfa0fd67d
[packages/python-PyKDE4.git] / python-PyKDE4.spec
1 #
2 # Conditional build:
3 %define         _state          stable
4 %define         orgname         pykde4
5 %define         qtver           4.8.0
6 %define         sipver          2:4.14
7 %define         pyqtver         4.9
8 %define         kdeworkspacever 4.11.0
9
10 Summary:        PyKDE4 - Python bindings for KDE 4
11 Summary(pl.UTF-8):      PyKDE4 - dowiązania KDE 4 dla Pythona
12 Name:           python-PyKDE4
13 Version:        4.12.3
14 Release:        1
15 License:        GPL
16 Group:          Libraries/Python
17 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
18 # Source0-md5:  58f2b0089a84269c730c98ca48c48c51
19 BuildRequires:  cmake >= 2.8.0
20 BuildRequires:  kde4-kdebase-workspace-devel >= %{kdeworkspacever}
21 BuildRequires:  kde4-kdepimlibs-devel
22 BuildRequires:  polkit-qt-1-devel
23 BuildRequires:  python-PyQt4-devel >= %{pyqtver}
24 BuildRequires:  python-sip >= %{sipver}
25 BuildRequires:  qt4-build >= %{qtver}
26 BuildRequires:  qt4-qmake >= %{qtver}
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.600
29 Requires:       python-PyQt4 >= %{pyqtver}
30 Requires:       python-sip >= %{sipver}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 PyKDE4 is a set of Python bindings for the KDE 4 desktop environment.
35 The bindings are implemented as a set of Python modules, which
36 correspond to KDE libraries.
37
38 %description -l pl.UTF-8
39 PyKDE4 to zbiór dowiązań środowiska graficznego KDE 4 dla Pythona.
40 Dowiązania są zaimplementowane jako zbiór modułów Pythona
41 odpowiadających poszczególnym bibliotekom KDE.
42
43 %package devel
44 Summary:        SIP development files for PyKDE4
45 Summary(pl.UTF-8):      Pliki programistyczne SIP dla PyKDE4
46 Group:          Development/Languages/Python
47 Requires:       python-PyKDE4 = %{version}-%{release}
48 Requires:       python-PyQt4-devel >= %{pyqtver}
49 Requires:       python-sip-devel >= %{sipver}
50
51 %description devel
52 SIP development files for PyKDE4, needed to build other bindings for
53 C++ classes that inherit from any of the KDE4 classes.
54
55 %description devel -l pl.UTF-8
56 Pliki programistyczne SIP dla PyKDE4, potrzebne do budowania innych
57 dowiązań do klas C++ dziedziczących z dowolnej klasy KDE4.
58
59 %package devel-tools
60 Summary:        PyKDE4 development tools
61 Summary(pl.UTF-8):      Narzędzia programistyczne PyKDE4
62 Group:          Development/Languages/Python
63 Requires:       python-PyKDE4 = %{version}-%{release}
64 Requires:       python-PyQt4-devel-tools >= %{pyqtver}
65
66 %description devel-tools
67 PyKDE4 development tool: pykdeuic4.
68
69 %description devel-tools -l pl.UTF-8
70 Narzędzie programistyczne PyKDE4: pykdeuic4.
71
72 %package examples
73 Summary:        PyKDE4 examples
74 Summary(pl.UTF-8):      Przykłady dla PyKDE4
75 Group:          Libraries/Python
76
77 %description examples
78 PyKDE4 examples.
79
80 %description examples -l pl.UTF-8
81 Przykłady dla PyKDE4.
82
83 %prep
84 %setup -q -n %{orgname}-%{version}
85
86 %build
87 install -d build
88 cd build
89 %cmake \
90         ../
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT%{_examplesdir}/python-PyKDE4-%{version}
97
98 %{__make} -C build install \
99         DESTDIR=$RPM_BUILD_ROOT \
100         kde_htmldir=%{_kdedocdir}
101
102 mv $RPM_BUILD_ROOT%{_datadir}/apps/pykde4/examples/* $RPM_BUILD_ROOT%{_examplesdir}/python-PyKDE4-%{version}
103 %py_comp $RPM_BUILD_ROOT%{py_sitedir}/PyKDE4
104 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/PyKDE4
105
106 # don't use py_postclean
107 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyKDE4/*.py
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_libdir}/kde4/kpythonpluginfactory.so
115 %dir %{py_sitedir}/PyKDE4
116 %attr(755,root,root) %{py_sitedir}/PyKDE4/akonadi.so
117 %attr(755,root,root) %{py_sitedir}/PyKDE4/dnssd.so
118 %attr(755,root,root) %{py_sitedir}/PyKDE4/kdecore.so
119 %attr(755,root,root) %{py_sitedir}/PyKDE4/kdeui.so
120 %attr(755,root,root) %{py_sitedir}/PyKDE4/khtml.so
121 %attr(755,root,root) %{py_sitedir}/PyKDE4/kio.so
122 %attr(755,root,root) %{py_sitedir}/PyKDE4/knewstuff.so
123 %attr(755,root,root) %{py_sitedir}/PyKDE4/kparts.so
124 %attr(755,root,root) %{py_sitedir}/PyKDE4/kterminal.so
125 %attr(755,root,root) %{py_sitedir}/PyKDE4/ktexteditor.so
126 %attr(755,root,root) %{py_sitedir}/PyKDE4/kutils.so
127 %attr(755,root,root) %{py_sitedir}/PyKDE4/nepomuk.so
128 %attr(755,root,root) %{py_sitedir}/PyKDE4/phonon.so
129 %attr(755,root,root) %{py_sitedir}/PyKDE4/plasma.so
130 %attr(755,root,root) %{py_sitedir}/PyKDE4/solid.so
131 %attr(755,root,root) %{py_sitedir}/PyKDE4/soprano.so
132 %{py_sitedir}/PyKDE4/__init__.py[co]
133 %{py_sitedir}/PyKDE4/pykdeconfig.py[co]
134
135 %files devel
136 %defattr(644,root,root,755)
137 %dir %{_datadir}/sip/PyKDE4
138 %{_datadir}/sip/PyKDE4/akonadi
139 %{_datadir}/sip/PyKDE4/dnssd
140 %{_datadir}/sip/PyKDE4/kdecore
141 %{_datadir}/sip/PyKDE4/kdeui
142 %{_datadir}/sip/PyKDE4/khtml
143 %{_datadir}/sip/PyKDE4/kio
144 %{_datadir}/sip/PyKDE4/knewstuff
145 %{_datadir}/sip/PyKDE4/kparts
146 %{_datadir}/sip/PyKDE4/kterminal
147 %{_datadir}/sip/PyKDE4/ktexteditor
148 %{_datadir}/sip/PyKDE4/kutils
149 %{_datadir}/sip/PyKDE4/nepomuk
150 %{_datadir}/sip/PyKDE4/phonon
151 %{_datadir}/sip/PyKDE4/plasma
152 %{_datadir}/sip/PyKDE4/polkitqt
153 %{_datadir}/sip/PyKDE4/solid
154 %{_datadir}/sip/PyKDE4/soprano
155 %{_datadir}/sip/PyKDE4/glossary.html
156
157 %files devel-tools
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_bindir}/pykdeuic4*
160 %{py_sitedir}/PyQt4/uic/pykdeuic4.py*
161 %{py_sitedir}/PyQt4/uic/widget-plugins/kde4.py*
162
163 %files examples
164 %defattr(644,root,root,755)
165 %{_examplesdir}/python-PyKDE4-%{version}
This page took 0.080278 seconds and 2 git commands to generate.