]> git.pld-linux.org Git - packages/python-PyKDE4.git/blob - python-PyKDE4.spec
- 4.10.0
[packages/python-PyKDE4.git] / python-PyKDE4.spec
1 #
2 # Conditional build:
3 %define         _state          stable
4 %define         orgname         pykde4
5 %define         qtver           4.8.0
6 %define         sipver          2:4.14
7 %define         pyqtver         4.9
8
9 Summary:        PyKDE4 - Python bindings for KDE 4
10 Summary(pl.UTF-8):      PyKDE4 - dowiązania KDE 4 dla Pythona
11 Name:           python-PyKDE4
12 Version:        4.10.0
13 Release:        1
14 License:        GPL
15 Group:          Libraries/Python
16 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
17 # Source0-md5:  dc823ad11e6ff9661d854251d6dbb00f
18 BuildRequires:  cmake >= 2.8.0
19 BuildRequires:  kde4-kdebase-workspace-devel >= %{version}
20 BuildRequires:  python-PyQt4-devel >= %{pyqtver}
21 BuildRequires:  python-sip >= %{sipver}
22 BuildRequires:  qt4-build >= %{qtver}
23 BuildRequires:  qt4-qmake >= %{qtver}
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.600
26 Requires:       python-PyQt4 >= %{pyqtver}
27 Requires:       python-sip >= %{sipver}
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 PyKDE4 is a set of Python bindings for the KDE 4 desktop environment.
32 The bindings are implemented as a set of Python modules, which
33 correspond to KDE libraries.
34
35 %description -l pl.UTF-8
36 PyKDE4 to zbiór dowiązań środowiska graficznego KDE 4 dla Pythona.
37 Dowiązania są zaimplementowane jako zbiór modułów Pythona
38 odpowiadających poszczególnym bibliotekom KDE.
39
40 %package devel
41 Summary:        SIP development files for PyKDE4
42 Summary(pl.UTF-8):      Pliki programistyczne SIP dla PyKDE4
43 Group:          Development/Languages/Python
44 Requires:       python-PyKDE4 = %{version}-%{release}
45 Requires:       python-PyQt4-devel >= %{pyqtver}
46 Requires:       python-sip-devel >= %{sipver}
47
48 %description devel
49 SIP development files for PyKDE4, needed to build other bindings for
50 C++ classes that inherit from any of the KDE4 classes.
51
52 %description devel -l pl.UTF-8
53 Pliki programistyczne SIP dla PyKDE4, potrzebne do budowania innych
54 dowiązań do klas C++ dziedziczących z dowolnej klasy KDE4.
55
56 %package devel-tools
57 Summary:        PyKDE4 development tools
58 Summary(pl.UTF-8):      Narzędzia programistyczne PyKDE4
59 Group:          Development/Languages/Python
60 Requires:       python-PyKDE4 = %{version}-%{release}
61 Requires:       python-PyQt4-devel-tools >= %{pyqtver}
62
63 %description devel-tools
64 PyKDE4 development tool: pykdeuic4.
65
66 %description devel-tools -l pl.UTF-8
67 Narzędzie programistyczne PyKDE4: pykdeuic4.
68
69 %package examples
70 Summary:        PyKDE4 examples
71 Summary(pl.UTF-8):      Przykłady dla PyKDE4
72 Group:          Libraries/Python
73
74 %description examples
75 PyKDE4 examples.
76
77 %description examples -l pl.UTF-8
78 Przykłady dla PyKDE4.
79
80 %prep
81 %setup -q -n %{orgname}-%{version}
82
83 %build
84 install -d build
85 cd build
86 %cmake \
87         ../
88
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT%{_examplesdir}/python-PyKDE4-%{version}
94
95 %{__make} -C build install \
96         DESTDIR=$RPM_BUILD_ROOT \
97         kde_htmldir=%{_kdedocdir}
98
99 mv $RPM_BUILD_ROOT%{_datadir}/apps/pykde4/examples/* $RPM_BUILD_ROOT%{_examplesdir}/python-PyKDE4-%{version}
100 %py_comp $RPM_BUILD_ROOT%{py_sitedir}/PyKDE4
101 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}/PyKDE4
102
103 # don't use py_postclean
104 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyKDE4/*.py
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %files
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_libdir}/kde4/kpythonpluginfactory.so
112 %dir %{py_sitedir}/PyKDE4
113 %attr(755,root,root) %{py_sitedir}/PyKDE4/akonadi.so
114 %attr(755,root,root) %{py_sitedir}/PyKDE4/dnssd.so
115 %attr(755,root,root) %{py_sitedir}/PyKDE4/kdecore.so
116 %attr(755,root,root) %{py_sitedir}/PyKDE4/kdeui.so
117 %attr(755,root,root) %{py_sitedir}/PyKDE4/khtml.so
118 %attr(755,root,root) %{py_sitedir}/PyKDE4/kio.so
119 %attr(755,root,root) %{py_sitedir}/PyKDE4/knewstuff.so
120 %attr(755,root,root) %{py_sitedir}/PyKDE4/kparts.so
121 %attr(755,root,root) %{py_sitedir}/PyKDE4/kterminal.so
122 %attr(755,root,root) %{py_sitedir}/PyKDE4/ktexteditor.so
123 %attr(755,root,root) %{py_sitedir}/PyKDE4/kutils.so
124 %attr(755,root,root) %{py_sitedir}/PyKDE4/nepomuk.so
125 %attr(755,root,root) %{py_sitedir}/PyKDE4/phonon.so
126 %attr(755,root,root) %{py_sitedir}/PyKDE4/plasma.so
127 %attr(755,root,root) %{py_sitedir}/PyKDE4/solid.so
128 %attr(755,root,root) %{py_sitedir}/PyKDE4/soprano.so
129 %{py_sitedir}/PyKDE4/__init__.py[co]
130 %{py_sitedir}/PyKDE4/pykdeconfig.py[co]
131
132 %files devel
133 %defattr(644,root,root,755)
134 %dir %{_datadir}/sip/PyKDE4
135 %{_datadir}/sip/PyKDE4/akonadi
136 %{_datadir}/sip/PyKDE4/dnssd
137 %{_datadir}/sip/PyKDE4/kdecore
138 %{_datadir}/sip/PyKDE4/kdeui
139 %{_datadir}/sip/PyKDE4/khtml
140 %{_datadir}/sip/PyKDE4/kio
141 %{_datadir}/sip/PyKDE4/knewstuff
142 %{_datadir}/sip/PyKDE4/kparts
143 %{_datadir}/sip/PyKDE4/kterminal
144 %{_datadir}/sip/PyKDE4/ktexteditor
145 %{_datadir}/sip/PyKDE4/kutils
146 %{_datadir}/sip/PyKDE4/nepomuk
147 %{_datadir}/sip/PyKDE4/phonon
148 %{_datadir}/sip/PyKDE4/plasma
149 %{_datadir}/sip/PyKDE4/polkitqt
150 %{_datadir}/sip/PyKDE4/solid
151 %{_datadir}/sip/PyKDE4/soprano
152 %{_datadir}/sip/PyKDE4/glossary.html
153
154 %files devel-tools
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_bindir}/pykdeuic4
157 %{py_sitedir}/PyQt4/uic/pykdeuic4.py*
158 %{py_sitedir}/PyQt4/uic/widget-plugins/kde4.py*
159
160 %files examples
161 %defattr(644,root,root,755)
162 %{_examplesdir}/python-PyKDE4-%{version}
This page took 0.078383 seconds and 3 git commands to generate.