]> git.pld-linux.org Git - packages/python-PyKCS11.git/blob - python-PyKCS11.spec
automatic change: use py_build/py_install macros
[packages/python-PyKCS11.git] / python-PyKCS11.spec
1 %define         rname           PyKCS11
2 #
3 Summary:        Full PKCS11 wrapper for Python
4 Name:           python-PyKCS11
5 Version:        1.2.1
6 Release:        2
7 License:        GPL
8 Group:          Libraries/Python
9 Source0:        http://downloads.sourceforge.net/pkcs11wrap/%{rname}-%{version}.tar.gz
10 # Source0-md5:  f1be0bcef765a36e4362342c5df49eef
11 URL:            http://www.bit4id.org/trac/pykcs11
12 BuildRequires:  libstdc++-devel
13 BuildRequires:  python-devel >= 1:2.5
14 BuildRequires:  rpm-pythonprov
15 %pyrequires_eq  python-modules
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 PyKCS11: a complete PKCS#11 wrapper for Python, created using the SWIG
20 compile.
21
22 %prep
23 %setup -qn %{rname}-%{version}
24 %build
25
26 %py_build
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30
31 %py_install
32
33 %py_postclean
34
35 %clean
36 rm -rf $RPM_BUILD_ROOT
37
38 %files
39 %defattr(644,root,root,755)
40 %dir %{py_sitedir}/PyKCS11
41 %{py_sitedir}/PyKCS11/*.py[co]
42 %attr(755,root,root) %{py_sitedir}/PyKCS11/*.so
43 %{py_sitedir}/*.egg-info
This page took 0.091428 seconds and 3 git commands to generate.