]> git.pld-linux.org Git - packages/python-PyGitUp.git/blob - python-PyGitUp.spec
888074c34bba60cacf1c7088cb9950a631294626
[packages/python-PyGitUp.git] / python-PyGitUp.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4
5 %define         module  PyGitUp
6 Summary:        git-up(1) -- fetch and rebase all locally-tracked remote branches
7 Name:           python-%{module}
8 Version:        1.1.5
9 Release:        2
10 License:        BSD
11 Group:          Libraries/Python
12 Source0:        https://github.com/msiemens/PyGitUp/archive/v%{version}.tar.gz?/%{module}-v%{version}.tar.gz
13 # Source0-md5:  9d271f0b1867307efbb8365ae88fe941
14 Patch0:         requirements.patch
15 URL:            https://github.com/msiemens/PyGitUp
16 BuildRequires:  rpm-pythonprov
17 # if py_postclean is used
18 BuildRequires:  rpmbuild(macros) >= 1.710
19 BuildRequires:  python-git >= 0.3.2.1
20 BuildRequires:  python-async
21 BuildRequires:  python-colorama >= 0.2.4
22 BuildRequires:  python-distribute
23 BuildRequires:  python-docopt >= 0.6.1
24 BuildRequires:  python-gitdb
25 BuildRequires:  python-nose
26 BuildRequires:  python-smmap
27 BuildRequires:  python-termcolor >= 1.1.0
28 Requires:       python-git >= 0.3.2-0.RC1.2
29 Requires:       python-async
30 Requires:       python-colorama >= 0.2.4
31 Requires:       python-docopt >= 0.6.1
32 Requires:       python-gitdb
33 Requires:       python-modules
34 Requires:       python-nose
35 Requires:       python-smmap
36 Requires:       python-termcolor >= 1.1.0
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 git-up(1) -- fetch and rebase all locally-tracked remote branches.
42
43 %prep
44 %setup -q -n %{module}-%{version}
45 %patch0 -p1
46
47 %build
48 %py_build %{?with_tests:test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %py_install
54
55 %py_postclean
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc README.rst
63 %attr(755,root,root) %{_bindir}/git-up
64 %attr(755,root,root) %{_bindir}/gitup.py
65 %dir %{py_sitescriptdir}/%{module}
66 %{py_sitescriptdir}/%{module}/*.py[co]
67 %{py_sitescriptdir}/%{module}/check-bundler.rb
68 %if "%{py_ver}" > "2.4"
69 %{py_sitescriptdir}/git_up-*.egg-info
70 %endif
This page took 0.095324 seconds and 2 git commands to generate.