]> git.pld-linux.org Git - packages/python-PyAMF.git/blob - python-PyAMF.spec
- release 2 (by relup.sh)
[packages/python-PyAMF.git] / python-PyAMF.spec
1 # TODO: Fix tests (django twisted) ?
2 # TODO: Move tests to separate package
3 #
4 # Conditional build:
5 %bcond_with     tests   # perform "make test"
6
7 %define         module  PyAMF
8 Summary:        Action Message Format (AMF) support for Python
9 Summary(pl.UTF-8):      Wsparcie dla Action Message Format (AMF)
10 Name:           python-%{module}
11 Version:        0.8.0
12 Release:        2
13 License:        MIT
14 Group:          Development/Languages/Python
15 # http://pypi.python.org/packages/source/P/PyAMF/PyAMF-0.6.1.tar.gz
16 Source0:        https://pypi.python.org/packages/a0/06/43976c0e3951b9bf7ba0d7d614a8e3e024eb5a1c6acecc9073b81c94fb52/%{module}-%{version}.tar.gz
17 # Source0-md5:  51e810531a663b55e686286edb23e82a
18 URL:            http://www.pyamf.org/index.html
19 BuildRequires:  python-devel
20 BuildRequires:  python-setuptools
21 BuildRequires:  rpm-pythonprov
22 # if py_postclean is used
23 BuildRequires:  rpmbuild(macros) >= 1.710
24 Requires:       python-modules
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 PyAMF provides Action Message Format (AMF) support for Python that is
29 compatible with the Adobe Flash Player. It includes integration with
30 Python web frameworks like Django, Pylons, Twisted, SQLAlchemy, web2py
31 and more.
32
33 %description -l pl.UTF-8
34 PyAMF dostarcza wsparcie Action Message Format (AMF) dla Pythona
35 kompatybilne z Adobe Flash Player. Integruje siÄ™ z Pythonowymi
36 framworkami www jak Django, Pylons, Twisted, SQLAlchemy, web2py i
37 inne.
38
39 %prep
40 %setup -q -n %{module}-%{version}
41
42 %build
43 %py_build
44
45 %{?with_tests:%{__python} setup.py test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 %py_install
50
51 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
52 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
53 %py_postclean
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 # %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
61 %dir %{py_sitedir}/cpyamf
62 %attr(755,root,root) %{py_sitedir}/cpyamf/*.so
63 %{py_sitedir}/cpyamf/__init__.*
64 %{py_sitedir}/pyamf
65 %if "%{py_ver}" > "2.4"
66 %{py_sitedir}/%{module}-%{version}-*.egg-info
67 %endif
This page took 0.137978 seconds and 3 git commands to generate.