]> git.pld-linux.org Git - packages/python-PasteDeploy.git/blob - python-PasteDeploy.spec
rebuild with tests and docs
[packages/python-PasteDeploy.git] / python-PasteDeploy.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5 %bcond_with     tests   # unit tests (not included in archive)
6
7 %define         module  PasteDeploy
8 Summary:        Load, configure, and compose WSGI applications and servers
9 Summary(pl.UTF-8):      Wczytywanie, konfiguracja i łączenie aplikacji i serwerów WSGI
10 Name:           python-%{module}
11 Version:        1.5.2
12 Release:        7
13 License:        MIT
14 Group:          Libraries/Python
15 #Source0Download: https://pypi.org/simple/pastedeploy/
16 Source0:        https://files.pythonhosted.org/packages/source/P/PasteDeploy/%{module}-%{version}.tar.gz
17 # Source0-md5:  352b7205c78c8de4987578d19431af3b
18 # dead
19 #URL:           http://pythonpaste.org/deploy/
20 URL:            https://pypi.org/project/PasteDeploy/
21 %if %{with python2}
22 BuildRequires:  python-devel >= 1:2.5
23 BuildRequires:  python-setuptools >= 0.6-0.a9.1
24 %if %{with tests}
25 BuildRequires:  python-nose >= 0.11
26 %endif
27 %endif
28 %if %{with python3}
29 BuildRequires:  python3-devel >= 1:3.2
30 BuildRequires:  python3-setuptools >= 0.6-0.a9.1
31 %if %{with tests}
32 BuildRequires:  python3-nose >= 0.11
33 %endif
34 %endif
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  rpmbuild(macros) >= 1.714
37 Requires:       python-Paste
38 Requires:       python-modules >= 1:2.5
39 BuildArch:      noarch
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 This tool provides code to load WSGI applications and servers from
44 URIs; these URIs can refer to Python Eggs for INI-style configuration
45 files. Paste Script provides commands to serve applications based on
46 this configuration file.
47
48 %description -l pl.UTF-8
49 To narzędzie zawiera kod do wczytywania aplikacji i serwerów WSGI z
50 URI; URI te mogą odnosić się do pakietów Python Egg dla plików
51 konfiguracyjnych w stylu INI. Paste Script udostępnia polecenia do
52 obsługi aplikacji w oparciu o ten plik konfiguracyjny.
53
54 %package -n python3-%{module}
55 Summary:        Load, configure, and compose WSGI applications and servers
56 Summary(pl.UTF-8):      Wczytywanie, konfiguracja i łączenie aplikacji i serwerów WSGI
57 Group:          Libraries/Python
58 Requires:       python3-Paste
59 Requires:       python3-modules >= 1:3.2
60
61 %description -n python3-%{module}
62 This tool provides code to load WSGI applications and servers from
63 URIs; these URIs can refer to Python Eggs for INI-style configuration
64 files. Paste Script provides commands to serve applications based on
65 this configuration file.
66
67 %description -n python3-%{module} -l pl.UTF-8
68 To narzędzie zawiera kod do wczytywania aplikacji i serwerów WSGI z
69 URI; URI te mogą odnosić się do pakietów Python Egg dla plików
70 konfiguracyjnych w stylu INI. Paste Script udostępnia polecenia do
71 obsługi aplikacji w oparciu o ten plik konfiguracyjny.
72
73 %prep
74 %setup -q -n PasteDeploy-%{version}
75
76 %build
77 %if %{with python2}
78 %py_build %{?with_tests:test}
79 %endif
80
81 %if %{with python3}
82 %py3_build %{?with_tests:test}
83 %endif
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %if %{with python2}
89 %py_install
90
91 %py_postclean
92 %endif
93
94 %if %{with python3}
95 %py3_install
96 %endif
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %if %{with python2}
102 %files
103 %defattr(644,root,root,755)
104 %doc README docs/*.txt
105 %{py_sitescriptdir}/paste/deploy
106 %{py_sitescriptdir}/PasteDeploy-%{version}-py*.egg-info
107 %{py_sitescriptdir}/PasteDeploy-%{version}-py*-nspkg.pth
108 %endif
109
110 %if %{with python3}
111 %files -n python3-%{module}
112 %defattr(644,root,root,755)
113 %doc README docs/*.txt
114 %{py3_sitescriptdir}/paste/deploy
115 %{py3_sitescriptdir}/PasteDeploy-%{version}-py*.egg-info
116 %{py3_sitescriptdir}/PasteDeploy-%{version}-py*-nspkg.pth
117 %endif
This page took 0.119186 seconds and 3 git commands to generate.