]> git.pld-linux.org Git - packages/python-Paste.git/blob - python-Paste.spec
- updated to 2.0.3 (python 3 support)
[packages/python-Paste.git] / python-Paste.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5 %bcond_without  doc     # Sphinx documentation
6 %bcond_without  tests   # unit tests
7
8 Summary:        Tools for using a Web Server Gateway Interface stack
9 Summary(pl.UTF-8):      Narzędzia do używania stosu Web Server Gateway Interface
10 Name:           python-Paste
11 Version:        2.0.3
12 Release:        1
13 Group:          Libraries/Python
14 License:        MIT
15 #Source0Download: https://pypi.org/simple/paste/
16 Source0:        https://files.pythonhosted.org/packages/source/P/Paste/Paste-%{version}.tar.gz
17 # Source0-md5:  1231e14eae62fa7ed76e9130b04bc61e
18 Patch0:         %{name}-py3.7.patch
19 # dead
20 #URL:           http://pythonpaste.org/
21 URL:            https://pypi.org/project/Paste/
22 %if %{with python2}
23 BuildRequires:  python-devel >= 1:2.6
24 BuildRequires:  python-setuptools >= 0.6-0.a9.1
25 %if %{with tests}
26 BuildRequires:  python-nose >= 0.11
27 BuildRequires:  python-six >= 1.4.0
28 %endif
29 %endif
30 %if %{with python3}
31 BuildRequires:  python3-devel >= 1:3.4
32 BuildRequires:  python3-setuptools >= 0.6-0.a9.1
33 %if %{with tests}
34 BuildRequires:  python3-nose >= 0.11
35 BuildRequires:  python3-six >= 1.4.0
36 %endif
37 %endif
38 %if %{with doc}
39 BuildRequires:  sphinx-pdg
40 %endif
41 BuildRequires:  rpm-pythonprov
42 BuildRequires:  rpmbuild(macros) >= 1.714
43 Requires:       python-modules >= 1:2.6
44 BuildArch:      noarch
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Paste provides several pieces of "middleware" (or filters) that can be
49 nested to build web applications. Each piece of middleware uses the
50 WSGI (PEP 333) interface, and should be compatible with other
51 middleware based on those interfaces.
52
53 %description -l pl.UTF-8
54 Pakiet Paste dostarcza kilka części warstwy pośredniej (lub filtrów),
55 które można osadzać w celu zbudowania aplikacji WWW. Każda część
56 warstwy pośredniej używa interfejsu WSGI (PEP 333) i powinna być
57 kompatybilna z inną warstwą pośrednią opartą na tych interfejsach.
58
59 %package -n python3-Paste
60 Summary:        Tools for using a Web Server Gateway Interface stack
61 Summary(pl.UTF-8):      Narzędzia do używania stosu Web Server Gateway Interface
62 Group:          Libraries/Python
63 Requires:       python3-modules >= 1:3.4
64
65 %description -n python3-Paste
66 Paste provides several pieces of "middleware" (or filters) that can be
67 nested to build web applications. Each piece of middleware uses the
68 WSGI (PEP 333) interface, and should be compatible with other
69 middleware based on those interfaces.
70
71 %description -n python3-Paste -l pl.UTF-8
72 Pakiet Paste dostarcza kilka części warstwy pośredniej (lub filtrów),
73 które można osadzać w celu zbudowania aplikacji WWW. Każda część
74 warstwy pośredniej używa interfejsu WSGI (PEP 333) i powinna być
75 kompatybilna z inną warstwą pośrednią opartą na tych interfejsach.
76
77 %package apidocs
78 Summary:        API documentation for Python Paste module
79 Summary(pl.UTF-8):      Dokumentacja API modułu Pythona Paste
80 Group:          Documentation
81
82 %description apidocs
83 API documentation for Python Paste module.
84
85 %description apidocs -l pl.UTF-8
86 Dokumentacja API modułu Pythona Paste.
87
88 %prep
89 %setup -q -n Paste-%{version}
90 %patch0 -p1
91
92 # junk in archive
93 %{__rm} paste/*.py.orig paste/util/*.py.orig
94 # online test + requires outdated pythonpaste.org website content
95 %{__rm} tests/test_proxy.py
96
97 %build
98 %if %{with python2}
99 %py_build %{?with_tests:test}
100 %endif
101
102 %if %{with python3}
103 %py3_build %{?with_tests:test}
104 %endif
105
106 %if %{with doc}
107 # no Makefile docs
108 cd docs
109 sphinx-build -b html . _build/html
110 %endif
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %if %{with python2}
116 %py_install
117
118 %py_postclean
119 %endif
120
121 %if %{with python3}
122 %py3_install
123 %endif
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %if %{with python2}
129 %files
130 %defattr(644,root,root,755)
131 %doc README.rst docs/{license,news}.txt
132 # paste is also top dir for other python-Paste* packages
133 %dir %{py_sitescriptdir}/paste
134 %{py_sitescriptdir}/paste/auth
135 %{py_sitescriptdir}/paste/cowbell
136 %{py_sitescriptdir}/paste/debug
137 %{py_sitescriptdir}/paste/evalexception
138 %{py_sitescriptdir}/paste/exceptions
139 %{py_sitescriptdir}/paste/util
140 %{py_sitescriptdir}/paste/*.py[co]
141 %{py_sitescriptdir}/Paste-%{version}-py*.egg-info
142 %{py_sitescriptdir}/Paste-%{version}-py*-nspkg.pth
143 %endif
144
145 %if %{with python3}
146 %files -n python3-Paste
147 %defattr(644,root,root,755)
148 %doc README.rst docs/{license,news}.txt
149 # paste is also top dir for other python3-Paste* packages
150 %dir %{py3_sitescriptdir}/paste
151 %{py3_sitescriptdir}/paste/auth
152 %{py3_sitescriptdir}/paste/cowbell
153 %{py3_sitescriptdir}/paste/debug
154 %{py3_sitescriptdir}/paste/evalexception
155 %{py3_sitescriptdir}/paste/exceptions
156 %{py3_sitescriptdir}/paste/util
157 %{py3_sitescriptdir}/paste/*.py
158 %{py3_sitescriptdir}/paste/__pycache__
159 %{py3_sitescriptdir}/Paste-%{version}-py*.egg-info
160 %{py3_sitescriptdir}/Paste-%{version}-py*-nspkg.pth
161 %endif
162
163 %if %{with doc}
164 %files apidocs
165 %defattr(644,root,root,755)
166 %doc docs/_build/html/{_static,community,download,include,modules,*.html,*.js}
167 %endif
This page took 0.066264 seconds and 3 git commands to generate.