]> git.pld-linux.org Git - packages/python-Levenshtein.git/blob - python-Levenshtein.spec
- release 5 (by relup.sh)
[packages/python-Levenshtein.git] / python-Levenshtein.spec
1 %define         pname Levenshtein
2 Summary:        Python extension computing string distances and similarities
3 Summary(pl.UTF-8):      Rozszerzenie Pythona do obliczania odległości i podobieństw łańcuchów
4 Name:           python-%{pname}
5 Version:        0.10
6 Release:        5
7 License:        GPL
8 Group:          Libraries/Python
9 Source0:        http://trific.ath.cx/Ftp//python/levenshtein/python-Levenshtein-%{version}.tar.bz2
10 # Source0-md5:  88d39338fc75090da78adf43785c71b4
11 URL:            http://trific.ath.cx/resources/python/levenshtein/
12 BuildRequires:  rpmbuild(macros) >= 1.710
13 BuildRequires:  python-devel >= 1:2.3.0
14 BuildRequires:  python-modules
15 BuildRequires:  rpm-pythonprov
16 %pyrequires_eq  python-modules
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Levenshtein computes Levenshtein distances, similarity ratios,
21 generalized medians and set medians of Strings and Unicodes. Becuase
22 it's implemented in C, it's much faster than corresponding Python
23 library functions and methods.
24
25 %description -l pl.UTF-8
26 Levenshtein oblicza odległości Levenshteina, współczynniki
27 podobieństwa, uogólnione mediany i mediany zbiorów dla wartości String
28 i Unicode. Ponieważ jest zaimplementowany w C, jest dużo szybszy od
29 odpowiadających mu funkcji bibliotecznych i metod Pythona.
30
31 %prep
32 %setup -q
33
34 %build
35 %py_build
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 %py_install
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc NEWS README
47 %attr(755,root,root) %{py_sitedir}/%{pname}.so
48 %if "%{py_ver}" > "2.4"
49 %{py_sitedir}/python_Levenshtein-*.egg-info
50 %endif
This page took 0.113471 seconds and 3 git commands to generate.