]> git.pld-linux.org Git - packages/python-ClientCookie.git/blob - python-ClientCookie.spec
BR: rpmbuild(macros) >= 1.710
[packages/python-ClientCookie.git] / python-ClientCookie.spec
1 #
2 # TODO:
3 #   - egg-info
4 %define         module  ClientCookie
5 #
6 Summary:        Python module for handling HTTP cookies on the client side
7 Summary(pl.UTF-8):      Moduł Pythona obsługi ciasteczek HTTP (cookies) po stronie klienta
8 Name:           python-%{module}
9 Version:        1.3.0
10 Release:        5
11 License:        BSD/ZPL 2.1
12 Group:          Libraries/Python
13 Source0:        http://wwwsearch.sourceforge.net/ClientCookie/src/%{module}-%{version}.tar.gz
14 # Source0-md5:  7a43e4624299b3951ae1a442194d2185
15 URL:            http://wwwsearch.sourceforge.net/ClientCookie/
16 BuildRequires:  python
17 BuildRequires:  rpmbuild(macros) >= 1.710
18 %pyrequires_eq  python-modules
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 ClientCookie is a Python module for handling HTTP cookies on the
24 client side, useful for accessing web sites that require cookies to be
25 set and then returned later. It also provides some other (optional)
26 useful stuff: HTTP-EQUIV and Refresh handling, automatic adding of the
27 Referer [sic] header and lazily-seek()able responses. These extras are
28 implemented using an extension that makes it easier to add new
29 functionality to urllib2. It has developed from a port of Gisle Aas'
30 Perl module HTTP::Cookies, from the libwww-perl library.
31
32 %description -l pl.UTF-8
33 ClientCookie jest modułem języka Python obsługującym ciasteczka HTTP
34 (cookies) po stronie klienta. Ułatwia dostęp do stron WWW wymagających
35 ustawienia oraz zwracania ciasteczek. Dodatkowo dostarcza inne
36 (opcjonalne) możliwości, takie jak: obsługa HTTP-EQUIV i Refresh,
37 automatyczne dodawanie nagłówka Referer i odpowiedzi przeszukiwane
38 z opóźnieniem. Dodatki te są zaimplementowane przy użyciu rozszerzenia,
39 ułatwiającego dodawanie nowych funkcji do urllib2. ClientCookie został
40 stworzony na podstawie modułu HTTP::Cookies dla Perla pochodzącego
41 z biblioteki libwww-perl.
42
43 %prep
44 %setup -q -n %{module}-%{version}
45
46 %build
47 %py_build
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53 %py_install
54
55 %py_postclean
56 install test/*.py $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc COPYING.txt ChangeLog.txt GeneralFAQ.html INSTALL.txt README.txt doc.html
64 %dir %{py_sitescriptdir}/%{module}
65 %{py_sitescriptdir}/%{module}/*.py[co]
66 %{_examplesdir}/%{name}-%{version}
This page took 0.044886 seconds and 3 git commands to generate.