]> git.pld-linux.org Git - packages/pylint.git/blob - pylint.spec
- up to 0.28.0
[packages/pylint.git] / pylint.spec
1 # TODO:
2 # - include examples in package
3 #
4 Summary:        Python tool that checks if a module satisfy a coding standard
5 Summary(pl.UTF-8):      Pythonowe narzędzie sprawdzające zgodność modułu ze standardem kodowania
6 Name:           pylint
7 Version:        0.28.0
8 Release:        1
9 License:        GPL
10 Group:          Development/Languages/Python
11 Source0:        https://bitbucket.org/logilab/pylint/get/%{name}-version-%{version}.tar.bz2
12 # Source0-md5:  6680efb92319ca65158b9ab5e6d26a81
13 Patch0:         %{name}-type_error.patch
14 URL:            http://www.pylint.org/
15 BuildRequires:  python-devel
16 BuildRequires:  python-modules >= 2.2.1
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.219
19 BuildRequires:  sphinx-pdg
20 %pyrequires_eq  python-modules
21 Requires:       python-logilab-astng >= 0.21.0
22 Requires:       python-logilab-common >= 0.53.0
23 Suggests:       python-devel-src
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Python tool that checks if a module satisfy a coding standard.
29
30 %description -l pl.UTF-8
31 Narzędzie sprawdzające zgodność modułów napisanych w języku Python
32 z regułami tworzenia kodu źródłowego.
33
34 %package gui
35 Summary:        GUI for pylint
36 Summary(pl.UTF-8):      Graficzny interfejs użytkownika dla pylinta
37 Group:          Development/Languages/Python
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       python-tkinter
40
41 %description gui
42 Tk based GUI for pylint.
43
44 %description gui -l pl.UTF-8
45 Oparty na bibliotece Tk graficzny interfejs użytkownika dla pylinta.
46
47 %prep
48 %setup -q -c
49 cd logilab-pylint-*
50 %patch0 -p1
51
52 %build
53 cd logilab-pylint-*
54 python setup.py build
55
56 %{__make} -C doc text
57
58 %install
59 cd logilab-pylint-*
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_mandir}/man1}
62
63 python setup.py install \
64         --optimize=2 \
65         --root=$RPM_BUILD_ROOT
66
67 install man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
68 install examples/pylintrc $RPM_BUILD_ROOT%{_sysconfdir}/pylintrc
69
70 %py_postclean
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc logilab-pylint-*/{ChangeLog,README,examples/*,doc/_build/text/*.txt}
78 %attr(755,root,root) %{_bindir}/epylint
79 %attr(755,root,root) %{_bindir}/pylint
80 %attr(755,root,root) %{_bindir}/pyreverse
81 %attr(755,root,root) %{_bindir}/symilar
82 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pylintrc
83 %{py_sitescriptdir}/pylint
84 %{py_sitescriptdir}/pylint-%{version}-py*.egg-info
85 %{_mandir}/man1/epylint.1*
86 %{_mandir}/man1/pylint.1*
87 %{_mandir}/man1/pyreverse.1*
88 %{_mandir}/man1/symilar.1*
89
90 %files gui
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_bindir}/pylint-gui
93 %{_mandir}/man1/pylint-gui.1*
This page took 0.077967 seconds and 4 git commands to generate.