]> git.pld-linux.org Git - packages/pylint.git/blob - pylint.spec
- workaround for the http://www.logilab.org/ticket/74087 bug
[packages/pylint.git] / pylint.spec
1 # TODO:
2 # - include examples in package
3 #
4 Summary:        Python tool that checks if a module satisfy a coding standard
5 Summary(pl.UTF-8):      Pythonowe narzędzie sprawdzające zgodność modułu ze standardem kodowania
6 Name:           pylint
7 Version:        0.24.0
8 Release:        2
9 License:        GPL
10 Group:          Development/Languages/Python
11 Source0:        ftp://ftp.logilab.fr/pub/pylint/%{name}-%{version}.tar.gz
12 # Source0-md5:  71df67d15f3aa1895c543b40a6955ed3
13 Patch0:         %{name}-type_error.patch
14 URL:            http://www.logilab.org/project/pylint
15 BuildRequires:  python-devel
16 BuildRequires:  python-modules >= 2.2.1
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.219
19 %pyrequires_eq  python-modules
20 Requires:       python-logilab-astng >= 0.21.0
21 Requires:       python-logilab-common >= 0.53.0
22 Suggests:       python-devel-src
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Python tool that checks if a module satisfy a coding standard.
28
29 %description -l pl.UTF-8
30 Narzędzie sprawdzające zgodność modułów napisanych w języku Python
31 z regułami tworzenia kodu źródłowego.
32
33 %package gui
34 Summary:        GUI for pylint
35 Summary(pl.UTF-8):      Graficzny interfejs użytkownika dla pylinta
36 Group:          Development/Languages/Python
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       python-tkinter
39
40 %description gui
41 Tk based GUI for pylint.
42
43 %description gui -l pl.UTF-8
44 Oparty na bibliotece Tk graficzny interfejs użytkownika dla pylinta.
45
46 %prep
47 %setup -q
48
49 %patch0 -p1
50
51 %build
52 python setup.py build
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_mandir}/man1}
57
58 python setup.py install \
59         --optimize=2 \
60         --root=$RPM_BUILD_ROOT
61
62 install man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
63 install examples/pylintrc $RPM_BUILD_ROOT%{_sysconfdir}/pylintrc
64
65 %py_postclean
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc ChangeLog README examples/* doc/*.txt
73 %attr(755,root,root) %{_bindir}/epylint
74 %attr(755,root,root) %{_bindir}/pylint
75 %attr(755,root,root) %{_bindir}/pyreverse
76 %attr(755,root,root) %{_bindir}/symilar
77 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pylintrc
78 %{py_sitescriptdir}/*
79 %{_mandir}/man1/*
80
81 %files gui
82 %defattr(644,root,root,755)
83 %attr(755,root,root) %{_bindir}/pylint-gui
This page took 0.099624 seconds and 4 git commands to generate.