]> git.pld-linux.org Git - packages/pylint.git/blob - pylint.spec
- split gui subpackage, R: python-tkinter
[packages/pylint.git] / pylint.spec
1 Summary:        Python tool that checks if a module satisfy a coding standard
2 Summary(pl):    Pythonowe narzêdzie sprawdzaj±ce zgodno¶æ modu³u ze standardem kodowania
3 Name:           pylint
4 Version:        0.8.1
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages/Python
8 Source0:        ftp://ftp.logilab.fr/pub/pylint/%{name}-%{version}.tar.gz
9 # Source0-md5:  f04addb7496a2a3e26675d36026718d7
10 URL:            http://www.logilab.org/projects/pylint/view
11 BuildRequires:  python-devel
12 BuildRequires:  python-modules >= 2.2.1
13 BuildRequires:  rpm-pythonprov
14 BuildRequires:  rpmbuild(macros) >= 1.219
15 %pyrequires_eq  python-modules
16 Requires:       python-logilab-astng >= 0.13.1
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Python tool that checks if a module satisfy a coding standard.
22
23 %description -l pl
24 Narzêdzie sprawdzaj±ce zgodno¶æ modu³ów napisanych w jêzyku Python
25 z regu³ami tworzenia kodu ¼ród³owego.
26
27 %package gui
28 Summary:        GUI for pylint
29 Summary:        Graficzny interfejs u¿ytkownika dla pylint
30 Group:          Development/Languages/Python
31 Requires:       %{name} = %{version}-%{release}
32 Requires:       python-tkinter
33
34 %description gui
35 Tk based GUI for pylint.
36
37 %description gui -l pl
38 Bazuj±cy na bibliotece Tk graficzny interfejs u¿ytkownika dla pylint.
39
40
41 %prep
42 %setup -q
43
44 %build
45 python setup.py build
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_mandir}/man1}
50
51 python setup.py install \
52         --optimize=2 \
53         --root=$RPM_BUILD_ROOT
54
55 install man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
56 tail -n 320 examples/pylintrc > $RPM_BUILD_ROOT%{_sysconfdir}/pylintrc
57
58 %py_postclean
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc ChangeLog TODO README examples/* doc/*.txt
66 %attr(755,root,root) %{_bindir}/pylint
67 %attr(755,root,root) %{_bindir}/symilar
68 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pylintrc
69 %{py_sitescriptdir}/*
70 %{_mandir}/man1/*
71
72 %files gui
73 %defattr(644,root,root,755)
74 %attr(755,root,root) %{_bindir}/pylint-gui
This page took 0.027534 seconds and 4 git commands to generate.