]> git.pld-linux.org Git - packages/pylint.git/blob - pylint.spec
- release 2
[packages/pylint.git] / pylint.spec
1 # TODO:
2 # - include examples in package
3 #
4 Summary:        Python tool that checks if a module satisfy a coding standard
5 Summary(pl.UTF-8):      Pythonowe narzędzie sprawdzające zgodność modułu ze standardem kodowania
6 Name:           pylint
7 Version:        0.21.1
8 Release:        2
9 License:        GPL
10 Group:          Development/Languages/Python
11 Source0:        ftp://ftp.logilab.fr/pub/pylint/%{name}-%{version}.tar.gz
12 # Source0-md5:  70f82198cde208b9118e81a43f3c7d80
13 URL:            http://www.logilab.org/project/pylint
14 BuildRequires:  python-devel
15 BuildRequires:  python-modules >= 2.2.1
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.219
18 %pyrequires_eq  python-modules
19 Requires:       python-logilab-astng >= 0.20.1
20 Requires:       python-logilab-common >= 0.50.1
21 Suggests:       python-devel-src
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Python tool that checks if a module satisfy a coding standard.
27
28 %description -l pl.UTF-8
29 Narzędzie sprawdzające zgodność modułów napisanych w języku Python
30 z regułami tworzenia kodu źródłowego.
31
32 %package gui
33 Summary:        GUI for pylint
34 Summary(pl.UTF-8):      Graficzny interfejs użytkownika dla pylinta
35 Group:          Development/Languages/Python
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       python-tkinter
38
39 %description gui
40 Tk based GUI for pylint.
41
42 %description gui -l pl.UTF-8
43 Oparty na bibliotece Tk graficzny interfejs użytkownika dla pylinta.
44
45 %prep
46 %setup -q
47
48 %build
49 python setup.py build
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_mandir}/man1}
54
55 python setup.py install \
56         --optimize=2 \
57         --root=$RPM_BUILD_ROOT
58
59 install man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
60 install examples/pylintrc $RPM_BUILD_ROOT%{_sysconfdir}/pylintrc
61
62 %py_postclean
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc ChangeLog README examples/* doc/*.txt
70 %attr(755,root,root) %{_bindir}/epylint
71 %attr(755,root,root) %{_bindir}/pylint
72 %attr(755,root,root) %{_bindir}/pyreverse
73 %attr(755,root,root) %{_bindir}/symilar
74 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pylintrc
75 %{py_sitescriptdir}/*
76 %{_mandir}/man1/*
77
78 %files gui
79 %defattr(644,root,root,755)
80 %attr(755,root,root) %{_bindir}/pylint-gui
This page took 0.078737 seconds and 4 git commands to generate.