]> git.pld-linux.org Git - packages/pure-ftpd.git/blob - pure-ftpd.spec
58077730cba948dabdd425e2db2552d80179a5dd
[packages/pure-ftpd.git] / pure-ftpd.spec
1 #
2 # Conditional build:
3 %bcond_with     extra           # with additional, maybe useful, but unmaintained features
4 %bcond_without  ldap            # disable LDAP auth
5 %bcond_without  longusername    # with username length = 128 (default 32)
6 %bcond_without  mysql           # disable MySQL auth but disables PAM auth
7 %bcond_without  pgsql           # disable PostgreSQL support
8 %bcond_without  puredb          # disable pure-db support
9 %bcond_without  tls             # disable SSL/TLS support
10 %bcond_without  cap             # disable capabilities
11
12 %define rel     1
13 Summary:        Small, fast and secure FTP server
14 Summary(pl.UTF-8):      Mały, szybki i bezpieczny serwer FTP
15 Name:           pure-ftpd
16 Version:        1.0.48
17 Release:        %{rel}%{?with_extra:extra}
18 License:        BSD-like%{?with_extra:, GLPv2 for pure-config due to libcfg+ license}
19 Group:          Daemons
20 Source0:        http://download.pureftpd.org/pub/pure-ftpd/releases/%{name}-%{version}.tar.bz2
21 # Source0-md5:  4538d563fb4cbe755767c91b14ed2fd2
22 Source1:        %{name}.pamd
23 Source2:        %{name}.init
24 Source3:        %{name}.sysconfig
25 Source4:        ftpusers.tar.bz2
26 # Source4-md5:  76c80b6ec9f4d079a1e27316edddbe16
27 Source5:        http://twittner.host.sk/files/pure-config/pure-config-20041201.tar.gz
28 # Source5-md5:  3f2ff6b00b5c38ee11ce588ee5af6cf6
29 Patch0:         %{name}-config.patch
30 Patch1:         %{name}-allauth.patch
31 Patch2:         %{name}-pure-pw_passwd.patch
32 Patch3:         %{name}-mysql_config.patch
33 # from Fedora
34 Patch4:         0003-Allow-having-both-options-and-config-file-on-command.patch
35 Patch5:         audit_cap.patch
36 Patch6:         %{name}-apparmor.patch
37 Patch7:         %{name}-mysql-utf8.patch
38 URL:            http://www.pureftpd.org/
39 %{?with_extra:BuildRequires:    autoconf}
40 %{?with_extra:BuildRequires:    automake}
41 BuildRequires:  libapparmor-devel
42 %{?with_cap:BuildRequires:      libcap-devel}
43 %{?with_extra:BuildRequires:    libcfg+-devel >= 0.6.2}
44 BuildRequires:  libsodium-devel
45 %{?with_mysql:BuildRequires:    mysql-devel}
46 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
47 %{?with_tls:BuildRequires:      openssl-devel}
48 BuildRequires:  pam-devel
49 %{?with_pgsql:BuildRequires:    postgresql-devel}
50 BuildRequires:  rpmbuild(macros) >= 1.304
51 Requires(post,preun):   /sbin/chkconfig
52 Requires(postun):       /usr/sbin/groupdel
53 Requires(postun):       /usr/sbin/userdel
54 Requires(pre):  /bin/id
55 Requires(pre):  /usr/bin/getgid
56 Requires(pre):  /usr/sbin/groupadd
57 Requires(pre):  /usr/sbin/useradd
58 Requires:       pam >= 0.79.0
59 %{!?with_extra:Requires:        perl-base}
60 Requires:       rc-scripts
61 Provides:       ftpserver
62 Provides:       user(ftpauth)
63 Provides:       group(ftpauth)
64 Conflicts:      man-pages < 1.51
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %define         _sysconfdir     /etc/ftpd
68 %define         _ftpdir         /home/services/ftp
69 %define         schemadir       /usr/share/openldap/schema
70
71 %description
72 Pure-FTPd is a fast, production-quality, standard-comformant FTP
73 server, based upon Troll-FTPd. Unlike other popular FTP servers, it
74 has no known security flaw, it is really trivial to set up and it is
75 especially designed for modern Linux kernels (setfsuid, sendfile,
76 capabilities) . Features include PAM support, IPv6, chroot()ed home
77 directories, virtual domains, built-in LS, anti-warez system, bounded
78 ports for passive downloads...
79
80 %description -l pl.UTF-8
81 Pure-FTPD to szybki, wysokiej jakości, odpowiadający standardom serwer
82 FTP bazujący na Troll-FTPd. W przeciwieństwie do innych serwerów FTP
83 nie ma znanych luk w bezpieczeństwie. Ponadto jest trywialny w
84 konfiguracji i specjalnie zaprojektowany dla nowych kerneli Linuksa
85 (setfsuid, sendfile, capabilibies). Możliwości to wsparcie dla PAM-a,
86 IPv6, chroot()owanych katalogów domowych, virtualne domeny, wbudowany
87 LS, system anty-warezowy, ograniczanie portów dla pasywnych
88 połączeń...
89
90 %package -n openldap-schema-pureftpd
91 Summary:        Pure-FTPd LDAP schema
92 Summary(pl.UTF-8):      Schemat LDAP dla Pure-FTPd
93 Group:          Networking/Daemons
94 Requires(post,postun):  sed >= 4.0
95 Requires:       openldap-servers
96 Requires:       sed >= 4.0
97 %if "%{_rpmversion}" >= "5"
98 BuildArch:      noarch
99 %endif
100
101 %description -n openldap-schema-pureftpd
102 This package contains an Pure-FTPd openldap schema.
103
104 %description -n openldap-schema-pureftpd -l pl.UTF-8
105 Ten pakiet zawiera schemat Pure-FTPd pureftpd.schema dla openldapa.
106
107 %prep
108 %setup -q -a 5
109 %patch0 -p0
110 %patch1 -p1
111 %patch3 -p1
112 %patch4 -p1
113 %patch5 -p1
114 %patch6 -p1
115 %patch7 -p1
116
117 %{?with_extra:%patch2 -p1}
118
119 %build
120 %{__aclocal} -Im4
121 %{__autoconf}
122 %{__autoheader}
123 %{__automake}
124 %configure \
125         CFLAGS="%{rpmcflags} %{rpmcppflags} -DALLOW_DELETION_OF_TEMPORARY_FILES=1 -DALWAYS_SHOW_RESOLVED_SYMLINKS=1" \
126         --with-boring \
127         --with-altlog \
128         --with-cookie \
129         --with-diraliases \
130         --with-extauth \
131         --with-ftpwho \
132         --with-language=english \
133         %{!?with_cap:--without-capabilities} \
134         %{?with_ldap:--with-ldap} \
135         %{?with_mysql:CPPFLAGS="-I%{_includedir}/mysql" --with-mysql} \
136         --with-pam \
137         --with-peruserlimits \
138         --with-rfc2640 \
139         %{?with_pgsql:--with-pgsql} \
140         --with-privsep \
141         %{?with_puredb:--with-puredb} \
142         --with-quotas \
143         --with-ratios \
144         --with-throttling \
145         %{?with_tls:--with-tls --with-certfile=%{_sharedstatedir}/openssl/certs/ftpd.pem} \
146         --with-uploadscript \
147         --with-virtualchroot \
148         --with-virtualhosts \
149         --with-apparmor
150
151 %if %{with extra}
152 cd pure-config
153 %{__aclocal}
154 %{__autoconf}
155 %{__autoheader}
156 %{__automake}
157 %configure
158 %{__make}
159 %endif
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163 install -d $RPM_BUILD_ROOT/etc/{pam.d,sysconfig,security,rc.d/init.d} \
164         $RPM_BUILD_ROOT{%{_sysconfdir}/vhosts,%{_ftpdir},%{schemadir}}
165
166 %{__make} install \
167         DESTDIR=$RPM_BUILD_ROOT
168
169 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/%{name}
170 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
171 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
172
173 %{?with_ldap:install pureftpd-ldap.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-ldap.conf}
174 %{?with_mysql:install pureftpd-mysql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
175 %{?with_pgsql:install pureftpd-pgsql.conf $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
176 cp -p pureftpd.schema $RPM_BUILD_ROOT%{schemadir}/pureftpd.schema
177
178 mv $RPM_BUILD_ROOT%{_sysconfdir}/{pure-ftpd,pureftpd}.conf
179
180 touch $RPM_BUILD_ROOT%{_sysconfdir}/{ftpusers,pureftpd-dir-aliases}
181
182 ln -s vhosts $RPM_BUILD_ROOT%{_sysconfdir}/pure-ftpd
183
184 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
185 rm -f $RPM_BUILD_ROOT%{_mandir}/ftpusers-path.diff
186
187 %if %{with extra}
188 %{__make} -C pure-config install \
189         DESTDIR=$RPM_BUILD_ROOT
190 %endif
191
192 %clean
193 rm -rf $RPM_BUILD_ROOT
194
195 %post
196 /sbin/chkconfig --add %{name}
197 %service %{name} restart "PureFTPD daemon"
198
199 %pre
200 %groupadd -g 326 ftpauth
201 %useradd -u 326 -d %{_ftpdir} -s /bin/false -c "FTP Auth daemon" -g ftpauth ftpauth
202
203 %preun
204 if [ "$1" = "0" ]; then
205         %service %{name} stop
206         /sbin/chkconfig --del %{name}
207 fi
208
209 %postun
210 if [ "$1" = "0" ]; then
211         %userremove ftpauth
212         %groupremove ftpauth
213 fi
214
215 %post -n openldap-schema-pureftpd
216 %openldap_schema_register %{schemadir}/pureftpd.schema -d core
217 %service -q ldap restart
218
219 %postun -n openldap-schema-pureftpd
220 if [ "$1" = "0" ]; then
221         %openldap_schema_unregister %{schemadir}/pureftpd.schema
222         %service -q ldap restart
223 fi
224
225 %triggerpostun -- %{name} < 1.0.41-2
226 %{?with_mysql:sed -i -e 's#MYSQLCrypt[\t ]\+all#MYSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-mysql.conf}
227 %{?with_pgsql:sed -i -e 's#PgSQLCrypt[\t ]\+all#PgSQLCrypt    any#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd-pgsql.conf}
228 sed -i -e 's#SSLCertFile#CertFile#gi' $RPM_BUILD_ROOT%{_sysconfdir}/pureftpd.conf
229 exit 0
230
231 %files
232 %defattr(644,root,root,755)
233 %doc AUTHORS ChangeLog COPYING FAQ HISTORY NEWS README* THANKS pure*.conf pureftpd.schema
234 %attr(755,root,root) %{_bindir}/*
235 %attr(755,root,root) %{_sbindir}/*
236 %attr(754,root,root) /etc/rc.d/init.d/%{name}
237 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/*
238 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
239 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ftpusers
240 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-dir-aliases
241 %{?with_ldap:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-ldap.conf}
242 %{?with_mysql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-mysql.conf}
243 %{?with_pgsql:%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd-pgsql.conf}
244 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pureftpd.conf
245 %attr(710,root,ftp) %dir %{_sysconfdir}
246 %dir %{_sysconfdir}/vhosts
247 %dir %{_sysconfdir}/pure-ftpd
248 %dir %{_ftpdir}
249 %{_mandir}/man?/*
250 %lang(ja) %{_mandir}/ja/man5/ftpusers*
251 %lang(pl) %{_mandir}/pl/man5/ftpusers*
252 %lang(pt_BR) %{_mandir}/pt_BR/man5/ftpusers*
253 %lang(ru) %{_mandir}/ru/man5/ftpusers*
254
255 %files -n openldap-schema-pureftpd
256 %defattr(644,root,root,755)
257 %{schemadir}/pureftpd.schema
This page took 0.040692 seconds and 2 git commands to generate.