]> git.pld-linux.org Git - packages/pulseview.git/blob - pulseview.spec
- updated to 0.4.2
[packages/pulseview.git] / pulseview.spec
1 # TODO: ENABLE_FLOW (BR: gstreamermm-devel >= 1.8.0, libsigrokflow-devel >= 0.1.0)
2 #
3 # Conditional build:
4 %bcond_with     tests   # "make test" call (requires functional libusb, i.e. accessible USB subsystem)
5 #
6 Summary:        Qt based logic analyzer GUI for sigrok
7 Summary(pl.UTF-8):      Oparty na Qt graficzny interfejs analizatora logicznego dla szkieletu sigrok
8 Name:           pulseview
9 Version:        0.4.2
10 Release:        1
11 License:        GPL v3+
12 Group:          X11/Applications/Graphics
13 Source0:        https://sigrok.org/download/source/pulseview/%{name}-%{version}.tar.gz
14 # Source0-md5:  108a5f095f06a9485d31a0349ea38243
15 URL:            https://sigrok.org/wiki/PulseView
16 BuildRequires:  Qt5Core-devel >= 5.3
17 BuildRequires:  Qt5Gui-devel >= 5.3
18 BuildRequires:  Qt5Svg-devel >= 5.3
19 BuildRequires:  Qt5Widgets-devel >= 5.3
20 BuildRequires:  boost-devel >= 1.55
21 %{?with_tests:BuildRequires:    boost-test >= 1.53}
22 BuildRequires:  cmake >= 2.8.12
23 BuildRequires:  glib2-devel >= 1:2.28.0
24 BuildRequires:  glibmm-devel >= 2.28.0
25 BuildRequires:  libsigrok-c++-devel >= 0.5.1
26 BuildRequires:  libsigrok-devel >= 0.5.1
27 BuildRequires:  libsigrokdecode-devel >= 0.5.2
28 BuildRequires:  libstdc++-devel >= 6:4.7
29 BuildRequires:  pkgconfig
30 BuildRequires:  qt5-build >= 5.3
31 BuildRequires:  qt5-linguist >= 5.3
32 BuildRequires:  qt5-qmake >= 5.3
33 Requires(post,postun):  desktop-file-utils
34 Requires(post,postun):  gtk-update-icon-cache
35 Requires:       Qt5Gui-platform-xcb
36 Requires:       glib2 >= 1:2.28.0
37 Requires:       glibmm >= 2.28.0
38 Requires:       hicolor-icon-theme
39 Requires:       libsigrok >= 0.5.1
40 Requires:       libsigrok-c++-devel >= 0.5.1
41 Requires:       libsigrokdecode >= 0.5.2
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Qt based logic analyzer GUI for sigrok.
46
47 %description -l pl.UTF-8
48 Oparty na Qt graficzny interfejs analizatora logicznego dla szkieletu
49 sigrok.
50
51 %prep
52 %setup -q
53
54 %build
55 install -d build
56 cd build
57 %cmake .. \
58         -DDISABLE_WERROR=ON \
59         %{?with_tests:-DENABLE_TESTS=ON}
60
61 %{__make}
62
63 %{?with_tests:%{__make} test}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT%{_mandir}/man1
68
69 %{__make} -C build install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post
76 %update_desktop_database
77 %update_icon_cache hicolor
78
79 %postun
80 %update_desktop_database
81 %update_icon_cache hicolor
82
83 %files
84 %defattr(644,root,root,755)
85 %doc NEWS README
86 %attr(755,root,root) %{_bindir}/pulseview
87 %{_mandir}/man1/pulseview.1*
88 %{_desktopdir}/org.sigrok.PulseView.desktop
89 %{_iconsdir}/hicolor/*x*/apps/pulseview.png
90 %{_iconsdir}/hicolor/scalable/apps/pulseview.svg
91 %{_datadir}/metainfo/org.sigrok.PulseView.appdata.xml
This page took 0.076661 seconds and 3 git commands to generate.