]> git.pld-linux.org Git - packages/pulseview.git/blob - pulseview.spec
- added qt patch (fixes build with recent Qt5)
[packages/pulseview.git] / pulseview.spec
1 # TODO: ENABLE_FLOW (BR: gstreamermm-devel >= 1.8.0, libsigrokflow-devel >= 0.1.0)
2 #
3 # Conditional build:
4 %bcond_with     tests   # "make test" call (requires functional libusb, i.e. accessible USB subsystem)
5 #
6 Summary:        Qt based logic analyzer GUI for sigrok
7 Summary(pl.UTF-8):      Oparty na Qt graficzny interfejs analizatora logicznego dla szkieletu sigrok
8 Name:           pulseview
9 Version:        0.4.2
10 Release:        1
11 License:        GPL v3+
12 Group:          X11/Applications/Graphics
13 Source0:        https://sigrok.org/download/source/pulseview/%{name}-%{version}.tar.gz
14 # Source0-md5:  108a5f095f06a9485d31a0349ea38243
15 Patch0:         %{name}-qt.patch
16 URL:            https://sigrok.org/wiki/PulseView
17 BuildRequires:  Qt5Core-devel >= 5.3
18 BuildRequires:  Qt5Gui-devel >= 5.3
19 BuildRequires:  Qt5Svg-devel >= 5.3
20 BuildRequires:  Qt5Widgets-devel >= 5.3
21 BuildRequires:  boost-devel >= 1.55
22 %{?with_tests:BuildRequires:    boost-test >= 1.53}
23 BuildRequires:  cmake >= 2.8.12
24 BuildRequires:  glib2-devel >= 1:2.28.0
25 BuildRequires:  glibmm-devel >= 2.28.0
26 BuildRequires:  libsigrok-c++-devel >= 0.5.1
27 BuildRequires:  libsigrok-devel >= 0.5.1
28 BuildRequires:  libsigrokdecode-devel >= 0.5.2
29 BuildRequires:  libstdc++-devel >= 6:4.7
30 BuildRequires:  pkgconfig
31 BuildRequires:  qt5-build >= 5.3
32 BuildRequires:  qt5-linguist >= 5.3
33 BuildRequires:  qt5-qmake >= 5.3
34 Requires(post,postun):  desktop-file-utils
35 Requires(post,postun):  gtk-update-icon-cache
36 Requires:       Qt5Gui-platform-xcb
37 Requires:       glib2 >= 1:2.28.0
38 Requires:       glibmm >= 2.28.0
39 Requires:       hicolor-icon-theme
40 Requires:       libsigrok >= 0.5.1
41 Requires:       libsigrok-c++-devel >= 0.5.1
42 Requires:       libsigrokdecode >= 0.5.2
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Qt based logic analyzer GUI for sigrok.
47
48 %description -l pl.UTF-8
49 Oparty na Qt graficzny interfejs analizatora logicznego dla szkieletu
50 sigrok.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55
56 %build
57 install -d build
58 cd build
59 %cmake .. \
60         -DDISABLE_WERROR=ON \
61         %{?with_tests:-DENABLE_TESTS=ON}
62
63 %{__make}
64
65 %{?with_tests:%{__make} test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT%{_mandir}/man1
70
71 %{__make} -C build install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post
78 %update_desktop_database
79 %update_icon_cache hicolor
80
81 %postun
82 %update_desktop_database
83 %update_icon_cache hicolor
84
85 %files
86 %defattr(644,root,root,755)
87 %doc NEWS README
88 %attr(755,root,root) %{_bindir}/pulseview
89 %{_mandir}/man1/pulseview.1*
90 %{_desktopdir}/org.sigrok.PulseView.desktop
91 %{_iconsdir}/hicolor/*x*/apps/pulseview.png
92 %{_iconsdir}/hicolor/scalable/apps/pulseview.svg
93 %{_datadir}/metainfo/org.sigrok.PulseView.appdata.xml
This page took 0.051951 seconds and 3 git commands to generate.