]> git.pld-linux.org Git - packages/pspp.git/blob - pspp.spec
c8108078d9f590bf68a5240a6bf8d6f10742f8b6
[packages/pspp.git] / pspp.spec
1 #
2 # Conditional build:
3 %bcond_without  glade   # Glade extensions for PSPP development
4 %bcond_without  perl    # Perl module
5
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        GNU PSPP - program for statistical analysis of sampled data
8 Summary(pl.UTF-8):      GNU PSPP - program do analizy statystycznej danych próbkowanych
9 Name:           pspp
10 Version:        1.0.1
11 Release:        1
12 License:        GPL v3+
13 Group:          Applications/Science
14 Source0:        http://ftp.gnu.org/gnu/pspp/%{name}-%{version}.tar.gz
15 # Source0-md5:  ac18c5da11915e59ec32fe00e541abb8
16 Patch0:         %{name}-info.patch
17 Patch1:         %{name}-perl.patch
18 Patch2:         %{name}-glade.patch
19 URL:            http://www.gnu.org/software/pspp/
20 BuildRequires:  autoconf >= 2.63
21 BuildRequires:  automake
22 BuildRequires:  cairo-devel >= 1.5
23 BuildRequires:  gettext-tools
24 BuildRequires:  glib2-devel >= 1:2.32
25 BuildRequires:  gsl-devel >= 1.13
26 BuildRequires:  gtk+3-devel >= 3.14.5
27 BuildRequires:  gtksourceview3-devel >= 3.4.2
28 %{?with_glade:BuildRequires:    glade-devel >= 3.0}
29 BuildRequires:  libtool
30 BuildRequires:  libxml2-devel >= 2.0
31 BuildRequires:  openssl-devel
32 BuildRequires:  pango-devel >= 1:1.22
33 BuildRequires:  perl-base >= 5.005_03
34 %{?with_perl:BuildRequires:     perl-devel >= 1:5.8}
35 BuildRequires:  pkgconfig
36 BuildRequires:  postgresql-devel
37 BuildRequires:  readline-devel
38 BuildRequires:  rpm-perlprov >= 4.1-13
39 BuildRequires:  texinfo
40 BuildRequires:  zlib-devel
41 Requires:       %{name}-libs = %{version}-%{release}
42 Requires:       cairo >= 1.5
43 Requires:       glib2 >= 1:2.32
44 Requires:       gtk+3 >= 3.14.5
45 Requires:       gtksourceview3 >= 3.4.2
46 Requires:       pango >= 1:1.22
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 GNU PSPP is a program for statistical analysis of sampled data. It is
51 a Free replacement for the proprietary program SPSS, and appears very
52 similar to it with a few exceptions.
53
54 %description -l pl.UTF-8
55 GNU PSPP to program do analizy statystycznej danych próbkowanych. Jest
56 to wolnodostępny zamiennik własnościowego programu SPSS; jest do niego
57 dosyć podobny z kilkoma wyjątkami.
58
59 %package libs
60 Summary:        GNU PSPP libraries and command line tools
61 Summary(pl.UTF-8):      Biblioteki GNU PSPP i narzędzia linii poleceń
62 Group:          Applications/Science
63 Requires:       gsl >= 1.13
64 Conflicts:      pspp < 0.8.5-1
65
66 %description libs
67 GNU PSP libraries command line tools.
68
69 %description libs -l pl.UTF-8
70 Biblioteki GNU PSPP i narzędzia linii poleceń.
71
72 %package -n perl-PSPP
73 Summary:        PSPP module for Perl
74 Summary(pl.UTF-8):      Moduł PSPP dla Perla
75 Group:          Development/Languages/Perl
76 Requires:       %{name}-libs = %{version}-%{release}
77
78 %description -n perl-PSPP
79 PSPP Perl module provides an interface to the libraries used by pspp
80 to read and write system files.
81
82 %description -n perl-PSPP -l pl.UTF-8
83 Moduł Perla PSPP udostępnia interfejs do bibliotek wykorzystywanych
84 przez pspp do odczytu i zapisu plików systemowych.
85
86 %package glade
87 Summary:        Glade extensions for PSPP development
88 Summary(pl.UTF-8):      Rozszerzenia Glade do rozwijania PSPP
89 Group:          X11/Development/Libraries
90 Requires:       glade >= 3.0
91
92 %description glade
93 Glade extensions for PSPP development.
94
95 %description glade -l pl.UTF-8
96 Rozszerzenia Glade do rozwijania PSPP.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101 %patch1 -p1
102 %patch2 -p1
103
104 %build
105 %{__libtoolize}
106 %{__aclocal} -I gl/m4
107 %{__autoconf}
108 %{__autoheader}
109 %{__automake}
110 %configure \
111         --disable-static \
112         %{?with_glade:--with-gui-tools} \
113         --with-openssl \
114         --with-packager="PLD Linux (http://pld-linux.org/)" \
115         %{!?with_perl:--without-perl-module}
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 %if %{with perl}
126 %{__make} -C perl-module install \
127         DESTDIR=$RPM_BUILD_ROOT
128 %endif
129
130 # API not exported
131 %{__rm} $RPM_BUILD_ROOT%{_libdir}/pspp/lib{pspp,pspp-core}.{la,so}
132 %if %{with glade}
133 # loadable module
134 %{__rm} $RPM_BUILD_ROOT%{_libdir}/glade/modules/*.la
135 %endif
136
137 %find_lang %{name}
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %files -f %{name}.lang
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/pspp
145 %attr(755,root,root) %{_bindir}/psppire
146 %{_datadir}/pspp
147 %{_datadir}/appdata/pspp.appdata.xml
148 %{_desktopdir}/pspp.desktop
149 %{_iconsdir}/hicolor/*/apps/pspp.*
150 %{_iconsdir}/hicolor/*/mimetypes/application-x-spss-*.png
151 %{_infodir}/pspp.info*
152 %{_infodir}/pspp-dev.info*
153 %{_mandir}/man1/pspp.1*
154 %{_mandir}/man1/psppire.1*
155
156 %files libs
157 %defattr(644,root,root,755)
158 %doc AUTHORS ChangeLog NEWS ONEWS README THANKS TODO
159 %attr(755,root,root) %{_bindir}/pspp-convert
160 %attr(755,root,root) %{_bindir}/pspp-dump-sav
161 %dir %{_libdir}/pspp
162 %attr(755,root,root) %{_libdir}/pspp/libpspp-%{version}.so
163 %attr(755,root,root) %{_libdir}/pspp/libpspp-core-%{version}.so
164 %{_mandir}/man1/pspp-convert.1*
165 %{_mandir}/man1/pspp-dump-sav.1*
166
167 %if %{with perl}
168 %files -n perl-PSPP
169 %defattr(644,root,root,755)
170 %{perl_vendorarch}/PSPP.pm
171 %dir %{perl_vendorarch}/auto/PSPP
172 %attr(755,root,root) %{perl_vendorarch}/auto/PSPP/PSPP.so
173 %{_mandir}/man3/PSPP.3pm*
174 %{_mandir}/man3/PSPP::Examples.3pm*
175 %endif
176
177 %if %{with glade}
178 %files glade
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/glade/modules/libglade-psppire.so
181 %{_datadir}/glade/catalogs/psppire.xml
182 %{_datadir}/glade/pixmaps/hicolor/16x16/actions/widget-psppire-psppire-*.png
183 %{_datadir}/glade/pixmaps/hicolor/22x22/actions/widget-psppire-psppire-*.png
184 %endif
This page took 0.071182 seconds and 3 git commands to generate.