]> git.pld-linux.org Git - packages/pspp.git/blob - pspp.spec
- updated to 1.6.2
[packages/pspp.git] / pspp.spec
1 #
2 # Conditional build:
3 %bcond_with     glade   # Glade extensions for PSPP development (broken in 1.4.1)
4 %bcond_without  perl    # Perl module
5
6 Summary:        GNU PSPP - program for statistical analysis of sampled data
7 Summary(pl.UTF-8):      GNU PSPP - program do analizy statystycznej danych próbkowanych
8 Name:           pspp
9 Version:        1.6.2
10 Release:        1
11 License:        GPL v3+
12 Group:          Applications/Science
13 Source0:        https://ftp.gnu.org/gnu/pspp/%{name}-%{version}.tar.gz
14 # Source0-md5:  0e2aecdf978b9de9feb94214e39185bd
15 Patch0:         %{name}-info.patch
16 Patch1:         %{name}-perl.patch
17 URL:            http://www.gnu.org/software/pspp/
18 BuildRequires:  autoconf >= 2.64
19 BuildRequires:  automake >= 1:1.14
20 BuildRequires:  cairo-devel >= 1.5
21 BuildRequires:  gettext-tools >= 0.20
22 BuildRequires:  glib2-devel >= 1:2.44
23 BuildRequires:  gsl-devel >= 1.13
24 BuildRequires:  gtk+3-devel >= 3.22.0
25 BuildRequires:  gtksourceview4-devel >= 4.0
26 %{?with_glade:BuildRequires:    glade-devel >= 3.0}
27 BuildRequires:  libtool
28 BuildRequires:  libxml2-devel >= 2.0
29 BuildRequires:  pango-devel >= 1:1.22
30 BuildRequires:  perl-base >= 5.005_03
31 %{?with_perl:BuildRequires:     perl-devel >= 1:5.8}
32 BuildRequires:  pkgconfig
33 BuildRequires:  postgresql-devel
34 BuildRequires:  python3 >= 1:3
35 BuildRequires:  readline-devel
36 BuildRequires:  rpm-perlprov >= 4.1-13
37 BuildRequires:  rpmbuild(macros) >= 1.745
38 BuildRequires:  spread-sheet-widget-devel >= 0.7
39 BuildRequires:  texinfo
40 BuildRequires:  zlib-devel
41 Requires(post,postun):  desktop-file-utils
42 Requires(post,postun):  gtk-update-icon-cache
43 Requires:       %{name}-libs = %{version}-%{release}
44 Requires:       cairo >= 1.5
45 Requires:       glib2 >= 1:2.44
46 Requires:       gtk+3 >= 3.22.0
47 Requires:       gtksourceview4 >= 4.0
48 Requires:       pango >= 1:1.22
49 Requires:       shared-mime-info
50 Requires:       spread-sheet-widget >= 0.7
51 %if %{without glade}
52 Obsoletes:      pspp-glade < 1.4.1
53 %endif
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 GNU PSPP is a program for statistical analysis of sampled data. It is
58 a Free replacement for the proprietary program SPSS, and appears very
59 similar to it with a few exceptions.
60
61 %description -l pl.UTF-8
62 GNU PSPP to program do analizy statystycznej danych próbkowanych. Jest
63 to wolnodostępny zamiennik własnościowego programu SPSS; jest do niego
64 dosyć podobny z kilkoma wyjątkami.
65
66 %package libs
67 Summary:        GNU PSPP libraries and command line tools
68 Summary(pl.UTF-8):      Biblioteki GNU PSPP i narzędzia linii poleceń
69 Group:          Applications/Science
70 Requires:       gsl >= 1.13
71 Conflicts:      pspp < 0.8.5-1
72
73 %description libs
74 GNU PSP libraries command line tools.
75
76 %description libs -l pl.UTF-8
77 Biblioteki GNU PSPP i narzędzia linii poleceń.
78
79 %package -n perl-PSPP
80 Summary:        PSPP module for Perl
81 Summary(pl.UTF-8):      Moduł PSPP dla Perla
82 Group:          Development/Languages/Perl
83 Requires:       %{name}-libs = %{version}-%{release}
84
85 %description -n perl-PSPP
86 PSPP Perl module provides an interface to the libraries used by pspp
87 to read and write system files.
88
89 %description -n perl-PSPP -l pl.UTF-8
90 Moduł Perla PSPP udostępnia interfejs do bibliotek wykorzystywanych
91 przez pspp do odczytu i zapisu plików systemowych.
92
93 %package glade
94 Summary:        Glade extensions for PSPP development
95 Summary(pl.UTF-8):      Rozszerzenia Glade do rozwijania PSPP
96 Group:          X11/Development/Libraries
97 Requires:       glade >= 3.0
98
99 %description glade
100 Glade extensions for PSPP development.
101
102 %description glade -l pl.UTF-8
103 Rozszerzenia Glade do rozwijania PSPP.
104
105 %prep
106 %setup -q
107 %patch0 -p1
108 %patch1 -p1
109
110 %build
111 %{__libtoolize}
112 %{__aclocal} -I gl/m4
113 %{__autoconf}
114 %{__autoheader}
115 %{__automake}
116 %configure \
117         --disable-static \
118         %{?with_glade:--with-gui-tools} \
119         --with-packager="PLD Linux (http://pld-linux.org/)" \
120         %{!?with_perl:--without-perl-module}
121
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 %if %{with perl}
131 %{__make} -C perl-module install \
132         DESTDIR=$RPM_BUILD_ROOT
133 %endif
134
135 # API not exported
136 %{__rm} $RPM_BUILD_ROOT%{_libdir}/pspp/lib{pspp,pspp-core}.{la,so}
137 %if %{with glade}
138 # loadable module
139 %{__rm} $RPM_BUILD_ROOT%{_libdir}/glade/modules/*.la
140 %endif
141
142 %find_lang %{name}
143
144 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post
150 %update_desktop_database
151 %update_icon_cache hicolor
152 %update_mime_database
153
154 %postun
155 %update_desktop_database
156 %update_icon_cache hicolor
157 %update_mime_database
158
159 %files -f %{name}.lang
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_bindir}/pspp
162 %attr(755,root,root) %{_bindir}/pspp-output
163 %attr(755,root,root) %{_bindir}/psppire
164 %{_datadir}/pspp
165 %{_datadir}/metainfo/org.gnu.pspp.metainfo.xml
166 %{_datadir}/mime/packages/org.gnu.pspp.xml
167 %{_desktopdir}/org.gnu.pspp.desktop
168 %{_iconsdir}/hicolor/*/apps/org.gnu.pspp.*
169 %{_iconsdir}/hicolor/*x*/mimetypes/application-x-spss-*.png
170 %{_infodir}/pspp.info*
171 %{_infodir}/pspp-dev.info*
172 %{_infodir}/pspp-figures
173 %{_infodir}/screenshots
174 %{_mandir}/man1/pspp.1*
175 %{_mandir}/man1/pspp-output.1*
176 %{_mandir}/man1/psppire.1*
177
178 %files libs
179 %defattr(644,root,root,755)
180 %doc AUTHORS ChangeLog NEWS ONEWS README THANKS
181 %attr(755,root,root) %{_bindir}/pspp-convert
182 %attr(755,root,root) %{_bindir}/pspp-dump-sav
183 %dir %{_libdir}/pspp
184 %attr(755,root,root) %{_libdir}/pspp/libpspp-%{version}.so
185 %attr(755,root,root) %{_libdir}/pspp/libpspp-core-%{version}.so
186 %{_mandir}/man1/pspp-convert.1*
187 %{_mandir}/man1/pspp-dump-sav.1*
188
189 %if %{with perl}
190 %files -n perl-PSPP
191 %defattr(644,root,root,755)
192 %{perl_vendorarch}/PSPP.pm
193 %dir %{perl_vendorarch}/auto/PSPP
194 %attr(755,root,root) %{perl_vendorarch}/auto/PSPP/PSPP.so
195 %{_mandir}/man3/PSPP.3pm*
196 %{_mandir}/man3/PSPP::Examples.3pm*
197 %endif
198
199 %if %{with glade}
200 %files glade
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/glade/modules/libglade-psppire.so
203 %{_datadir}/glade/catalogs/psppire.xml
204 %{_datadir}/glade/pixmaps/hicolor/16x16/actions/widget-psppire-psppire-*.png
205 %{_datadir}/glade/pixmaps/hicolor/22x22/actions/widget-psppire-psppire-*.png
206 %endif
This page took 0.481278 seconds and 3 git commands to generate.