]> git.pld-linux.org Git - packages/protobuf-c.git/blob - protobuf-c.spec
eb98c50a932a4148cef233f505cfc4f728d3ec01
[packages/protobuf-c.git] / protobuf-c.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build with tests
4
5 Summary:        C bindings for Google's Protocol Buffers
6 Summary(pl.UTF-8):      Wiązania C do biblioteki Google Protocol Buffers
7 Name:           protobuf-c
8 Version:        1.3.3
9 Release:        2
10 License:        Apache v2.0
11 Group:          Libraries
12 #Source0Download: https://github.com/protobuf-c/protobuf-c/releases
13 Source0:        https://github.com/protobuf-c/protobuf-c/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  16a79ce1f6e168c1b3ed41175ba57ee5
15 URL:            https://github.com/protobuf-c/protobuf-c
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  doxygen
19 BuildRequires:  libstdc++-devel >= 6:4.7
20 BuildRequires:  libtool >= 2:2
21 BuildRequires:  pkgconfig
22 BuildRequires:  protobuf-devel >= 2.6.0
23 Requires:       protobuf >= 2.6.0
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Protocol Buffers are a way of encoding structured data in an efficient
28 yet extensible format. This package provides a code generator and
29 run-time libraries to use Protocol Buffers from pure C (not C++).
30
31 It uses a modified version of protoc called protoc-c.
32
33 %description -l pl.UTF-8
34 Bufory protokołowe (Protocol Buffers) to sposób kodowania danych
35 strukturalnych w wydajny i rozszerzalny sposób. Ten pakiet dostarcza
36 generator kodu oraz biblioteki uruchomieniowe pozwalające na używanie
37 buforów protokołowych z czystego języka C (nie C++).
38
39 Wykorzystuje zmodyfikowaną wersję protoc o nazwie protoc-c.
40
41 %package devel
42 Summary:        Protocol Buffers C header files
43 Summary(pl.UTF-8):      Pliki nagłówkowe C biblioteki Protocol Buffers
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 This package contains protobuf-c header files.
49
50 %description devel -l pl.UTF-8
51 Ten pakiet zawiera pliki nagłówkowe protobuf-c.
52
53 %package static
54 Summary:        Static protobuf-c library
55 Summary(pl.UTF-8):      Statyczna biblioteka protobuf-c
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static protobuf-c library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka protobuf-c.
64
65 %prep
66 %setup -q
67
68 %build
69 %{__libtoolize}
70 %{__aclocal} -I m4
71 %{__autoconf}
72 %{__autoheader}
73 %{__automake}
74 %configure \
75         --disable-silent-rules
76
77 %{__make}
78
79 %{?with_tests:%{__make} check}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libprotobuf-c.la
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc ChangeLog LICENSE README.md TODO
97 %attr(755,root,root) %{_bindir}/protoc-c
98 %attr(755,root,root) %{_bindir}/protoc-gen-c
99 %attr(755,root,root) %{_libdir}/libprotobuf-c.so.*.*.*
100 %attr(755,root,root) %ghost %{_libdir}/libprotobuf-c.so.1
101
102 %files devel
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/libprotobuf-c.so
105 # XXX: dir shared with libtcmalloc and protobuf
106 %dir %{_includedir}/google
107 %{_includedir}/google/protobuf-c
108 %{_includedir}/protobuf-c
109 %{_pkgconfigdir}/libprotobuf-c.pc
110
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/libprotobuf-c.a
This page took 0.055864 seconds and 2 git commands to generate.