]> git.pld-linux.org Git - packages/postgis.git/blob - postgis.spec
- up to 2.1.4; fixed undefined symbol in liblwgeom
[packages/postgis.git] / postgis.spec
1 %define pg_version      %(rpm -q --queryformat '%{VERSION}' postgresql-backend-devel)
2 %define beta %{nil}
3 #
4 # Conditional build:
5 %bcond_without  raster  # disable raster support
6 %bcond_without  doc     # HTML documentation
7 %bcond_without  gui     # data import GUI
8 #
9 Summary:        Geographic Information Systems Extensions to PostgreSQL
10 Summary(pl.UTF-8):      Rozszerzenie do PostgreSQL wspomagające Geograficzne Systemy Informacyjne
11 Name:           postgis
12 Version:        2.1.4
13 Release:        1
14 License:        GPL v2+
15 Group:          Applications/Databases
16 Source0:        http://download.osgeo.org/postgis/source/%{name}-%{version}%{beta}.tar.gz
17 # Source0-md5:  6f7bacc0205859dafdfe545db1b892ca
18 URL:            http://postgis.refractions.net/
19 %{?with_raster:BuildRequires:   gdal-devel >= 1.6.0}
20 BuildRequires:  gdal-devel
21 BuildRequires:  geos-devel >= 3.3.2
22 BuildRequires:  json-c-devel
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libxml2-devel
25 BuildRequires:  perl-base
26 BuildRequires:  postgresql-backend-devel >= 8.3
27 BuildRequires:  postgresql-devel >= 8.3
28 BuildRequires:  proj-devel >= 4.5.0
29 %if %{with doc}
30 BuildRequires:  ImageMagick
31 BuildRequires:  docbook-style-xsl
32 BuildRequires:  libxml2-progs
33 BuildRequires:  libxslt-progs
34 %endif
35 %if %{with gui}
36 BuildRequires:  gtk+2-devel >= 2:2.8.0
37 BuildRequires:  pkgconfig
38 %endif
39 %{?with_raster:Requires:        gdal >= 1.6.0}
40 Requires:       liblwgeom = %{version}-%{release}
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         specflags_x86_64        -fPIC
44
45 # oh well... I also don't understand this... ;)
46
47 %description
48 This package contains a module which implements GIS simple features,
49 ties the features to rtree indexing, and provides some spatial
50 functions for accessing and analyzing geographic data.
51
52 %description -l pl.UTF-8
53 Pakiet ten zawiera moduł implementujący proste funkcje GIS, wiąże je z
54 indeksowaniem rtree oraz dostarcza funkcje dostępu oraz analizy danych
55 geograficznych.
56
57 %package gui
58 Summary:        Data import GUI for PostGIS
59 Summary(pl.UTF-8):      Graficzny interfejs użytkownika importujący dane dla PostGIS-a
60 Group:          X11/Applications
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       gtk+2 >= 2:2.8.0
63
64 %description gui
65 Data import GUI for PostGIS.
66
67 %description gui -l pl.UTF-8
68 Graficzny interfejs użytkownika importujący dane dla PostGIS-a.
69
70 %package -n liblwgeom
71 Summary:        lwgeom library (a part of PostGIS project)
72 Summary(pl.UTF-8):      Biblioteka lwgeom (część projektu PostGIS)
73 Group:          Libraries
74 Requires:       geos >= 3.3.2
75 Requires:       proj >= 4.5.0
76 Conflicts:      postgis < 2.0.0-2
77
78 %description -n liblwgeom
79 lwgeom library (a part of PostGIS project).
80
81 %description -n liblwgeom -l pl.UTF-8
82 Biblioteka lwgeom (część projektu PostGIS).
83
84 %package -n liblwgeom-devel
85 Summary:        Header file for lwgeom library
86 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki lwgeom
87 Group:          Development/Libraries
88 Requires:       geos-devel >= 3.3.2
89 Requires:       liblwgeom = %{version}-%{release}
90 Requires:       proj-devel >= 4.5.0
91
92 %description -n liblwgeom-devel
93 Header file for lwgeom library.
94
95 %description -n liblwgeom-devel -l pl.UTF-8
96 Plik nagłówkowy biblioteki lwgeom.
97
98 %package -n liblwgeom-static
99 Summary:        Static lwgeom library
100 Summary(pl.UTF-8):      Statyczna biblioteka lwgeom
101 Group:          Development/Libraries
102 Requires:       liblwgeom-devel = %{version}-%{release}
103
104 %description -n liblwgeom-static
105 Static lwgeom library.
106
107 %description -n liblwgeom-static -l pl.UTF-8
108 Statyczna biblioteka lwgeom.
109
110 %prep
111 %setup -q -n %{name}-%{version}%{beta}
112
113 %build
114 %configure \
115         --with-geos \
116         --with-geos-libdir=/usr/%{_lib} \
117         %{?with_gui:--with-gui} \
118         --with-pgsql \
119         --with-proj=%{_prefix} \
120         --with-proj-libdir=/usr/%{_lib} \
121         %{!?with_raster:--without-raster}
122
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -n liblwgeom -p /sbin/ldconfig
135 %postun -n liblwgeom -p /sbin/ldconfig
136
137 %files
138 %defattr(644,root,root,755)
139 %doc CREDITS LICENSE.TXT NEWS README.postgis TODO %{?with_doc:doc/html}
140 %attr(755,root,root) %{_bindir}/pgsql2shp
141 %attr(755,root,root) %{_bindir}/shp2pgsql
142 %attr(755,root,root) %{_libdir}/postgresql/postgis-2.1.so
143 %{_datadir}/postgresql/contrib/postgis-2.1
144 %if %{with raster}
145 %attr(755,root,root) %{_bindir}/raster2pgsql
146 %attr(755,root,root) %{_libdir}/postgresql/rtpostgis-2.1.so
147 %{_datadir}/postgresql/extension/postgis*.control
148 %{_datadir}/postgresql/extension/postgis*.sql
149 %endif
150
151 %if %{with gui}
152 %files gui
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_bindir}/shp2pgsql-gui
155 %endif
156
157 %files -n liblwgeom
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/liblwgeom-?.?.?.so
160
161 %files -n liblwgeom-devel
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/liblwgeom.so
164 %{_libdir}/liblwgeom.la
165 %{_includedir}/liblwgeom.h
166
167 %files -n liblwgeom-static
168 %defattr(644,root,root,755)
169 %{_libdir}/liblwgeom.a
This page took 0.101068 seconds and 3 git commands to generate.