]> git.pld-linux.org Git - packages/pommed.git/blob - pommed.spec
misc cosmetics
[packages/pommed.git] / pommed.spec
1 # TODO: optflags
2 #
3 # Conditional build
4 %bcond_without  gpomme  # don't build gpomme client
5
6 Summary:        pommed - Apple laptops hotkeys event handler
7 Summary(pl.UTF-8):      pommed - obsługa zdarzeń klawiszy specjalnych w laptopach Apple'a
8 Name:           pommed
9 Version:        1.39
10 Release:        1
11 License:        GPL v2
12 Group:          Applications
13 Source0:        http://alioth.debian.org/frs/download.php/3583/%{name}-%{version}.tar.gz
14 # Source0-md5:  f36757d180ed4f35fced6c096e1bcbeb
15 Source1:        %{name}.init
16 URL:            https://launchpad.net/pommed
17 BuildRequires:  alsa-lib-devel
18 BuildRequires:  audiofile-devel
19 BuildRequires:  dbus-devel
20 BuildRequires:  gettext-devel
21 BuildRequires:  libconfuse-devel
22 BuildRequires:  libsmbios-devel
23 BuildRequires:  pciutils-devel
24 BuildRequires:  rpmbuild(macros) >= 1.228
25 %if %{with gpomme}
26 BuildRequires:  gtk+2-devel
27 BuildRequires:  libglade2-devel
28 %endif
29 BuildRequires:  xorg-lib-libXpm-devel
30 Requires(post,preun):   /sbin/chkconfig
31 Requires:       alsa-lib
32 Requires:       eject
33 Requires:       pomme-client
34 Requires:       rc-scripts
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 pommed is a daemon handling the hotkeys found on the Apple laptops,
39 like the MacBook Pro, MacBook and PowerBook laptops. These hotkeys
40 control, through pommed, the LCD backlight level, the audio volume,
41 the keyboard backlight level (only on the MacBook Pro and the latest
42 PowerBook) and the CD/DVD drive ejection. Additionally, pommed
43 monitors the ambient light sensors found on the MacBook Pro and the
44 latest PowerBook to automatically light up the keyboard backlight when
45 the ambient light level gets too low.
46
47 %description -l pl.UTF-8
48 pommed to demon obsługujący klawisze specjalne w laptopach Apple'a,
49 takich jak MacBook Pro, MacBook i PowerBook. Klawisze te poprzez
50 pommeda sterują poziomem podświetlenia LCD, głośnością dźwięku,
51 poziomem podświetlenia klawiatury (tylko w MacBooku Pro i najnowszych
52 PowerBookach) oraz wysuwaniem napędu CD/DVD. Ponadto pommed monitoruje
53 czujnik światła zewnętrznego w MacBookach Pro i najnowszych
54 PowerBookach w celu automatycznego podświetlania klawiatury kiedy
55 światło zewnętrzne jest zbyt słabe.
56
57 %package -n gpomme
58 Summary:        gpomme - GTK+ graphical client for use with pommed
59 Summary(pl.UTF-8):      gpomme - graficzny klient GTK+ dla pommeda
60 Group:          X11/Applications
61 Requires:       %{name} = %{version}-%{release}
62 Provides:       pomme-client
63
64 %description -n gpomme
65 gpomme will react to signals sent by pommed over DBus when a key is
66 pressed, displaying the action taken by pommed and the current state
67 associated with this action.
68
69 %description -n gpomme -l pl.UTF-8
70 gpomme reaguje na sygnały wysyłane przez pommeda poprzez DBus przy
71 naciśnięciu klawisza, wyświetlając podejmowaną akcję i aktualny stan
72 związany z tą akcją.
73
74 %package -n wmpomme
75 Summary:        wmpomme - WindowMaker dockapp for use with pommed
76 Summary(pl.UTF-8):      wmpomme - aplet doku WindowMakera dla pommeda
77 Group:          X11/Applications
78 Requires:       %{name} = %{version}-%{release}
79 Provides:       pomme-client
80
81 %description -n wmpomme
82 wmpomme displays, as a WindowMaker dockapp, the state of the devices
83 controlled by pommed.
84
85 %description -n wmpomme -l pl.UTF-8
86 wmpomme wyświetla w postaci apletu doku WindowMakera stan urządzeń
87 sterowanych przez pommeda.
88
89 %prep
90 %setup -q
91
92 %build
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_datadir}/%{name},/etc/{dbus-1/system.d,rc.d/init.d}}
98
99 install -p pommed/pommed $RPM_BUILD_ROOT%{_sbindir}
100 cp -p pommed/data/* $RPM_BUILD_ROOT%{_datadir}/%{name}
101 cp -p pommed.conf.{mactel,pmac} $RPM_BUILD_ROOT%{_sysconfdir}
102 cp -p dbus-policy.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/pommed.conf
103 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/pommed
104 %if %{with gpomme}
105 install -d $RPM_BUILD_ROOT{%{_datadir}/gpomme/themes,%{_desktopdir}}
106 install -p gpomme/gpomme $RPM_BUILD_ROOT%{_bindir}
107 cp -a gpomme/themes/* $RPM_BUILD_ROOT%{_datadir}/gpomme/themes
108 cp -p gpomme/gpomme*.desktop $RPM_BUILD_ROOT%{_desktopdir}
109 %endif
110 install -p wmpomme/wmpomme $RPM_BUILD_ROOT%{_bindir}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post
116 /sbin/chkconfig --add %{name}
117 %service pommed restart
118
119 %preun
120 if [ "$1" = "0" ]; then
121         /sbin/chkconfig --del %{name}
122         %service pommed stop
123 fi
124
125 %files
126 %defattr(644,root,root,755)
127 %doc AUTHORS README TODO
128 %attr(755,root,root) %{_sbindir}/pommed
129 %{_datadir}/%{name}
130 %{_sysconfdir}/pommed.conf.*
131 /etc/dbus-1/system.d/pommed.conf
132 %attr(754,root,root) /etc/rc.d/init.d/pommed
133
134 %if %{with gpomme}
135 %files -n gpomme
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_bindir}/gpomme
138 %{_datadir}/gpomme
139 %{_desktopdir}/gpomme*.desktop
140 %endif
141
142 %files -n wmpomme
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/wmpomme
This page took 0.051484 seconds and 3 git commands to generate.