]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- ac-prog-libtool.patch not needed, remove completely
[packages/poldek.git] / poldek.spec
1 # TODO:
2 # - fails to build without poldek-devel - fix it !
3 #
4 # Conditional build:
5 %bcond_with     static  # don't use shared libraries
6 %bcond_without  imode   # don't build interactive mode
7 %bcond_without  python  # don't build python bindings
8
9 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
10 %if "%{pld_release}" == "ti"
11 %define ver_db  4.5.20
12 %define ver_db_rel      8
13 %else
14 %define ver_db  4.7.25
15 %define ver_db_rel      1
16 %endif
17 %define ver_rpm 4.5-49
18
19 %define         snap    rc2
20 %define         rel             3
21 Summary:        RPM packages management helper tool
22 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
23 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
24 Name:           poldek
25 Version:        0.30
26 Release:        0.%{snap}.%{rel}
27 License:        GPL v2
28 Group:          Applications/System
29 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
30 Source0:        http://carme.pld-linux.org/~cactus/snaps/poldek/%{name}-%{version}%{snap}.tar.bz2
31 # Source0-md5:  14135ae2960da09990c50d5b5342be64
32 Source1:        %{name}.conf
33 Source2:        %{name}-multilib.conf
34 Source3:        %{name}-ti.conf
35 Source4:        %{name}-multilib-ti.conf
36 Source5:        %{name}-aliases.conf
37 Source6:        %{name}.desktop
38 Source7:        %{name}.png
39 Source8:        %{name}-debuginfo.conf
40 Source9:        %{name}-aidath.conf
41 Source10:       %{name}-multilib-aidath.conf
42 Source11:       %{name}-archive.conf
43 Patch0:         %{name}-vserver-packages.patch
44 Patch1:         %{name}-config.patch
45 Patch2:         %{name}-size-type.patch
46 Patch4:         %{name}-Os-fail-workaround.patch
47 URL:            http://poldek.pld-linux.org/
48 BuildRequires:  autoconf
49 BuildRequires:  automake
50 BuildRequires:  bzip2-devel
51 BuildRequires:  check-devel
52 BuildRequires:  db-devel >= %{ver_db}-%{ver_db_rel}
53 BuildRequires:  docbook-dtd412-xml
54 BuildRequires:  gettext-devel
55 BuildRequires:  libtool
56 BuildRequires:  libxml2-devel
57 BuildRequires:  neon-devel
58 BuildRequires:  openssl-devel >= 0.9.7d
59 BuildRequires:  pcre-devel
60 BuildRequires:  pkgconfig
61 BuildRequires:  popt-devel
62 %{?with_python:BuildRequires:   python-devel}
63 BuildRequires:  readline-devel >= 5.0
64 BuildRequires:  rpm-devel >= %{ver_rpm}
65 %{?with_python:BuildRequires:   rpm-pythonprov}
66 BuildRequires:  swig-python
67 BuildRequires:  zlib-devel
68 %if %{with static}
69 BuildRequires:  bzip2-static
70 BuildRequires:  db-static >= %{ver_db}-%{ver_db_rel}
71 BuildRequires:  glibc-static
72 BuildRequires:  libselinux-static
73 BuildRequires:  libxml2-static
74 BuildRequires:  ncurses-static
75 BuildRequires:  openssl-static
76 BuildRequires:  pcre-static
77 BuildRequires:  popt-static
78 BuildRequires:  readline-static
79 BuildRequires:  rpm-static
80 BuildRequires:  zlib-static
81 %endif
82 Requires(triggerpostun):        awk
83 Requires(triggerpostun):        sed >= 4.0
84 Requires:       %{name}-libs = %{version}-%{release}
85 Requires:       db >= %{ver_db}-%{ver_db_rel}
86 Requires:       rpm >= %{ver_rpm}
87 Requires:       rpm-db-ver = %{ver_db}
88 Requires:       rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
89 # vf* scripts use sed
90 Requires:       sed
91 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93 %description
94 poldek is an RPM package management tool which allows you to easily
95 perform package verification, installation (including system
96 installation from scratch), upgrading, and removal.
97
98 Program can be used in batch (like apt-get from Debian's APT) or
99 interactive mode. The interactive mode puts you into a readline
100 interface with command line autocompletion and history, similar to the
101 shell mode of Perl's CPAN.
102
103 %{?with_static:This version is statically linked.}
104
105 %{!?with_imode:This version hasn't got interactive mode.}
106 #'vim
107
108 %description -l hu.UTF-8
109 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
110 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
111 nulláról), frissítést és eltávolítást.
112
113 A program használható parancssorból (mint a Debian apt-get programja)
114 vagy interaktív módban. Az interaktív mód egy readline környezetet
115 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
116 shell módjához.
117
118 %{?with_static:Ez a verzió statikusan linkelt.}
119
120 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
121
122 %description -l pl.UTF-8
123 poldek jest narzędziem linii poleceń służącym do weryfikacji,
124 instalacji (włączając instalację systemu od zera), aktualizacji i
125 usuwania pakietów.
126
127 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
128 interaktywnym. Tryb interaktywny posiada interfejs readline z
129 dopełnianiem komend i historią, podobny do trybu shell perlowego
130 modułu CPAN.
131
132 %{?with_static:Ta wersja jest konsolidowana statycznie.}
133
134 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
135
136 %package libs
137 Summary:        poldek libraries
138 Summary(hu.UTF-8):      A poldek könyvtárai
139 Summary(pl.UTF-8):      Biblioteki poldka
140 Group:          Libraries
141
142 %description libs
143 poldek libraries.
144
145 %description libs -l hu.UTF-8
146 A poldek könyvtárai.
147
148 %description libs -l pl.UTF-8
149 Biblioteki poldka.
150
151 %package devel
152 Summary:        Header files for poldek libraries
153 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
154 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
155 Group:          Development/Libraries
156 Requires:       %{name}-libs = %{version}-%{release}
157 Requires:       rpm-devel >= %{ver_rpm}
158
159 %description devel
160 Header files for poldek libraries.
161
162 %description devel -l hu.UTF-8
163 A poldek könyvtár fejlesztői fájljai.
164
165 %description devel -l pl.UTF-8
166 Pliki nagłówkowe bibliotek poldka.
167
168 %package static
169 Summary:        poldek static libraries
170 Summary(hu.UTF-8):      poldek statikus könyvtárak
171 Summary(pl.UTF-8):      Biblioteki statyczne poldka
172 Group:          Development/Libraries
173 Requires:       %{name}-devel = %{version}-%{release}
174
175 %description static
176 poldek static libraries.
177
178 %description static -l hu.UTF-8
179 poldek statikus könyvtárak.
180
181 %description static -l pl.UTF-8
182 Biblioteki statyczne poldka.
183
184 %package -n python-poldek
185 Summary:        Python modules for poldek
186 Summary(hu.UTF-8):      Python modulok poldek-hez
187 Summary(pl.UTF-8):      Moduły języka Python dla poldka
188 Group:          Libraries/Python
189 Requires:       %{name}-libs = %{version}-%{release}
190 %pyrequires_eq  python-libs
191
192 %description -n python-poldek
193 Python modules for poldek.
194
195 %description -n python-poldek -l hu.UTF-8
196 Python modulok poldek-hez.
197
198 %description -n python-poldek -l pl.UTF-8
199 Moduły języka Python dla poldka.
200
201 %prep
202 %setup -q
203 %patch0 -p1
204 %patch1 -p1
205 %patch2 -p1
206 %patch4 -p1
207
208 rm -f m4/libtool.m4 m4/lt*.m4
209
210 # cleanup backups after patching
211 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
212 chmod u+x ./configure ./doc/conf-xml2.sh
213
214 %build
215 %{__libtoolize}
216 %{__aclocal} -I m4
217 %{__autoheader}
218 %{__autoconf}
219 %{__automake}
220 cp -f config.sub trurlib
221
222 CPPFLAGS="-std=gnu99"
223 %configure \
224         %{?with_static:--enable-static --disable-shared} \
225         %{!?with_imode:--disable-imode} \
226         --enable-nls \
227         %{?with_python:--with-python}
228 %{__make}
229 #       --enable-trace
230
231 %install
232 rm -rf $RPM_BUILD_ROOT
233 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d
234
235 %{__make} install \
236         DESTDIR=$RPM_BUILD_ROOT
237
238 %if %{with python}
239 %{__make} -C python install \
240         DESTDIR=$RPM_BUILD_ROOT \
241         libdir=%{py_sitedir}
242 %endif
243
244 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
245
246 %ifarch i486 i686 ppc sparc alpha athlon
247         %define         _ftp_arch       %{_target_cpu}
248 %endif
249 %ifarch %{x8664}
250         %define         _ftp_arch       x86_64
251         %define         _ftp_alt_arch   i686
252 %endif
253 %ifarch i586
254         %if "%{pld_release}" == "ti"
255                 %define         _ftp_arch       i586
256         %else
257                 %define         _ftp_arch       i486
258         %endif
259 %endif
260 %ifarch pentium2 pentium3 pentium4
261         %define         _ftp_arch       i686
262 %endif
263 %ifarch sparcv9 sparc64
264         %define         _ftp_arch       sparc
265         %if "%{pld_release}" == "th"
266                 %define         _ftp_arch       %{_target_cpu}
267                 %ifarch sparc64
268                 %define         _ftp_alt_arch   sparcv9
269                 %endif
270         %endif
271 %endif
272
273 %if "%{pld_release}" == "ti"
274         %define pld_conf %{SOURCE3}
275         %ifarch %{x8664}
276                 %define pld_multilib_conf %{SOURCE4}
277         %endif
278 %endif
279
280 %if "%{pld_release}" == "th"
281         %define pld_conf %{SOURCE1}
282         %define pld_debuginfo_conf %{SOURCE8}
283         %define pld_archive_conf %{SOURCE11}
284
285         %ifarch %{x8664}
286                 %define pld_multilib_conf %{SOURCE2}
287         %endif
288
289         # aidath
290         %ifarch sparcv9 sparc64
291                 %define pld_conf %{SOURCE9}
292                 %undefine pld_archive_conf
293         %endif
294         %ifarch sparc64
295                 %define pld_multilib_conf %{SOURCE10}
296         %endif
297 %endif
298
299 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
300
301 %if 0%{?pld_multilib_conf:1}
302         sed 's|%%ARCH%%|%{_ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
303 %endif
304
305 %if 0%{?pld_debuginfo_conf:1}
306 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
307 %endif
308
309 %if 0%{?pld_archive_conf:1}
310 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
311 %endif
312
313 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
314
315 %if %{with imode}
316 # add desktop file and icon
317 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
318 cp -a %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
319 cp -a %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
320 %endif
321
322 # sources we don't package
323 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,pld,fedora,centos}-source.conf
324 # include them in %doc
325 rm -rf configs
326 cp -a conf configs
327 rm -f configs/Makefile*
328
329 %if %{with python}
330 %py_postclean
331 rm -f $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
332 %endif
333
334 %find_lang %{name}
335
336 %clean
337 rm -rf $RPM_BUILD_ROOT
338
339 %post
340 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
341 if [ "$1" = "1" ]; then
342         # remove ignore = vserver-packages inside vserver on first install
343         {
344                 while read f ctx; do
345                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
346                 done </proc/self/status
347         } 2>/dev/null
348         if [ -z "$ctx" -o "$ctx" = "0" ]; then
349                 VSERVER=no
350         else
351                 VSERVER=yes
352         fi
353         if [ "$VSERVER" = "yes" ]; then
354                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
355         fi
356 fi
357
358 %postun -p      /sbin/postshell
359 -/usr/sbin/fix-info-dir -c %{_infodir}
360
361 %post   libs -p /sbin/ldconfig
362 %postun libs -p /sbin/ldconfig
363
364 %triggerpostun -- poldek < 0.19.0-1.20050613.22.0
365 if [ -f /etc/poldek.conf.rpmsave ]; then
366         awk '/^source/ {
367         name = $3;
368         path = $4;
369         auto = "yes";
370         autoup = "yes";
371         type = "pdir";
372         pri = "";
373
374         if (sub(",noauto", "", name)) {
375                 auto = "no";
376         }
377
378         # process pri=\d+
379         if (match(name, /,pri=[0-9]+/)) {
380                 pri = substr(name, RSTART + 5, RLENGTH - 5);
381                 name = substr(name, 1, RSTART - 1) substr(name, RSTART + RLENGTH);
382         }
383
384         # skip ac sources. already in new config.
385         if (name !~ /^ac(-(ready|test|supported|updates-(general|security)))?$/) {
386                 print "";
387                 print "[source]";
388                 print "name = " name;
389                 print "type = " type;
390                 print "path = " path;
391                 print "auto = " auto;
392                 print "autoup = " autoup;
393                 if (pri) {
394                         print "pri = " pri;
395                 }
396         }
397
398         }' < /etc/poldek.conf.rpmsave >> /etc/poldek/source.conf
399         echo "Converted old custom sources from /etc/poldek.conf.rpmsave to new poldek format in /etc/poldek/source.conf"
400
401         # copy hold=
402         hold=$(grep ^hold /etc/poldek.conf.rpmsave)
403         if [ "$hold" ]; then
404                 sed -i -e "/^#hold =/s/^.*/$hold/" /etc/poldek/poldek.conf
405         fi
406 fi
407
408 %triggerpostun -- poldek < 0.30-0.20080225.00.1
409 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
410         %{__sed} -i -e '/^%%include source.conf/{
411                 a
412                 a# /etc/poldek/repos.d/*.conf
413                 a%%includedir repos.d
414         }' %{_sysconfdir}/%{name}/poldek.conf
415 fi
416
417 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
418 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
419
420 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
421         cp -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
422         cp -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
423 fi
424
425 %ifarch %{x8664}
426 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
427         cp -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
428         cp -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
429 fi
430 %endif
431
432 %files -f %{name}.lang
433 %defattr(644,root,root,755)
434 %doc ChangeLog README* NEWS TODO configs
435 %dir %{_sysconfdir}/%{name}
436 %dir %{_sysconfdir}/%{name}/repos.d
437 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
438 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
439 %attr(755,root,root) %{_bindir}/*
440 %dir %{_libdir}/%{name}
441 %attr(755,root,root) %{_libdir}/%{name}/*
442 %{_mandir}/man1/%{name}*
443 %lang(pl) %{_mandir}/pl/man1/%{name}*
444 %{_infodir}/poldek.info*
445 %if %{with imode}
446 %{_desktopdir}/%{name}.desktop
447 %{_pixmapsdir}/%{name}.png
448 %endif
449
450 %if %{without static}
451 %files libs
452 %defattr(644,root,root,755)
453 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
454 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
455 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
456 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
457 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
458 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
459 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
460 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
461 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
462 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
463 %endif
464
465 %files devel
466 %defattr(644,root,root,755)
467 %{!?with_static:%attr(755,root,root) %{_libdir}/lib*.so}
468 %{_libdir}/lib*.la
469 %{_includedir}/*
470
471 %files static
472 %defattr(644,root,root,755)
473 %{_libdir}/lib*.a
474
475 %if %{with python}
476 %files -n python-poldek
477 %defattr(644,root,root,755)
478 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
479 %{py_sitescriptdir}/poldek.py[co]
480 %{py_sitescriptdir}/poldekmod.py[co]
481 %endif
This page took 0.056924 seconds and 4 git commands to generate.