]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- up to 0.30 rc5; up to upa autoswich, gzip fix, aria2 support
[packages/poldek.git] / poldek.spec
1 # TODO:
2 # - fails to build without poldek-devel - fix it !
3 #
4 # Conditional build:
5 %bcond_with     static  # don't use shared libraries
6 %bcond_without  imode   # don't build interactive mode
7 %bcond_without  python  # don't build python bindings
8
9 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
10 %if "%{pld_release}" == "ti"
11 %define ver_db  4.5.20
12 %define ver_db_rel      8
13 %else
14 %define ver_db  4.7.25
15 %define ver_db_rel      1
16 %endif
17 %define ver_rpm 4.5-49
18
19 %define         snap    rc5
20 %define         rel     1
21 Summary:        RPM packages management helper tool
22 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
23 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
24 Name:           poldek
25 Version:        0.30
26 Release:        1.%{snap}.%{rel}
27 License:        GPL v2
28 Group:          Applications/System
29 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
30 Source0:        http://carme.pld-linux.org/~cactus/snaps/poldek/%{name}-%{version}%{snap}.tar.xz
31 # Source0-md5:  ab89926c28cfb6b7d72497fc37c16ac4
32 Source1:        %{name}.conf
33 Source2:        %{name}-multilib.conf
34 Source3:        %{name}-ti.conf
35 Source4:        %{name}-multilib-ti.conf
36 Source5:        %{name}-aliases.conf
37 Source6:        %{name}.desktop
38 Source7:        %{name}.png
39 Source8:        %{name}-debuginfo.conf
40 Source9:        %{name}-aidath.conf
41 Source10:       %{name}-multilib-aidath.conf
42 Source11:       %{name}-archive.conf
43 Patch0:         %{name}-vserver-packages.patch
44 Patch1:         %{name}-config.patch
45 Patch2:         %{name}-size-type.patch
46 Patch3:         %{name}-Os-fail-workaround.patch
47 Patch4:         %{name}-git.patch
48 URL:            http://poldek.pld-linux.org/
49 BuildRequires:  autoconf
50 BuildRequires:  automake
51 BuildRequires:  bzip2-devel
52 BuildRequires:  check-devel
53 BuildRequires:  db-devel >= %{ver_db}-%{ver_db_rel}
54 BuildRequires:  docbook-dtd412-xml
55 BuildRequires:  gettext-devel
56 BuildRequires:  libtool
57 BuildRequires:  libxml2-devel
58 BuildRequires:  neon-devel
59 BuildRequires:  openssl-devel >= 0.9.7d
60 BuildRequires:  pcre-devel
61 BuildRequires:  pkgconfig
62 BuildRequires:  popt-devel
63 %{?with_python:BuildRequires:   python-devel}
64 BuildRequires:  readline-devel >= 5.0
65 BuildRequires:  rpm-devel >= %{ver_rpm}
66 %{?with_python:BuildRequires:   rpm-pythonprov}
67 BuildRequires:  swig-python
68 BuildRequires:  zlib-devel
69 %if %{with static}
70 BuildRequires:  bzip2-static
71 BuildRequires:  db-static >= %{ver_db}-%{ver_db_rel}
72 BuildRequires:  glibc-static
73 BuildRequires:  libselinux-static
74 BuildRequires:  libxml2-static
75 BuildRequires:  ncurses-static
76 BuildRequires:  openssl-static
77 BuildRequires:  pcre-static
78 BuildRequires:  popt-static
79 BuildRequires:  readline-static
80 BuildRequires:  rpm-static
81 BuildRequires:  zlib-static
82 %endif
83 Requires(triggerpostun):        awk
84 Requires(triggerpostun):        sed >= 4.0
85 Requires:       %{name}-libs = %{version}-%{release}
86 Requires:       db >= %{ver_db}-%{ver_db_rel}
87 Requires:       rpm >= %{ver_rpm}
88 Requires:       rpm-db-ver = %{ver_db}
89 Requires:       rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
90 # vf* scripts use sed
91 Requires:       sed
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %description
95 poldek is an RPM package management tool which allows you to easily
96 perform package verification, installation (including system
97 installation from scratch), upgrading, and removal.
98
99 Program can be used in batch (like apt-get from Debian's APT) or
100 interactive mode. The interactive mode puts you into a readline
101 interface with command line autocompletion and history, similar to the
102 shell mode of Perl's CPAN.
103
104 %{?with_static:This version is statically linked.}
105
106 %{!?with_imode:This version hasn't got interactive mode.}
107 #'vim
108
109 %description -l hu.UTF-8
110 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
111 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
112 nulláról), frissítést és eltávolítást.
113
114 A program használható parancssorból (mint a Debian apt-get programja)
115 vagy interaktív módban. Az interaktív mód egy readline környezetet
116 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
117 shell módjához.
118
119 %{?with_static:Ez a verzió statikusan linkelt.}
120
121 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
122
123 %description -l pl.UTF-8
124 poldek jest narzędziem linii poleceń służącym do weryfikacji,
125 instalacji (włączając instalację systemu od zera), aktualizacji i
126 usuwania pakietów.
127
128 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
129 interaktywnym. Tryb interaktywny posiada interfejs readline z
130 dopełnianiem komend i historią, podobny do trybu shell perlowego
131 modułu CPAN.
132
133 %{?with_static:Ta wersja jest konsolidowana statycznie.}
134
135 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
136
137 %package libs
138 Summary:        poldek libraries
139 Summary(hu.UTF-8):      A poldek könyvtárai
140 Summary(pl.UTF-8):      Biblioteki poldka
141 Group:          Libraries
142
143 %description libs
144 poldek libraries.
145
146 %description libs -l hu.UTF-8
147 A poldek könyvtárai.
148
149 %description libs -l pl.UTF-8
150 Biblioteki poldka.
151
152 %package devel
153 Summary:        Header files for poldek libraries
154 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
155 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
156 Group:          Development/Libraries
157 Requires:       %{name}-libs = %{version}-%{release}
158 Requires:       rpm-devel >= %{ver_rpm}
159
160 %description devel
161 Header files for poldek libraries.
162
163 %description devel -l hu.UTF-8
164 A poldek könyvtár fejlesztői fájljai.
165
166 %description devel -l pl.UTF-8
167 Pliki nagłówkowe bibliotek poldka.
168
169 %package static
170 Summary:        poldek static libraries
171 Summary(hu.UTF-8):      poldek statikus könyvtárak
172 Summary(pl.UTF-8):      Biblioteki statyczne poldka
173 Group:          Development/Libraries
174 Requires:       %{name}-devel = %{version}-%{release}
175
176 %description static
177 poldek static libraries.
178
179 %description static -l hu.UTF-8
180 poldek statikus könyvtárak.
181
182 %description static -l pl.UTF-8
183 Biblioteki statyczne poldka.
184
185 %package -n python-poldek
186 Summary:        Python modules for poldek
187 Summary(hu.UTF-8):      Python modulok poldek-hez
188 Summary(pl.UTF-8):      Moduły języka Python dla poldka
189 Group:          Libraries/Python
190 Requires:       %{name}-libs = %{version}-%{release}
191 %pyrequires_eq  python-libs
192
193 %description -n python-poldek
194 Python modules for poldek.
195
196 %description -n python-poldek -l hu.UTF-8
197 Python modulok poldek-hez.
198
199 %description -n python-poldek -l pl.UTF-8
200 Moduły języka Python dla poldka.
201
202 %prep
203 %setup -q
204 %patch0 -p1
205 %patch1 -p1
206 %patch2 -p1
207 %patch3 -p1
208
209 rm -f m4/libtool.m4 m4/lt*.m4
210
211 # cleanup backups after patching
212 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
213 chmod u+x ./configure ./doc/conf-xml2.sh
214
215 %build
216 %{__libtoolize}
217 %{__aclocal} -I m4
218 %{__autoheader}
219 %{__autoconf}
220 %{__automake}
221 cd tndb
222 %{__libtoolize}
223 autoreconf -i
224 cd ../trurlib
225 %{__libtoolize}
226 autoreconf -i
227 cd ..
228
229 CPPFLAGS="-std=gnu99"
230 %configure \
231         %{?with_static:--enable-static --disable-shared} \
232         %{!?with_imode:--disable-imode} \
233         --enable-nls \
234         %{?with_python:--with-python}
235 %{__make}
236 #       --enable-trace
237
238 %install
239 rm -rf $RPM_BUILD_ROOT
240 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name}/repos.d,/var/cache/%{name}}
241
242 %{__make} install \
243         DESTDIR=$RPM_BUILD_ROOT
244
245 %if %{with python}
246 %{__make} -C python install \
247         DESTDIR=$RPM_BUILD_ROOT \
248         libdir=%{py_sitedir}
249 %endif
250
251 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
252
253 %ifarch i486 i686 ppc sparc alpha athlon
254         %define         _ftp_arch       %{_target_cpu}
255 %endif
256 %ifarch %{x8664}
257         %define         _ftp_arch       x86_64
258         %define         _ftp_alt_arch   i686
259 %endif
260 %ifarch i586
261         %if "%{pld_release}" == "ti"
262                 %define         _ftp_arch       i586
263         %else
264                 %define         _ftp_arch       i486
265         %endif
266 %endif
267 %ifarch pentium2 pentium3 pentium4
268         %define         _ftp_arch       i686
269 %endif
270 %ifarch sparcv9 sparc64
271         %define         _ftp_arch       sparc
272         %if "%{pld_release}" == "th"
273                 %define         _ftp_arch       %{_target_cpu}
274                 %ifarch sparc64
275                 %define         _ftp_alt_arch   sparcv9
276                 %endif
277         %endif
278 %endif
279
280 %if "%{pld_release}" == "ti"
281         %define pld_conf %{SOURCE3}
282         %ifarch %{x8664}
283                 %define pld_multilib_conf %{SOURCE4}
284         %endif
285 %endif
286
287 %if "%{pld_release}" == "th"
288         %define pld_conf %{SOURCE1}
289         %define pld_debuginfo_conf %{SOURCE8}
290         %define pld_archive_conf %{SOURCE11}
291
292         %ifarch %{x8664}
293                 %define pld_multilib_conf %{SOURCE2}
294         %endif
295
296         # aidath
297         %ifarch sparcv9 sparc64
298                 %define pld_conf %{SOURCE9}
299                 %undefine pld_archive_conf
300         %endif
301         %ifarch sparc64
302                 %define pld_multilib_conf %{SOURCE10}
303         %endif
304 %endif
305
306 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
307
308 %if 0%{?pld_multilib_conf:1}
309         sed 's|%%ARCH%%|%{_ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
310 %endif
311
312 %if 0%{?pld_debuginfo_conf:1}
313 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
314 %endif
315
316 %if 0%{?pld_archive_conf:1}
317 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
318 %endif
319
320 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
321
322 %if %{with imode}
323 # add desktop file and icon
324 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
325 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
326 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
327 %endif
328
329 # sources we don't package
330 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,pld,fedora,centos}-source.conf
331 # include them in %doc
332 rm -rf configs
333 cp -a conf configs
334 rm -f configs/Makefile*
335
336 %if %{with python}
337 %py_postclean
338 rm -f $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
339 %endif
340
341 %find_lang %{name}
342
343 %clean
344 rm -rf $RPM_BUILD_ROOT
345
346 %post
347 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
348 if [ "$1" = "1" ]; then
349         # remove ignore = vserver-packages inside vserver on first install
350         {
351                 while read f ctx; do
352                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
353                 done </proc/self/status
354         } 2>/dev/null
355         if [ -z "$ctx" -o "$ctx" = "0" ]; then
356                 VSERVER=no
357         else
358                 VSERVER=yes
359         fi
360         if [ "$VSERVER" = "yes" ]; then
361                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
362         fi
363 fi
364
365 %postun -p      /sbin/postshell
366 -/usr/sbin/fix-info-dir -c %{_infodir}
367
368 %post   libs -p /sbin/ldconfig
369 %postun libs -p /sbin/ldconfig
370
371 %triggerpostun -- poldek < 0.19.0-1.20050613.22.0
372 if [ -f /etc/poldek.conf.rpmsave ]; then
373         awk '/^source/ {
374         name = $3;
375         path = $4;
376         auto = "yes";
377         autoup = "yes";
378         type = "pdir";
379         pri = "";
380
381         if (sub(",noauto", "", name)) {
382                 auto = "no";
383         }
384
385         # process pri=\d+
386         if (match(name, /,pri=[0-9]+/)) {
387                 pri = substr(name, RSTART + 5, RLENGTH - 5);
388                 name = substr(name, 1, RSTART - 1) substr(name, RSTART + RLENGTH);
389         }
390
391         # skip ac sources. already in new config.
392         if (name !~ /^ac(-(ready|test|supported|updates-(general|security)))?$/) {
393                 print "";
394                 print "[source]";
395                 print "name = " name;
396                 print "type = " type;
397                 print "path = " path;
398                 print "auto = " auto;
399                 print "autoup = " autoup;
400                 if (pri) {
401                         print "pri = " pri;
402                 }
403         }
404
405         }' < /etc/poldek.conf.rpmsave >> /etc/poldek/source.conf
406         echo "Converted old custom sources from /etc/poldek.conf.rpmsave to new poldek format in /etc/poldek/source.conf"
407
408         # copy hold=
409         hold=$(grep ^hold /etc/poldek.conf.rpmsave)
410         if [ "$hold" ]; then
411                 sed -i -e "/^#hold =/s/^.*/$hold/" /etc/poldek/poldek.conf
412         fi
413 fi
414
415 %triggerpostun -- poldek < 0.30-0.20080225.00.1
416 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
417         %{__sed} -i -e '/^%%include source.conf/{
418                 a
419                 a# /etc/poldek/repos.d/*.conf
420                 a%%includedir repos.d
421         }' %{_sysconfdir}/%{name}/poldek.conf
422 fi
423
424 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
425 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
426
427 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
428         cp -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
429         cp -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
430 fi
431
432 %ifarch %{x8664}
433 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
434         cp -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
435         cp -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
436 fi
437 %endif
438
439 %files -f %{name}.lang
440 %defattr(644,root,root,755)
441 %doc ChangeLog README* NEWS TODO configs
442 %dir %{_sysconfdir}/%{name}
443 %dir %{_sysconfdir}/%{name}/repos.d
444 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
445 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
446 %attr(755,root,root) %{_bindir}/*
447 %dir %{_libdir}/%{name}
448 %attr(755,root,root) %{_libdir}/%{name}/*
449 %{_mandir}/man1/%{name}*
450 %lang(pl) %{_mandir}/pl/man1/%{name}*
451 %{_infodir}/poldek.info*
452 %if %{with imode}
453 %{_desktopdir}/%{name}.desktop
454 %{_pixmapsdir}/%{name}.png
455 %endif
456 %dir /var/cache/%{name}
457
458 %if %{without static}
459 %files libs
460 %defattr(644,root,root,755)
461 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
462 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
463 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
464 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
465 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
466 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
467 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
468 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
469 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
470 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
471 %endif
472
473 %files devel
474 %defattr(644,root,root,755)
475 %{!?with_static:%attr(755,root,root) %{_libdir}/lib*.so}
476 %{_libdir}/lib*.la
477 %{_includedir}/*
478
479 %files static
480 %defattr(644,root,root,755)
481 %{_libdir}/lib*.a
482
483 %if %{with python}
484 %files -n python-poldek
485 %defattr(644,root,root,755)
486 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
487 %{py_sitescriptdir}/poldek.py[co]
488 %{py_sitescriptdir}/poldekmod.py[co]
489 %endif
This page took 0.0604 seconds and 4 git commands to generate.