]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- removed outdated todo
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_without  python  # don't build python bindings
6
7 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
8 %if "%{pld_release}" == "ti"
9 %define ver_db  4.5.20
10 %define ver_db_rel      8
11 %else
12 %define ver_db  4.7.25
13 %define ver_db_rel      1
14 %endif
15 %define ver_rpm 4.5-49
16
17 %define         snap    rc5
18 %define         rel     11
19 Summary:        RPM packages management helper tool
20 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
21 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
22 Name:           poldek
23 Version:        0.30
24 Release:        1.%{snap}.%{rel}
25 License:        GPL v2
26 Group:          Applications/System
27 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
28 Source0:        http://carme.pld-linux.org/~cactus/snaps/poldek/%{name}-%{version}%{snap}.tar.xz
29 # Source0-md5:  ab89926c28cfb6b7d72497fc37c16ac4
30 Source1:        %{name}.conf
31 Source2:        %{name}-multilib.conf
32 Source3:        %{name}-ti.conf
33 Source4:        %{name}-multilib-ti.conf
34 Source5:        %{name}-aliases.conf
35 Source6:        %{name}.desktop
36 Source7:        %{name}.png
37 Source8:        %{name}-debuginfo.conf
38 Source9:        %{name}-aidath.conf
39 Source10:       %{name}-multilib-aidath.conf
40 Source11:       %{name}-archive.conf
41 Patch0:         %{name}-vserver-packages.patch
42 Patch1:         %{name}-config.patch
43 Patch2:         %{name}-size-type.patch
44 Patch3:         %{name}-Os-fail-workaround.patch
45 Patch4:         %{name}-git.patch
46 Patch5:         %{name}-am.patch
47 URL:            http://poldek.pld-linux.org/
48 BuildRequires:  autoconf
49 BuildRequires:  automake
50 BuildRequires:  bzip2-devel
51 BuildRequires:  check-devel
52 BuildRequires:  db-devel >= %{ver_db}-%{ver_db_rel}
53 BuildRequires:  docbook-dtd412-xml
54 BuildRequires:  gettext-devel
55 BuildRequires:  libtool
56 BuildRequires:  libxml2-devel
57 BuildRequires:  neon-devel
58 BuildRequires:  openssl-devel >= 0.9.7d
59 BuildRequires:  pcre-devel
60 BuildRequires:  pkgconfig
61 BuildRequires:  popt-devel
62 %{?with_python:BuildRequires:   python-devel}
63 BuildRequires:  readline-devel >= 5.0
64 BuildRequires:  rpm-devel >= %{ver_rpm}
65 %{?with_python:BuildRequires:   rpm-pythonprov}
66 BuildRequires:  swig-python
67 BuildRequires:  xmlto
68 BuildRequires:  zlib-devel
69 %if %{with static}
70 BuildRequires:  bzip2-static
71 BuildRequires:  db-static >= %{ver_db}-%{ver_db_rel}
72 BuildRequires:  glibc-static
73 BuildRequires:  libselinux-static
74 BuildRequires:  libxml2-static
75 BuildRequires:  ncurses-static
76 BuildRequires:  openssl-static
77 BuildRequires:  pcre-static
78 BuildRequires:  popt-static
79 BuildRequires:  readline-static
80 BuildRequires:  rpm-static
81 BuildRequires:  zlib-static
82 %endif
83 Requires(triggerpostun):        awk
84 Requires(triggerpostun):        sed >= 4.0
85 Requires:       %{name}-libs = %{version}-%{release}
86 Requires:       db >= %{ver_db}-%{ver_db_rel}
87 Requires:       rpm >= %{ver_rpm}
88 Requires:       rpm-db-ver = %{ver_db}
89 Requires:       rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
90 # vf* scripts use sed
91 Requires:       sed
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %description
95 poldek is an RPM package management tool which allows you to easily
96 perform package verification, installation (including system
97 installation from scratch), upgrading, and removal.
98
99 Program can be used in batch (like apt-get from Debian's APT) or
100 interactive mode. The interactive mode puts you into a readline
101 interface with command line autocompletion and history, similar to the
102 shell mode of Perl's CPAN.
103
104 %{?with_static:This version is statically linked.}
105
106 %{!?with_imode:This version hasn't got interactive mode.}
107 #'vim
108
109 %description -l hu.UTF-8
110 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
111 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
112 nulláról), frissítést és eltávolítást.
113
114 A program használható parancssorból (mint a Debian apt-get programja)
115 vagy interaktív módban. Az interaktív mód egy readline környezetet
116 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
117 shell módjához.
118
119 %{?with_static:Ez a verzió statikusan linkelt.}
120
121 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
122
123 %description -l pl.UTF-8
124 poldek jest narzędziem linii poleceń służącym do weryfikacji,
125 instalacji (włączając instalację systemu od zera), aktualizacji i
126 usuwania pakietów.
127
128 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
129 interaktywnym. Tryb interaktywny posiada interfejs readline z
130 dopełnianiem komend i historią, podobny do trybu shell perlowego
131 modułu CPAN.
132
133 %{?with_static:Ta wersja jest konsolidowana statycznie.}
134
135 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
136
137 %package libs
138 Summary:        poldek libraries
139 Summary(hu.UTF-8):      A poldek könyvtárai
140 Summary(pl.UTF-8):      Biblioteki poldka
141 Group:          Libraries
142
143 %description libs
144 poldek libraries.
145
146 %description libs -l hu.UTF-8
147 A poldek könyvtárai.
148
149 %description libs -l pl.UTF-8
150 Biblioteki poldka.
151
152 %package devel
153 Summary:        Header files for poldek libraries
154 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
155 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
156 Group:          Development/Libraries
157 Requires:       %{name}-libs = %{version}-%{release}
158 Requires:       rpm-devel >= %{ver_rpm}
159
160 %description devel
161 Header files for poldek libraries.
162
163 %description devel -l hu.UTF-8
164 A poldek könyvtár fejlesztői fájljai.
165
166 %description devel -l pl.UTF-8
167 Pliki nagłówkowe bibliotek poldka.
168
169 %package static
170 Summary:        poldek static libraries
171 Summary(hu.UTF-8):      poldek statikus könyvtárak
172 Summary(pl.UTF-8):      Biblioteki statyczne poldka
173 Group:          Development/Libraries
174 Requires:       %{name}-devel = %{version}-%{release}
175
176 %description static
177 poldek static libraries.
178
179 %description static -l hu.UTF-8
180 poldek statikus könyvtárak.
181
182 %description static -l pl.UTF-8
183 Biblioteki statyczne poldka.
184
185 %package -n python-poldek
186 Summary:        Python modules for poldek
187 Summary(hu.UTF-8):      Python modulok poldek-hez
188 Summary(pl.UTF-8):      Moduły języka Python dla poldka
189 Group:          Libraries/Python
190 Requires:       %{name}-libs = %{version}-%{release}
191 %pyrequires_eq  python-libs
192
193 %description -n python-poldek
194 Python modules for poldek.
195
196 %description -n python-poldek -l hu.UTF-8
197 Python modulok poldek-hez.
198
199 %description -n python-poldek -l pl.UTF-8
200 Moduły języka Python dla poldka.
201
202 %prep
203 %setup -q
204 %patch0 -p1
205 %patch1 -p1
206 %patch2 -p1
207 %patch3 -p1
208 %patch4 -p1
209 %patch5 -p1
210
211 %{__rm} m4/libtool.m4 m4/lt*.m4
212
213 # cleanup backups after patching
214 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
215 chmod u+x ./configure ./doc/conf-xml2.sh
216
217 %build
218 %{__libtoolize}
219 %{__aclocal} -I m4
220 %{__autoheader}
221 %{__autoconf}
222 %{__automake}
223 cd tndb
224 %{__libtoolize}
225 %{__aclocal}
226 %{__autoheader}
227 %{__autoconf}
228 %{__automake}
229 cd ../trurlib
230 %{__libtoolize}
231 %{__aclocal}
232 %{__autoheader}
233 %{__autoconf}
234 %{__automake}
235 cd ..
236
237 CPPFLAGS="%{rpmcppflags} -std=gnu99"
238 %configure \
239         %{?with_static:--enable-static --disable-shared} \
240         %{!?with_imode:--disable-imode} \
241         --enable-nls \
242         %{?with_python:--with-python}
243 %{__make} -j1
244 #       --enable-trace
245
246 %install
247 rm -rf $RPM_BUILD_ROOT
248 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name}/repos.d,/var/cache/%{name}}
249
250 %{__make} install -j1 \
251         DESTDIR=$RPM_BUILD_ROOT
252
253 %if %{with python}
254 %{__make} -C python -j1 install \
255         DESTDIR=$RPM_BUILD_ROOT \
256         libdir=%{py_sitedir}
257 %endif
258
259 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
260
261 %ifarch i486 i686 ppc sparc alpha athlon
262         %define         _ftp_arch       %{_target_cpu}
263 %endif
264 %ifarch %{x8664}
265         %define         _ftp_arch       x86_64
266         %define         _ftp_alt_arch   i686
267 %endif
268 %ifarch i586
269         %if "%{pld_release}" == "ti"
270                 %define         _ftp_arch       i586
271         %else
272                 %define         _ftp_arch       i486
273         %endif
274 %endif
275 %ifarch pentium2 pentium3 pentium4
276         %define         _ftp_arch       i686
277 %endif
278 %ifarch sparcv9 sparc64
279         %define         _ftp_arch       sparc
280         %if "%{pld_release}" == "th"
281                 %define         _ftp_arch       %{_target_cpu}
282                 %ifarch sparc64
283                 %define         _ftp_alt_arch   sparcv9
284                 %endif
285         %endif
286 %endif
287
288 %if "%{pld_release}" == "ti"
289         %define pld_conf %{SOURCE3}
290         %ifarch %{x8664}
291                 %define pld_multilib_conf %{SOURCE4}
292         %endif
293 %endif
294
295 %if "%{pld_release}" == "th"
296         %define pld_conf %{SOURCE1}
297         %define pld_debuginfo_conf %{SOURCE8}
298         %define pld_archive_conf %{SOURCE11}
299
300         %ifarch %{x8664}
301                 %define pld_multilib_conf %{SOURCE2}
302         %endif
303
304         # aidath
305         %ifarch sparcv9 sparc64
306                 %define pld_conf %{SOURCE9}
307                 %undefine pld_archive_conf
308         %endif
309         %ifarch sparc64
310                 %define pld_multilib_conf %{SOURCE10}
311         %endif
312 %endif
313
314 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
315
316 %if 0%{?pld_multilib_conf:1}
317         sed 's|%%ARCH%%|%{_ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
318 %endif
319
320 %if 0%{?pld_debuginfo_conf:1}
321 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
322 %endif
323
324 %if 0%{?pld_archive_conf:1}
325 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
326 %endif
327
328 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
329
330 %if %{with imode}
331 # add desktop file and icon
332 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
333 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
334 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
335 %endif
336
337 # sources we don't package
338 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
339 # include them in %doc
340 rm -rf configs
341 cp -a conf configs
342 rm -f configs/Makefile*
343
344 %if %{with python}
345 %py_postclean
346 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
347 %endif
348
349 %find_lang %{name}
350
351 %clean
352 rm -rf $RPM_BUILD_ROOT
353
354 %post
355 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
356 if [ "$1" = "1" ]; then
357         # remove ignore = vserver-packages inside vserver on first install
358         {
359                 while read f ctx; do
360                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
361                 done </proc/self/status
362         } 2>/dev/null
363         if [ -z "$ctx" -o "$ctx" = "0" ]; then
364                 VSERVER=no
365         else
366                 VSERVER=yes
367         fi
368         if [ "$VSERVER" = "yes" ]; then
369                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
370         fi
371 fi
372
373 %postun -p      /sbin/postshell
374 -/usr/sbin/fix-info-dir -c %{_infodir}
375
376 %post   libs -p /sbin/ldconfig
377 %postun libs -p /sbin/ldconfig
378
379 %triggerpostun -- poldek < 0.19.0-1.20050613.22.0
380 if [ -f /etc/poldek.conf.rpmsave ]; then
381         awk '/^source/ {
382         name = $3;
383         path = $4;
384         auto = "yes";
385         autoup = "yes";
386         type = "pdir";
387         pri = "";
388
389         if (sub(",noauto", "", name)) {
390                 auto = "no";
391         }
392
393         # process pri=\d+
394         if (match(name, /,pri=[0-9]+/)) {
395                 pri = substr(name, RSTART + 5, RLENGTH - 5);
396                 name = substr(name, 1, RSTART - 1) substr(name, RSTART + RLENGTH);
397         }
398
399         # skip ac sources. already in new config.
400         if (name !~ /^ac(-(ready|test|supported|updates-(general|security)))?$/) {
401                 print "";
402                 print "[source]";
403                 print "name = " name;
404                 print "type = " type;
405                 print "path = " path;
406                 print "auto = " auto;
407                 print "autoup = " autoup;
408                 if (pri) {
409                         print "pri = " pri;
410                 }
411         }
412
413         }' < /etc/poldek.conf.rpmsave >> /etc/poldek/source.conf
414         echo "Converted old custom sources from /etc/poldek.conf.rpmsave to new poldek format in /etc/poldek/source.conf"
415
416         # copy hold=
417         hold=$(grep ^hold /etc/poldek.conf.rpmsave)
418         if [ "$hold" ]; then
419                 sed -i -e "/^#hold =/s/^.*/$hold/" /etc/poldek/poldek.conf
420         fi
421 fi
422
423 %triggerpostun -- poldek < 0.30-0.20080225.00.1
424 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
425         %{__sed} -i -e '/^%%include source.conf/{
426                 a
427                 a# /etc/poldek/repos.d/*.conf
428                 a%%includedir repos.d
429         }' %{_sysconfdir}/%{name}/poldek.conf
430 fi
431
432 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
433 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
434
435 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
436         cp -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
437         cp -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
438 fi
439
440 %ifarch %{x8664}
441 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
442         cp -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
443         cp -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
444 fi
445 %endif
446
447 %files -f %{name}.lang
448 %defattr(644,root,root,755)
449 %doc ChangeLog README* NEWS TODO configs
450 %dir %{_sysconfdir}/%{name}
451 %dir %{_sysconfdir}/%{name}/repos.d
452 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
453 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
454 %attr(755,root,root) %{_bindir}/ipoldek
455 %attr(755,root,root) %{_bindir}/poldek
456 %attr(755,root,root) %{_bindir}/rpmvercmp
457 %dir %{_libdir}/%{name}
458 %attr(755,root,root) %{_libdir}/%{name}/*
459 %{_mandir}/man1/%{name}*.1*
460 %lang(pl) %{_mandir}/pl/man1/%{name}*
461 %{_infodir}/poldek.info*
462 %if %{with imode}
463 %{_desktopdir}/%{name}.desktop
464 %{_pixmapsdir}/%{name}.png
465 %endif
466 %dir /var/cache/%{name}
467
468 %if %{without static}
469 %files libs
470 %defattr(644,root,root,755)
471 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
472 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
473 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
474 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
475 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
476 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
477 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
478 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
479 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
480 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
481 %endif
482
483 %files devel
484 %defattr(644,root,root,755)
485 %if %{without static}
486 %attr(755,root,root) %{_libdir}/libpoclidek.so
487 %attr(755,root,root) %{_libdir}/libpoldek.so
488 %attr(755,root,root) %{_libdir}/libtndb.so
489 %attr(755,root,root) %{_libdir}/libtrurl.so
490 %attr(755,root,root) %{_libdir}/libvfile.so
491 %endif
492 %{_libdir}/libpoclidek.la
493 %{_libdir}/libpoldek.la
494 %{_libdir}/libtndb.la
495 %{_libdir}/libtrurl.la
496 %{_libdir}/libvfile.la
497 %{_includedir}/poldek
498 %{_includedir}/tndb
499 %{_includedir}/trurl
500 %{_includedir}/vfile
501 %{_pkgconfigdir}/tndb.pc
502
503 %files static
504 %defattr(644,root,root,755)
505 %{_libdir}/libtndb.a
506 %{_libdir}/libtrurl.a
507
508 %if %{with python}
509 %files -n python-poldek
510 %defattr(644,root,root,755)
511 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
512 %{py_sitescriptdir}/poldek.py[co]
513 %{py_sitescriptdir}/poldekmod.py[co]
514 %endif
This page took 0.056665 seconds and 4 git commands to generate.