]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- rpm5 also needs librpmio
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_without  python  # don't build python bindings
6 %bcond_with     snap    # install configs for official Th snapshot
7
8 # current snapshot name
9 %define         SNAP    2012
10
11 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
12 %define         ver_db          5.3
13 %define         ver_db_rel      1
14 %define         ver_rpm         5.4.10
15
16 %define         snap    rc6
17 %define         rel     0.1%{?with_snap:.%{SNAP}}
18 Summary:        RPM packages management helper tool
19 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
20 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
21 Name:           poldek
22 Version:        0.30
23 Release:        1.%{snap}.%{rel}
24 License:        GPL v2
25 Group:          Applications/System
26 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
27 Source0:        http://carme.pld-linux.org/~megabajt/snaps/poldek/%{name}-%{version}%{snap}.tar.xz
28 # Source0-md5:  4b528ad356b02efdd72b81f1ecaceb83
29 Source1:        %{name}.conf
30 Source2:        %{name}-multilib.conf
31 Source5:        %{name}-aliases.conf
32 Source6:        %{name}.desktop
33 Source7:        %{name}.png
34 Source8:        %{name}-debuginfo.conf
35 Source9:        %{name}-aidath.conf
36 Source10:       %{name}-multilib-aidath.conf
37 Source11:       %{name}-archive.conf
38 Source100:      %{name}-snap.conf
39 Source101:      %{name}-multilib-snap.conf
40 Source102:      %{name}-debuginfo-snap.conf
41 Patch0:         %{name}-vserver-packages.patch
42 Patch1:         %{name}-config.patch
43 Patch2:         %{name}-size-type.patch
44 Patch3:         %{name}-Os-fail-workaround.patch
45 Patch4:         %{name}-link-rpmio.patch
46 URL:            http://poldek.pld-linux.org/
47 BuildRequires:  autoconf
48 BuildRequires:  automake
49 BuildRequires:  bzip2-devel
50 BuildRequires:  check-devel
51 BuildRequires:  db-devel >= %{ver_db}-%{ver_db_rel}
52 BuildRequires:  docbook-dtd412-xml
53 BuildRequires:  gettext-devel
54 BuildRequires:  libtool
55 BuildRequires:  libxml2-devel
56 BuildRequires:  neon-devel
57 BuildRequires:  openssl-devel >= 0.9.7d
58 BuildRequires:  pcre-devel
59 BuildRequires:  pkgconfig
60 BuildRequires:  popt-devel
61 %{?with_python:BuildRequires:   python-devel}
62 BuildRequires:  readline-devel >= 5.0
63 BuildRequires:  rpm-devel >= %{ver_rpm}
64 %{?with_python:BuildRequires:   rpm-pythonprov}
65 BuildRequires:  swig-python
66 BuildRequires:  xmlto
67 BuildRequires:  zlib-devel
68 %if %{with static}
69 BuildRequires:  bzip2-static
70 BuildRequires:  db-static >= %{ver_db}-%{ver_db_rel}
71 BuildRequires:  glibc-static
72 BuildRequires:  libselinux-static
73 BuildRequires:  libxml2-static
74 BuildRequires:  ncurses-static
75 BuildRequires:  openssl-static
76 BuildRequires:  pcre-static
77 BuildRequires:  popt-static
78 BuildRequires:  readline-static
79 BuildRequires:  rpm-static
80 BuildRequires:  zlib-static
81 %endif
82 Requires(triggerpostun):        awk
83 Requires(triggerpostun):        sed >= 4.0
84 Requires:       %{name}-libs = %{version}-%{release}
85 Requires:       db >= %{ver_db}-%{ver_db_rel}
86 Requires:       rpm >= %{ver_rpm}
87 Requires:       rpm-db-ver = %{ver_db}
88 Requires:       rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
89 # vf* scripts use sed
90 Requires:       sed
91 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93 %description
94 poldek is an RPM package management tool which allows you to easily
95 perform package verification, installation (including system
96 installation from scratch), upgrading, and removal.
97
98 Program can be used in batch (like apt-get from Debian's APT) or
99 interactive mode. The interactive mode puts you into a readline
100 interface with command line autocompletion and history, similar to the
101 shell mode of Perl's CPAN.
102
103 %{?with_static:This version is statically linked.}
104
105 %{!?with_imode:This version hasn't got interactive mode.}
106 #'vim
107
108 %description -l hu.UTF-8
109 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
110 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
111 nulláról), frissítést és eltávolítást.
112
113 A program használható parancssorból (mint a Debian apt-get programja)
114 vagy interaktív módban. Az interaktív mód egy readline környezetet
115 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
116 shell módjához.
117
118 %{?with_static:Ez a verzió statikusan linkelt.}
119
120 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
121
122 %description -l pl.UTF-8
123 poldek jest narzędziem linii poleceń służącym do weryfikacji,
124 instalacji (włączając instalację systemu od zera), aktualizacji i
125 usuwania pakietów.
126
127 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
128 interaktywnym. Tryb interaktywny posiada interfejs readline z
129 dopełnianiem komend i historią, podobny do trybu shell perlowego
130 modułu CPAN.
131
132 %{?with_static:Ta wersja jest konsolidowana statycznie.}
133
134 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
135
136 %package libs
137 Summary:        poldek libraries
138 Summary(hu.UTF-8):      A poldek könyvtárai
139 Summary(pl.UTF-8):      Biblioteki poldka
140 Group:          Libraries
141
142 %description libs
143 poldek libraries.
144
145 %description libs -l hu.UTF-8
146 A poldek könyvtárai.
147
148 %description libs -l pl.UTF-8
149 Biblioteki poldka.
150
151 %package devel
152 Summary:        Header files for poldek libraries
153 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
154 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
155 Group:          Development/Libraries
156 Requires:       %{name}-libs = %{version}-%{release}
157 Requires:       rpm-devel >= %{ver_rpm}
158
159 %description devel
160 Header files for poldek libraries.
161
162 %description devel -l hu.UTF-8
163 A poldek könyvtár fejlesztői fájljai.
164
165 %description devel -l pl.UTF-8
166 Pliki nagłówkowe bibliotek poldka.
167
168 %package static
169 Summary:        poldek static libraries
170 Summary(hu.UTF-8):      poldek statikus könyvtárak
171 Summary(pl.UTF-8):      Biblioteki statyczne poldka
172 Group:          Development/Libraries
173 Requires:       %{name}-devel = %{version}-%{release}
174
175 %description static
176 poldek static libraries.
177
178 %description static -l hu.UTF-8
179 poldek statikus könyvtárak.
180
181 %description static -l pl.UTF-8
182 Biblioteki statyczne poldka.
183
184 %package -n python-poldek
185 Summary:        Python modules for poldek
186 Summary(hu.UTF-8):      Python modulok poldek-hez
187 Summary(pl.UTF-8):      Moduły języka Python dla poldka
188 Group:          Libraries/Python
189 Requires:       %{name}-libs = %{version}-%{release}
190 %pyrequires_eq  python-libs
191
192 %description -n python-poldek
193 Python modules for poldek.
194
195 %description -n python-poldek -l hu.UTF-8
196 Python modulok poldek-hez.
197
198 %description -n python-poldek -l pl.UTF-8
199 Moduły języka Python dla poldka.
200
201 %prep
202 %setup -q
203 %patch0 -p1
204 %patch1 -p1
205 %patch2 -p1
206 %patch3 -p1
207 %patch4 -p1
208
209 %{__rm} m4/libtool.m4 m4/lt*.m4
210
211 # cleanup backups after patching
212 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
213 chmod u+x ./configure ./doc/conf-xml2.sh
214
215 %build
216 %{__libtoolize}
217 %{__aclocal} -I m4
218 %{__autoheader}
219 %{__autoconf}
220 %{__automake}
221 cd tndb
222 %{__libtoolize}
223 %{__aclocal}
224 %{__autoheader}
225 %{__autoconf}
226 %{__automake}
227 cd ../trurlib
228 %{__libtoolize}
229 %{__aclocal}
230 %{__autoheader}
231 %{__autoconf}
232 %{__automake}
233 cd ..
234
235 CPPFLAGS="%{rpmcppflags} -std=gnu99"
236 %configure \
237         %{?with_static:--enable-static --disable-shared} \
238         %{!?with_imode:--disable-imode} \
239         --enable-nls \
240         %{?with_python:--with-python}
241 %{__make} -j1
242 #       --enable-trace
243
244 %install
245 rm -rf $RPM_BUILD_ROOT
246 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name}/repos.d,/var/cache/%{name}}
247
248 %{__make} install -j1 \
249         DESTDIR=$RPM_BUILD_ROOT
250
251 %if %{with python}
252 %{__make} -C python -j1 install \
253         DESTDIR=$RPM_BUILD_ROOT \
254         libdir=%{py_sitedir}
255 %endif
256
257 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
258
259 %ifarch i486 i686 ppc sparc alpha athlon
260         %define         _ftp_arch       %{_target_cpu}
261 %endif
262 %ifarch %{x8664}
263         %define         _ftp_arch       x86_64
264         %define         _ftp_alt_arch   i686
265 %endif
266 %ifarch i586
267         %define         _ftp_arch       i486
268 %endif
269 %ifarch pentium2 pentium3 pentium4
270         %define         _ftp_arch       i686
271 %endif
272 %ifarch sparcv9 sparc64
273         %define         _ftp_arch       sparc
274         %define         _ftp_arch       %{_target_cpu}
275         %ifarch sparc64
276                 %define         _ftp_alt_arch   sparcv9
277         %endif
278 %endif
279
280 %define pld_conf %{SOURCE1}
281 %define pld_debuginfo_conf %{SOURCE8}
282 %define pld_archive_conf %{SOURCE11}
283
284 %ifarch %{x8664}
285         %define pld_multilib_conf %{SOURCE2}
286 %endif
287
288 # aidath
289 %ifarch sparcv9 sparc64
290         %define pld_conf %{SOURCE9}
291         %undefine pld_archive_conf
292 %endif
293 %ifarch sparc64
294         %define pld_multilib_conf %{SOURCE10}
295 %endif
296
297 %{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
298
299 %if 0%{?pld_multilib_conf:1}
300         %{__sed} 's|%%ARCH%%|%{_ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
301 %endif
302
303 %if 0%{?pld_debuginfo_conf:1}
304 %{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
305 %endif
306
307 %if 0%{?pld_archive_conf:1}
308 %{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
309 %endif
310
311 # Always install snapshot configs
312 %{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' \
313         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
314 %{__sed} -e 's|%%ARCH%%|%{_ftp_arch}|g' \
315         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
316 %ifarch %{x8664}
317         %{__sed} -e 's|%%ARCH%%|%{_ftp_alt_arch}|g' \
318                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf
319 %endif
320
321 %if %{with snap}
322 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
323 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
324 %else
325 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
326 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
327 %endif
328
329 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
330
331 %if %{with imode}
332 # add desktop file and icon
333 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
334 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
335 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
336 %endif
337
338 # sources we don't package
339 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
340 # include them in %doc
341 %{__rm} -rf configs
342 cp -a conf configs
343 %{__rm} -f configs/Makefile*
344
345 %if %{with python}
346 %py_postclean
347 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
348 %endif
349
350 %find_lang %{name}
351
352 ldd $RPM_BUILD_ROOT%{_libdir}/libpoldek.so.2.0.0
353
354 %clean
355 rm -rf $RPM_BUILD_ROOT
356
357 %post
358 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
359 if [ "$1" = "1" ]; then
360         # remove ignore = vserver-packages inside vserver on first install
361         {
362                 while read f ctx; do
363                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
364                 done </proc/self/status
365         } 2>/dev/null
366         if [ -z "$ctx" -o "$ctx" = "0" ]; then
367                 VSERVER=no
368         else
369                 VSERVER=yes
370         fi
371         if [ "$VSERVER" = "yes" ]; then
372                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
373         fi
374 fi
375
376 %postun -p      /sbin/postshell
377 -/usr/sbin/fix-info-dir -c %{_infodir}
378
379 %post   libs -p /sbin/ldconfig
380 %postun libs -p /sbin/ldconfig
381
382 %triggerpostun -- poldek < 0.19.0-1.20050613.22.0
383 if [ -f /etc/poldek.conf.rpmsave ]; then
384         awk '/^source/ {
385         name = $3;
386         path = $4;
387         auto = "yes";
388         autoup = "yes";
389         type = "pdir";
390         pri = "";
391
392         if (sub(",noauto", "", name)) {
393                 auto = "no";
394         }
395
396         # process pri=\d+
397         if (match(name, /,pri=[0-9]+/)) {
398                 pri = substr(name, RSTART + 5, RLENGTH - 5);
399                 name = substr(name, 1, RSTART - 1) substr(name, RSTART + RLENGTH);
400         }
401
402         # skip ac sources. already in new config.
403         if (name !~ /^ac(-(ready|test|supported|updates-(general|security)))?$/) {
404                 print "";
405                 print "[source]";
406                 print "name = " name;
407                 print "type = " type;
408                 print "path = " path;
409                 print "auto = " auto;
410                 print "autoup = " autoup;
411                 if (pri) {
412                         print "pri = " pri;
413                 }
414         }
415
416         }' < /etc/poldek.conf.rpmsave >> /etc/poldek/source.conf
417         echo "Converted old custom sources from /etc/poldek.conf.rpmsave to new poldek format in /etc/poldek/source.conf"
418
419         # copy hold=
420         hold=$(grep ^hold /etc/poldek.conf.rpmsave)
421         if [ "$hold" ]; then
422                 %{__sed} -i -e "/^#hold =/s/^.*/$hold/" /etc/poldek/poldek.conf
423         fi
424 fi
425
426 %triggerpostun -- poldek < 0.30-0.20080225.00.1
427 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
428         %{__sed} -i -e '/^%%include source.conf/{
429                 a
430                 a# /etc/poldek/repos.d/*.conf
431                 a%%includedir repos.d
432         }' %{_sysconfdir}/%{name}/poldek.conf
433 fi
434
435 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
436 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
437
438 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
439         cp -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
440         cp -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
441 fi
442
443 %ifarch %{x8664}
444 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
445         cp -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
446         cp -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
447 fi
448 %endif
449
450 %files -f %{name}.lang
451 %defattr(644,root,root,755)
452 %doc ChangeLog README* NEWS TODO configs
453 %dir %{_sysconfdir}/%{name}
454 %dir %{_sysconfdir}/%{name}/repos.d
455 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
456 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
457 %attr(755,root,root) %{_bindir}/ipoldek
458 %attr(755,root,root) %{_bindir}/poldek
459 %attr(755,root,root) %{_bindir}/rpmvercmp
460 %dir %{_libdir}/%{name}
461 %attr(755,root,root) %{_libdir}/%{name}/*
462 %{_mandir}/man1/%{name}*.1*
463 %lang(pl) %{_mandir}/pl/man1/%{name}*
464 %{_infodir}/poldek.info*
465 %if %{with imode}
466 %{_desktopdir}/%{name}.desktop
467 %{_pixmapsdir}/%{name}.png
468 %endif
469 %dir /var/cache/%{name}
470
471 %if %{without static}
472 %files libs
473 %defattr(644,root,root,755)
474 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
475 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
476 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
477 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
478 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
479 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
480 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
481 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
482 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
483 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
484 %endif
485
486 %files devel
487 %defattr(644,root,root,755)
488 %if %{without static}
489 %attr(755,root,root) %{_libdir}/libpoclidek.so
490 %attr(755,root,root) %{_libdir}/libpoldek.so
491 %attr(755,root,root) %{_libdir}/libtndb.so
492 %attr(755,root,root) %{_libdir}/libtrurl.so
493 %attr(755,root,root) %{_libdir}/libvfile.so
494 %endif
495 %{_libdir}/libpoclidek.la
496 %{_libdir}/libpoldek.la
497 %{_libdir}/libtndb.la
498 %{_libdir}/libtrurl.la
499 %{_libdir}/libvfile.la
500 %{_includedir}/poldek
501 %{_includedir}/tndb
502 %{_includedir}/trurl
503 %{_includedir}/vfile
504 %{_pkgconfigdir}/tndb.pc
505
506 %files static
507 %defattr(644,root,root,755)
508 %{_libdir}/libtndb.a
509 %{_libdir}/libtrurl.a
510
511 %if %{with python}
512 %files -n python-poldek
513 %defattr(644,root,root,755)
514 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
515 %{py_sitescriptdir}/poldek.py[co]
516 %{py_sitescriptdir}/poldekmod.py[co]
517 %endif
This page took 0.096456 seconds and 4 git commands to generate.