]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- add cache dir
[packages/poldek.git] / poldek.spec
1 # TODO:
2 # - fails to build without poldek-devel - fix it !
3 #
4 # Conditional build:
5 %bcond_with     static  # don't use shared libraries
6 %bcond_without  imode   # don't build interactive mode
7 %bcond_without  python  # don't build python bindings
8
9 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
10 %if "%{pld_release}" == "ti"
11 %define ver_db  4.5.20
12 %define ver_db_rel      8
13 %else
14 %define ver_db  4.7.25
15 %define ver_db_rel      1
16 %endif
17 %define ver_rpm 4.5-49
18
19 %define         snap    rc3
20 %define         rel     3
21 Summary:        RPM packages management helper tool
22 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
23 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
24 Name:           poldek
25 Version:        0.30
26 Release:        1.%{snap}.%{rel}
27 License:        GPL v2
28 Group:          Applications/System
29 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
30 Source0:        http://carme.pld-linux.org/~cactus/snaps/poldek/%{name}-%{version}%{snap}.tar.bz2
31 # Source0-md5:  d85c14544d02d03d67d0b1ebd6ec7c61
32 Source1:        %{name}.conf
33 Source2:        %{name}-multilib.conf
34 Source3:        %{name}-ti.conf
35 Source4:        %{name}-multilib-ti.conf
36 Source5:        %{name}-aliases.conf
37 Source6:        %{name}.desktop
38 Source7:        %{name}.png
39 Source8:        %{name}-debuginfo.conf
40 Source9:        %{name}-aidath.conf
41 Source10:       %{name}-multilib-aidath.conf
42 Source11:       %{name}-archive.conf
43 Patch0:         %{name}-vserver-packages.patch
44 Patch1:         %{name}-config.patch
45 Patch2:         %{name}-size-type.patch
46 Patch3:         %{name}-Os-fail-workaround.patch
47 URL:            http://poldek.pld-linux.org/
48 BuildRequires:  autoconf
49 BuildRequires:  automake
50 BuildRequires:  bzip2-devel
51 BuildRequires:  check-devel
52 BuildRequires:  db-devel >= %{ver_db}-%{ver_db_rel}
53 BuildRequires:  docbook-dtd412-xml
54 BuildRequires:  gettext-devel
55 BuildRequires:  libtool
56 BuildRequires:  libxml2-devel
57 BuildRequires:  neon-devel
58 BuildRequires:  openssl-devel >= 0.9.7d
59 BuildRequires:  pcre-devel
60 BuildRequires:  pkgconfig
61 BuildRequires:  popt-devel
62 %{?with_python:BuildRequires:   python-devel}
63 BuildRequires:  readline-devel >= 5.0
64 BuildRequires:  rpm-devel >= %{ver_rpm}
65 %{?with_python:BuildRequires:   rpm-pythonprov}
66 BuildRequires:  swig-python
67 BuildRequires:  zlib-devel
68 %if %{with static}
69 BuildRequires:  bzip2-static
70 BuildRequires:  db-static >= %{ver_db}-%{ver_db_rel}
71 BuildRequires:  glibc-static
72 BuildRequires:  libselinux-static
73 BuildRequires:  libxml2-static
74 BuildRequires:  ncurses-static
75 BuildRequires:  openssl-static
76 BuildRequires:  pcre-static
77 BuildRequires:  popt-static
78 BuildRequires:  readline-static
79 BuildRequires:  rpm-static
80 BuildRequires:  zlib-static
81 %endif
82 Requires(triggerpostun):        awk
83 Requires(triggerpostun):        sed >= 4.0
84 Requires:       %{name}-libs = %{version}-%{release}
85 Requires:       db >= %{ver_db}-%{ver_db_rel}
86 Requires:       rpm >= %{ver_rpm}
87 Requires:       rpm-db-ver = %{ver_db}
88 Requires:       rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
89 # vf* scripts use sed
90 Requires:       sed
91 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93 %description
94 poldek is an RPM package management tool which allows you to easily
95 perform package verification, installation (including system
96 installation from scratch), upgrading, and removal.
97
98 Program can be used in batch (like apt-get from Debian's APT) or
99 interactive mode. The interactive mode puts you into a readline
100 interface with command line autocompletion and history, similar to the
101 shell mode of Perl's CPAN.
102
103 %{?with_static:This version is statically linked.}
104
105 %{!?with_imode:This version hasn't got interactive mode.}
106 #'vim
107
108 %description -l hu.UTF-8
109 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
110 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
111 nulláról), frissítést és eltávolítást.
112
113 A program használható parancssorból (mint a Debian apt-get programja)
114 vagy interaktív módban. Az interaktív mód egy readline környezetet
115 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
116 shell módjához.
117
118 %{?with_static:Ez a verzió statikusan linkelt.}
119
120 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
121
122 %description -l pl.UTF-8
123 poldek jest narzędziem linii poleceń służącym do weryfikacji,
124 instalacji (włączając instalację systemu od zera), aktualizacji i
125 usuwania pakietów.
126
127 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
128 interaktywnym. Tryb interaktywny posiada interfejs readline z
129 dopełnianiem komend i historią, podobny do trybu shell perlowego
130 modułu CPAN.
131
132 %{?with_static:Ta wersja jest konsolidowana statycznie.}
133
134 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
135
136 %package libs
137 Summary:        poldek libraries
138 Summary(hu.UTF-8):      A poldek könyvtárai
139 Summary(pl.UTF-8):      Biblioteki poldka
140 Group:          Libraries
141
142 %description libs
143 poldek libraries.
144
145 %description libs -l hu.UTF-8
146 A poldek könyvtárai.
147
148 %description libs -l pl.UTF-8
149 Biblioteki poldka.
150
151 %package devel
152 Summary:        Header files for poldek libraries
153 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
154 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
155 Group:          Development/Libraries
156 Requires:       %{name}-libs = %{version}-%{release}
157 Requires:       rpm-devel >= %{ver_rpm}
158
159 %description devel
160 Header files for poldek libraries.
161
162 %description devel -l hu.UTF-8
163 A poldek könyvtár fejlesztői fájljai.
164
165 %description devel -l pl.UTF-8
166 Pliki nagłówkowe bibliotek poldka.
167
168 %package static
169 Summary:        poldek static libraries
170 Summary(hu.UTF-8):      poldek statikus könyvtárak
171 Summary(pl.UTF-8):      Biblioteki statyczne poldka
172 Group:          Development/Libraries
173 Requires:       %{name}-devel = %{version}-%{release}
174
175 %description static
176 poldek static libraries.
177
178 %description static -l hu.UTF-8
179 poldek statikus könyvtárak.
180
181 %description static -l pl.UTF-8
182 Biblioteki statyczne poldka.
183
184 %package -n python-poldek
185 Summary:        Python modules for poldek
186 Summary(hu.UTF-8):      Python modulok poldek-hez
187 Summary(pl.UTF-8):      Moduły języka Python dla poldka
188 Group:          Libraries/Python
189 Requires:       %{name}-libs = %{version}-%{release}
190 %pyrequires_eq  python-libs
191
192 %description -n python-poldek
193 Python modules for poldek.
194
195 %description -n python-poldek -l hu.UTF-8
196 Python modulok poldek-hez.
197
198 %description -n python-poldek -l pl.UTF-8
199 Moduły języka Python dla poldka.
200
201 %prep
202 %setup -q
203 %patch0 -p1
204 %patch1 -p1
205 %patch2 -p1
206 %patch3 -p1
207
208 rm -f m4/libtool.m4 m4/lt*.m4
209
210 # cleanup backups after patching
211 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
212 chmod u+x ./configure ./doc/conf-xml2.sh
213
214 %build
215 %{__libtoolize}
216 %{__aclocal} -I m4
217 %{__autoheader}
218 %{__autoconf}
219 %{__automake}
220 cd tndb
221 %{__libtoolize}
222 autoreconf -i
223 cd ../trurlib
224 %{__libtoolize}
225 autoreconf -i
226 cd ..
227
228 CPPFLAGS="-std=gnu99"
229 %configure \
230         %{?with_static:--enable-static --disable-shared} \
231         %{!?with_imode:--disable-imode} \
232         --enable-nls \
233         %{?with_python:--with-python}
234 %{__make}
235 #       --enable-trace
236
237 %install
238 rm -rf $RPM_BUILD_ROOT
239 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name}/repos.d,/var/cache/%{name}}
240
241 %{__make} install \
242         DESTDIR=$RPM_BUILD_ROOT
243
244 %if %{with python}
245 %{__make} -C python install \
246         DESTDIR=$RPM_BUILD_ROOT \
247         libdir=%{py_sitedir}
248 %endif
249
250 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
251
252 %ifarch i486 i686 ppc sparc alpha athlon
253         %define         _ftp_arch       %{_target_cpu}
254 %endif
255 %ifarch %{x8664}
256         %define         _ftp_arch       x86_64
257         %define         _ftp_alt_arch   i686
258 %endif
259 %ifarch i586
260         %if "%{pld_release}" == "ti"
261                 %define         _ftp_arch       i586
262         %else
263                 %define         _ftp_arch       i486
264         %endif
265 %endif
266 %ifarch pentium2 pentium3 pentium4
267         %define         _ftp_arch       i686
268 %endif
269 %ifarch sparcv9 sparc64
270         %define         _ftp_arch       sparc
271         %if "%{pld_release}" == "th"
272                 %define         _ftp_arch       %{_target_cpu}
273                 %ifarch sparc64
274                 %define         _ftp_alt_arch   sparcv9
275                 %endif
276         %endif
277 %endif
278
279 %if "%{pld_release}" == "ti"
280         %define pld_conf %{SOURCE3}
281         %ifarch %{x8664}
282                 %define pld_multilib_conf %{SOURCE4}
283         %endif
284 %endif
285
286 %if "%{pld_release}" == "th"
287         %define pld_conf %{SOURCE1}
288         %define pld_debuginfo_conf %{SOURCE8}
289         %define pld_archive_conf %{SOURCE11}
290
291         %ifarch %{x8664}
292                 %define pld_multilib_conf %{SOURCE2}
293         %endif
294
295         # aidath
296         %ifarch sparcv9 sparc64
297                 %define pld_conf %{SOURCE9}
298                 %undefine pld_archive_conf
299         %endif
300         %ifarch sparc64
301                 %define pld_multilib_conf %{SOURCE10}
302         %endif
303 %endif
304
305 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
306
307 %if 0%{?pld_multilib_conf:1}
308         sed 's|%%ARCH%%|%{_ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
309 %endif
310
311 %if 0%{?pld_debuginfo_conf:1}
312 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
313 %endif
314
315 %if 0%{?pld_archive_conf:1}
316 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
317 %endif
318
319 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
320
321 %if %{with imode}
322 # add desktop file and icon
323 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
324 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
325 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
326 %endif
327
328 # sources we don't package
329 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,pld,fedora,centos}-source.conf
330 # include them in %doc
331 rm -rf configs
332 cp -a conf configs
333 rm -f configs/Makefile*
334
335 %if %{with python}
336 %py_postclean
337 rm -f $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
338 %endif
339
340 %find_lang %{name}
341
342 %clean
343 rm -rf $RPM_BUILD_ROOT
344
345 %post
346 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
347 if [ "$1" = "1" ]; then
348         # remove ignore = vserver-packages inside vserver on first install
349         {
350                 while read f ctx; do
351                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
352                 done </proc/self/status
353         } 2>/dev/null
354         if [ -z "$ctx" -o "$ctx" = "0" ]; then
355                 VSERVER=no
356         else
357                 VSERVER=yes
358         fi
359         if [ "$VSERVER" = "yes" ]; then
360                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
361         fi
362 fi
363
364 %postun -p      /sbin/postshell
365 -/usr/sbin/fix-info-dir -c %{_infodir}
366
367 %post   libs -p /sbin/ldconfig
368 %postun libs -p /sbin/ldconfig
369
370 %triggerpostun -- poldek < 0.19.0-1.20050613.22.0
371 if [ -f /etc/poldek.conf.rpmsave ]; then
372         awk '/^source/ {
373         name = $3;
374         path = $4;
375         auto = "yes";
376         autoup = "yes";
377         type = "pdir";
378         pri = "";
379
380         if (sub(",noauto", "", name)) {
381                 auto = "no";
382         }
383
384         # process pri=\d+
385         if (match(name, /,pri=[0-9]+/)) {
386                 pri = substr(name, RSTART + 5, RLENGTH - 5);
387                 name = substr(name, 1, RSTART - 1) substr(name, RSTART + RLENGTH);
388         }
389
390         # skip ac sources. already in new config.
391         if (name !~ /^ac(-(ready|test|supported|updates-(general|security)))?$/) {
392                 print "";
393                 print "[source]";
394                 print "name = " name;
395                 print "type = " type;
396                 print "path = " path;
397                 print "auto = " auto;
398                 print "autoup = " autoup;
399                 if (pri) {
400                         print "pri = " pri;
401                 }
402         }
403
404         }' < /etc/poldek.conf.rpmsave >> /etc/poldek/source.conf
405         echo "Converted old custom sources from /etc/poldek.conf.rpmsave to new poldek format in /etc/poldek/source.conf"
406
407         # copy hold=
408         hold=$(grep ^hold /etc/poldek.conf.rpmsave)
409         if [ "$hold" ]; then
410                 sed -i -e "/^#hold =/s/^.*/$hold/" /etc/poldek/poldek.conf
411         fi
412 fi
413
414 %triggerpostun -- poldek < 0.30-0.20080225.00.1
415 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
416         %{__sed} -i -e '/^%%include source.conf/{
417                 a
418                 a# /etc/poldek/repos.d/*.conf
419                 a%%includedir repos.d
420         }' %{_sysconfdir}/%{name}/poldek.conf
421 fi
422
423 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
424 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
425
426 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
427         cp -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
428         cp -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
429 fi
430
431 %ifarch %{x8664}
432 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
433         cp -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
434         cp -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
435 fi
436 %endif
437
438 %files -f %{name}.lang
439 %defattr(644,root,root,755)
440 %doc ChangeLog README* NEWS TODO configs
441 %dir %{_sysconfdir}/%{name}
442 %dir %{_sysconfdir}/%{name}/repos.d
443 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
444 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
445 %attr(755,root,root) %{_bindir}/*
446 %dir %{_libdir}/%{name}
447 %attr(755,root,root) %{_libdir}/%{name}/*
448 %{_mandir}/man1/%{name}*
449 %lang(pl) %{_mandir}/pl/man1/%{name}*
450 %{_infodir}/poldek.info*
451 %if %{with imode}
452 %{_desktopdir}/%{name}.desktop
453 %{_pixmapsdir}/%{name}.png
454 %endif
455 %dir /var/cache/%{name}
456
457 %if %{without static}
458 %files libs
459 %defattr(644,root,root,755)
460 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
461 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
462 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
463 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
464 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
465 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
466 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
467 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
468 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
469 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
470 %endif
471
472 %files devel
473 %defattr(644,root,root,755)
474 %{!?with_static:%attr(755,root,root) %{_libdir}/lib*.so}
475 %{_libdir}/lib*.la
476 %{_includedir}/*
477
478 %files static
479 %defattr(644,root,root,755)
480 %{_libdir}/lib*.a
481
482 %if %{with python}
483 %files -n python-poldek
484 %defattr(644,root,root,755)
485 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
486 %{py_sitescriptdir}/poldek.py[co]
487 %{py_sitescriptdir}/poldekmod.py[co]
488 %endif
This page took 0.065205 seconds and 4 git commands to generate.