]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
a2ae86512899322744c8f67b8286ea55bdf67c98
[packages/poldek.git] / poldek.spec
1 # TODO
2 # - fix config having escaped html entities:
3 #   # package A requires capability foo >= 1.0 while package B provides "foo"
4
5 # Conditional build:
6 %bcond_with     static  # don't use shared libraries
7 %bcond_without  imode   # don't build interactive mode
8 %bcond_without  python  # don't build python bindings
9 %bcond_with     snap    # install configs for official Th snapshot
10 %bcond_with     db61    # DB 6.1 instead of 5.2
11 %bcond_with     rpm4    # use rpm4/db4.7 instead of rpm5
12
13 # current snapshot name
14 %define         SNAP    2018
15
16 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
17 # NOTE: poldek links with "system db" (-ldb) anyway if it exists
18 %if %{with db61}
19 %define         db_pkg          db6.1
20 %define         ver_db          6.1
21 %define         ver_db_rel      1
22 %else
23 %define         db_pkg          db5.2
24 %define         ver_db          5.2
25 %define         ver_db_rel      3
26 %endif
27
28 %if %{with rpm4}
29 %define         db_pkg          db4.7
30 %define         ver_db          4.7.25
31 %define         ver_db_rel      1
32 %define         ver_rpm         4.5-49
33 %else
34 %define         ver_rpm         5.4.10
35 %endif
36
37 %define         rel     1
38 Summary:        RPM packages management helper tool
39 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
40 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
41 Name:           poldek
42 Version:        0.40.0
43 Release:        %{rel}%{?with_snap:.%{SNAP}}
44 License:        GPL v2
45 Group:          Applications/System
46 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
47 Source0:        https://launchpad.net/poldek/master/head/+download/%{name}-%{version}.tar.xz
48 # Source0-md5:  c88f3ada99799d0e1af78aeda428d041
49 Source1:        %{name}.conf
50 Source2:        %{name}-multilib.conf
51 Source3:        %{name}-config.sh
52 Source5:        %{name}-aliases.conf
53 Source6:        %{name}.desktop
54 Source7:        %{name}.png
55 # Source7-md5:  ee487abede50874e9eceb6495d5ee150
56 Source8:        %{name}-debuginfo.conf
57 Source9:        %{name}-aidath.conf
58 Source10:       %{name}-multilib-aidath.conf
59 Source11:       %{name}-archive.conf
60 Source100:      %{name}-snap.conf
61 Source101:      %{name}-multilib-snap.conf
62 Source102:      %{name}-debuginfo-snap.conf
63 Patch0:         %{name}-config.patch
64 Patch1:         pm-hooks.patch
65 Patch2:         poldek-ext-down-enable.patch
66 Patch3:         multiple-options.patch
67 URL:            http://poldek.pld-linux.org/
68 BuildRequires:  %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
69 BuildRequires:  autoconf
70 BuildRequires:  automake >= 1:1.11
71 BuildRequires:  bzip2-devel
72 BuildRequires:  check-devel
73 BuildRequires:  docbook-dtd412-xml
74 BuildRequires:  gettext-tools
75 BuildRequires:  libgomp-devel
76 BuildRequires:  libtool
77 BuildRequires:  libxml2-devel
78 BuildRequires:  openssl-devel >= 0.9.7d
79 BuildRequires:  pcre-devel
80 BuildRequires:  pkgconfig
81 BuildRequires:  popt-devel
82 %{?with_python:BuildRequires:   python-devel}
83 BuildRequires:  readline-devel >= 5.0
84 BuildRequires:  rpm-devel >= %{ver_rpm}
85 %{?with_python:BuildRequires:   rpm-pythonprov}
86 BuildRequires:  tar >= 1:1.22
87 BuildRequires:  xmlto
88 BuildRequires:  xz
89 BuildRequires:  zlib-devel
90 BuildRequires:  zstd-devel
91 %if %{with static}
92 BuildRequires:  %{db_pkg}-static >= %{ver_db}-%{ver_db_rel}
93 BuildRequires:  bzip2-static
94 BuildRequires:  glibc-static
95 BuildRequires:  libxml2-static
96 BuildRequires:  ncurses-static
97 BuildRequires:  openssl-static
98 BuildRequires:  pcre-static
99 BuildRequires:  popt-static
100 BuildRequires:  readline-static
101 BuildRequires:  rpm-static
102 BuildRequires:  zlib-static
103 BuildRequires:  zstd-static
104 %endif
105 Requires(triggerpostun):        awk
106 Requires(triggerpostun):        sed >= 4.0
107 Requires:       %{db_pkg} >= %{ver_db}-%{ver_db_rel}
108 Requires:       %{name}-libs = %{version}-%{release}
109 Requires:       /bin/run-parts
110 Requires:       rpm >= %{ver_rpm}
111 Requires:       rpm-db-ver = %{ver_db}
112 Requires:       rpm-lib >= %{ver_rpm}
113 Requires:       sed
114 Conflicts:      etckeeper < 1.18-2
115 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
116
117 %define         _libexecdir     %{_prefix}/lib/%{name}
118
119 %description
120 poldek is an RPM package management tool which allows you to easily
121 perform package verification, installation (including system
122 installation from scratch), upgrading, and removal.
123
124 Program can be used in batch (like apt-get from Debian's APT) or
125 interactive mode. The interactive mode puts you into a readline
126 interface with command line autocompletion and history, similar to the
127 shell mode of Perl's CPAN.
128
129 %{?with_static:This version is statically linked.}
130
131 %{!?with_imode:This version hasn't got interactive mode.}
132 #'vim
133
134 %description -l hu.UTF-8
135 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
136 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
137 nulláról), frissítést és eltávolítást.
138
139 A program használható parancssorból (mint a Debian apt-get programja)
140 vagy interaktív módban. Az interaktív mód egy readline környezetet
141 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
142 shell módjához.
143
144 %{?with_static:Ez a verzió statikusan linkelt.}
145
146 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
147
148 %description -l pl.UTF-8
149 poldek jest narzędziem linii poleceń służącym do weryfikacji,
150 instalacji (włączając instalację systemu od zera), aktualizacji i
151 usuwania pakietów.
152
153 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
154 interaktywnym. Tryb interaktywny posiada interfejs readline z
155 dopełnianiem komend i historią, podobny do trybu shell perlowego
156 modułu CPAN.
157
158 %{?with_static:Ta wersja jest konsolidowana statycznie.}
159
160 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
161
162 %package libs
163 Summary:        poldek libraries
164 Summary(hu.UTF-8):      A poldek könyvtárai
165 Summary(pl.UTF-8):      Biblioteki poldka
166 Group:          Libraries
167
168 %description libs
169 poldek libraries.
170
171 %description libs -l hu.UTF-8
172 A poldek könyvtárai.
173
174 %description libs -l pl.UTF-8
175 Biblioteki poldka.
176
177 %package devel
178 Summary:        Header files for poldek libraries
179 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
180 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
181 Group:          Development/Libraries
182 Requires:       %{name}-libs = %{version}-%{release}
183 Requires:       rpm-devel >= %{ver_rpm}
184
185 %description devel
186 Header files for poldek libraries.
187
188 %description devel -l hu.UTF-8
189 A poldek könyvtár fejlesztői fájljai.
190
191 %description devel -l pl.UTF-8
192 Pliki nagłówkowe bibliotek poldka.
193
194 %package static
195 Summary:        poldek static libraries
196 Summary(hu.UTF-8):      poldek statikus könyvtárak
197 Summary(pl.UTF-8):      Biblioteki statyczne poldka
198 Group:          Development/Libraries
199 Requires:       %{name}-devel = %{version}-%{release}
200
201 %description static
202 poldek static libraries.
203
204 %description static -l hu.UTF-8
205 poldek statikus könyvtárak.
206
207 %description static -l pl.UTF-8
208 Biblioteki statyczne poldka.
209
210 %package -n python-poldek
211 Summary:        Python modules for poldek
212 Summary(hu.UTF-8):      Python modulok poldek-hez
213 Summary(pl.UTF-8):      Moduły języka Python dla poldka
214 Group:          Libraries/Python
215 Requires:       %{name}-libs = %{version}-%{release}
216 Requires:       python-libs
217
218 %description -n python-poldek
219 Python modules for poldek.
220
221 %description -n python-poldek -l hu.UTF-8
222 Python modulok poldek-hez.
223
224 %description -n python-poldek -l pl.UTF-8
225 Moduły języka Python dla poldka.
226
227 %prep
228 %setup -q
229 %patch0 -p1
230 %patch1 -p1
231 %patch2 -p1
232 %patch3 -p1
233
234 %{__rm} m4/libtool.m4 m4/lt*.m4
235
236 # cleanup backups after patching
237 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
238 chmod u+x ./configure ./doc/conf-xml2.sh
239
240 %build
241 %{__gettextize}
242 %{__libtoolize}
243 %{__aclocal} -I m4
244 %{__autoheader}
245 %{__autoconf}
246 %{__automake}
247 cd tndb
248 %{__libtoolize}
249 %{__aclocal}
250 %{__autoheader}
251 %{__autoconf}
252 %{__automake}
253 cd ../trurlib
254 %{__libtoolize}
255 %{__aclocal}
256 %{__autoheader}
257 %{__autoconf}
258 %{__automake}
259 cd ..
260
261 CPPFLAGS="%{rpmcppflags} -std=gnu99 -fgnu89-inline -D_GNU_SOURCE=1"
262 %configure \
263         %{?with_static:--enable-static --disable-shared} \
264         %{!?with_imode:--disable-imode} \
265         --with-pkglibdir=%{_libexecdir} \
266         --enable-nls \
267         %{?with_python:--with-python}
268 %{__make} -j1
269 #       --enable-trace
270
271 %if %{with python}
272 %{__make} -C python
273 %endif
274
275 %install
276 rm -rf $RPM_BUILD_ROOT
277 install -d $RPM_BUILD_ROOT/var/cache/%{name}
278
279 %{__make} install -j1 \
280         DESTDIR=$RPM_BUILD_ROOT
281
282 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/poldek-config
283
284 %if %{with python}
285 %{__make} -C python -j1 install \
286         DESTDIR=$RPM_BUILD_ROOT \
287         py_sitedir=%{py_sitedir}
288 %endif
289
290 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
291
292 %ifarch i486 i686 ppc sparc alpha athlon
293         %define         ftp_arch        %{_target_cpu}
294 %endif
295 %ifarch %{x8664}
296         %define         ftp_arch        x86_64
297         %define         ftp_alt_arch    i686
298         %define         ftp_alt2_arch   x32
299 %endif
300 %ifarch x32
301         %define         ftp_arch        x32
302         %define         ftp_alt_arch    x86_64
303         %define         ftp_alt2_arch   i686
304 %endif
305 %ifarch i586
306         %define         ftp_arch        i486
307 %endif
308 %ifarch pentium2 pentium3 pentium4
309         %define         ftp_arch        i686
310 %endif
311 %ifarch sparcv9 sparc64
312         %define         ftp_arch        sparc
313         %define         ftp_arch        %{_target_cpu}
314         %ifarch sparc64
315                 %define         ftp_alt_arch    sparcv9
316         %endif
317 %endif
318
319 %define pld_conf %{SOURCE1}
320 %define pld_debuginfo_conf %{SOURCE8}
321 %define pld_archive_conf %{SOURCE11}
322
323 %ifarch %{x8664} x32
324         %define pld_multilib_conf %{SOURCE2}
325         %define pld_multilib2_conf %{SOURCE2}
326 %endif
327
328 # aidath
329 %ifarch sparcv9 sparc64
330         %define pld_conf %{SOURCE9}
331         %undefine pld_archive_conf
332 %endif
333 %ifarch sparc64
334         %define pld_multilib_conf %{SOURCE10}
335 %endif
336
337 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
338
339 %if 0%{?pld_multilib_conf:1}
340         %{__sed} 's|%%ARCH%%|%{ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
341 %endif
342
343 %if 0%{?pld_multilib2_conf:1}
344         %{__sed} 's|%%ARCH%%|%{ftp_alt2_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt2_arch}.conf
345 %endif
346
347 %if 0%{?pld_debuginfo_conf:1}
348 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
349 %endif
350
351 %if 0%{?pld_archive_conf:1}
352 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
353 %endif
354
355 # Always install snapshot configs
356 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
357         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
358 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
359         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
360 %ifarch %{x8664} x32
361         %{__sed} -e 's|%%ARCH%%|%{ftp_alt_arch}|g' \
362                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
363         %{__sed} -e 's|%%ARCH%%|%{ftp_alt2_arch}|g' \
364                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt2_arch}.conf
365 %endif
366
367 %if %{with snap}
368 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
369 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
370 %else
371 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
372 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
373 %endif
374
375 # create "all" meta repo
376 %if 0%{?ftp_alt_arch:1}%{?ftp_alt2_arch:1}
377 cat <<'EOF' >  $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-all.conf
378 # group source for referring th+th-multiarch sources together, i.e poldek -n th-all
379 [source]
380 type    = group
381 name    = th-all
382 sources = th %{?ftp_alt_arch:th-%{ftp_alt_arch}} %{?ftp_alt2_arch:th-%{ftp_alt2_arch}}
383 EOF
384 %endif
385
386 # th-2014 snap does not exist for x32 yet
387 %if "%{ftp_arch}" == "x32"
388 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
389 %endif
390 %if "%{ftp_alt2_arch}" == "x32"
391 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-x32.conf
392 %endif
393
394 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
395
396 %if %{with imode}
397 # add desktop file and icon
398 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
399 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
400 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
401 %endif
402
403 # sources we don't package
404 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
405 # include them in %doc
406 %{__rm} -rf configs
407 cp -a conf configs
408 %{__rm} -f configs/Makefile*
409
410 %if %{with python}
411 %py_postclean
412 %{__rm} $RPM_BUILD_ROOT%{_libdir}/_poldekmod.{la,so}
413 %endif
414
415 %find_lang %{name}
416
417 %clean
418 rm -rf $RPM_BUILD_ROOT
419
420 %post
421 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
422 if [ "$1" = "1" ]; then
423         # remove ignore = vserver-packages inside vserver on first install
424         {
425                 while read f ctx; do
426                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
427                 done </proc/self/status
428         } 2>/dev/null
429         if [ -z "$ctx" -o "$ctx" = "0" ]; then
430                 VSERVER=no
431         else
432                 VSERVER=yes
433         fi
434         if [ "$VSERVER" = "yes" ]; then
435                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
436         fi
437 fi
438
439 %postun -p      /sbin/postshell
440 -/usr/sbin/fix-info-dir -c %{_infodir}
441
442 %post   libs -p /sbin/ldconfig
443 %postun libs -p /sbin/ldconfig
444
445 %triggerpostun -- poldek < 0.30-0.20080225.00.1
446 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
447         %{__sed} -i -e '/^%%include source.conf/{
448                 a
449                 a# /etc/poldek/repos.d/*.conf
450                 a%%includedir repos.d
451         }' %{_sysconfdir}/%{name}/poldek.conf
452 fi
453
454 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
455 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
456
457 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
458         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
459         %{__mv} -v %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
460 fi
461
462 %ifarch %{x8664}
463 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
464         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
465         %{__mv} -v %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
466 fi
467 %endif
468
469 %triggerpostun -- poldek < 0.30.1-3
470 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave ]; then
471         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf{,.rpmnew}
472         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
473 fi
474 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave ]; then
475         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf{,.rpmnew}
476         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
477 fi
478
479 %triggerpostun -- %{name} < 0.30.1-8
480 if [ $1 -le 1 ]; then
481         # revert change on  --downgrade
482         %{__sed} -i -re 's,^pm command = %{_libexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
483 else
484         # setup pm command
485         %{__sed} -i -re 's,#?(pm command =).*,\1 %{_libexecdir}/pm-command.sh,' %{_sysconfdir}/%{name}/%{name}.conf
486 fi
487
488 %files -f %{name}.lang
489 %defattr(644,root,root,755)
490 %doc ChangeLog README* NEWS TODO configs
491 %dir %{_sysconfdir}/%{name}
492 %dir %{_sysconfdir}/%{name}/pre-install.d
493 %{_sysconfdir}/%{name}/pre-install.d/README
494 %dir %{_sysconfdir}/%{name}/post-install.d
495 %{_sysconfdir}/%{name}/post-install.d/README
496 %dir %{_sysconfdir}/%{name}/repos.d
497 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
498 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
499 %attr(755,root,root) %{_bindir}/ipoldek
500 %attr(755,root,root) %{_bindir}/poldek
501 %attr(755,root,root) %{_bindir}/poldek-config
502 %attr(755,root,root) %{_bindir}/rpmvercmp
503 %dir %{_libexecdir}
504 %attr(755,root,root) %{_libexecdir}/pm-command.sh
505 %attr(755,root,root) %{_libexecdir}/poldekuser-setup.sh
506 %attr(755,root,root) %{_libexecdir}/vfcompr
507 %attr(755,root,root) %{_libexecdir}/vfjuggle
508 %attr(755,root,root) %{_libexecdir}/vfsmb
509 %attr(755,root,root) %{_libexecdir}/zlib-in-rpm.sh
510 %{_mandir}/man1/%{name}*.1*
511 %lang(pl) %{_mandir}/pl/man1/%{name}*
512 %{_infodir}/poldek.info*
513 %if %{with imode}
514 %{_desktopdir}/%{name}.desktop
515 %{_pixmapsdir}/%{name}.png
516 %endif
517 %dir /var/cache/%{name}
518
519 %if %{without static}
520 %files libs
521 %defattr(644,root,root,755)
522 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
523 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
524 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
525 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
526 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
527 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
528 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
529 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
530 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
531 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
532 %endif
533
534 %files devel
535 %defattr(644,root,root,755)
536 %if %{without static}
537 %attr(755,root,root) %{_libdir}/libpoclidek.so
538 %attr(755,root,root) %{_libdir}/libpoldek.so
539 %attr(755,root,root) %{_libdir}/libtndb.so
540 %attr(755,root,root) %{_libdir}/libtrurl.so
541 %attr(755,root,root) %{_libdir}/libvfile.so
542 %endif
543 %{_libdir}/libpoclidek.la
544 %{_libdir}/libpoldek.la
545 %{_libdir}/libtndb.la
546 %{_libdir}/libtrurl.la
547 %{_libdir}/libvfile.la
548 %{_includedir}/poldek
549 %{_includedir}/tndb
550 %{_includedir}/trurl
551 %{_includedir}/vfile
552 %{_pkgconfigdir}/tndb.pc
553 %{_pkgconfigdir}/trurlib.pc
554
555 %files static
556 %defattr(644,root,root,755)
557 %{_libdir}/libtndb.a
558 %{_libdir}/libtrurl.a
559
560 %if %{with python}
561 %files -n python-poldek
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
564 %{py_sitescriptdir}/poldek.py[co]
565 %{py_sitescriptdir}/poldekmod.py[co]
566 %endif
This page took 0.088603 seconds and 2 git commands to generate.