]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- 2015 snap
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_without  python  # don't build python bindings
6 %bcond_with     snap    # install configs for official Th snapshot
7 %bcond_with     db61    # DB 6.1 instead of 5.2
8 %bcond_with     rpm4    # use rpm4/db4.7 instead of rpm5
9
10 # current snapshot name
11 %define         SNAP    2015
12
13 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
14 # NOTE: poldek links with "system db" (-ldb) anyway if it exists
15 %if %{with db61}
16 %define         db_pkg          db6.1
17 %define         ver_db          6.1
18 %define         ver_db_rel      1
19 %else
20 %define         db_pkg          db5.2
21 %define         ver_db          5.2
22 %define         ver_db_rel      3
23 %endif
24
25 %if %{with rpm4}
26 %define         db_pkg          db4.7
27 %define         ver_db          4.7.25
28 %define         ver_db_rel      1
29 %define         ver_rpm         4.5-49
30 %else
31 %define         ver_rpm         5.4.10
32 %endif
33
34 %define         rel     12
35 Summary:        RPM packages management helper tool
36 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
37 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
38 Name:           poldek
39 Version:        0.30.1
40 Release:        %{rel}%{?with_snap:.%{SNAP}}
41 License:        GPL v2
42 Group:          Applications/System
43 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
44 Source0:        http://carme.pld-linux.org/~megabajt/releases/poldek/%{name}-%{version}.tar.xz
45 # Source0-md5:  e569c8454df0932df53b09cee9998927
46 Source1:        %{name}.conf
47 Source2:        %{name}-multilib.conf
48 Source5:        %{name}-aliases.conf
49 Source6:        %{name}.desktop
50 Source7:        %{name}.png
51 Source8:        %{name}-debuginfo.conf
52 Source9:        %{name}-aidath.conf
53 Source10:       %{name}-multilib-aidath.conf
54 Source11:       %{name}-archive.conf
55 Source100:      %{name}-snap.conf
56 Source101:      %{name}-multilib-snap.conf
57 Source102:      %{name}-debuginfo-snap.conf
58 Patch0:         %{name}-size-type.patch
59 Patch1:         %{name}-config.patch
60 Patch2:         %{name}-missing-include.patch
61 Patch3:         pm-hooks.patch
62 Patch4:         %{name}-setenv-null.patch
63 Patch5:         %{name}-assert-sigint.patch
64 Patch6:         %{name}-upgrade-orphan.patch
65 URL:            http://poldek.pld-linux.org/
66 BuildRequires:  %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
67 BuildRequires:  autoconf
68 BuildRequires:  automake >= 1:1.11
69 BuildRequires:  bzip2-devel
70 BuildRequires:  check-devel
71 BuildRequires:  docbook-dtd412-xml
72 BuildRequires:  gettext-tools
73 BuildRequires:  libgomp-devel
74 BuildRequires:  libtool
75 BuildRequires:  libxml2-devel
76 BuildRequires:  openssl-devel >= 0.9.7d
77 BuildRequires:  pcre-devel
78 BuildRequires:  pkgconfig
79 BuildRequires:  popt-devel
80 %{?with_python:BuildRequires:   python-devel}
81 BuildRequires:  readline-devel >= 5.0
82 BuildRequires:  rpm-devel >= %{ver_rpm}
83 %{?with_python:BuildRequires:   rpm-pythonprov}
84 BuildRequires:  tar >= 1:1.22
85 BuildRequires:  xmlto
86 BuildRequires:  xz
87 BuildRequires:  zlib-devel
88 %if %{with static}
89 BuildRequires:  %{db_pkg}-static >= %{ver_db}-%{ver_db_rel}
90 BuildRequires:  bzip2-static
91 BuildRequires:  glibc-static
92 BuildRequires:  libxml2-static
93 BuildRequires:  ncurses-static
94 BuildRequires:  openssl-static
95 BuildRequires:  pcre-static
96 BuildRequires:  popt-static
97 BuildRequires:  readline-static
98 BuildRequires:  rpm-static
99 BuildRequires:  zlib-static
100 %endif
101 Requires(triggerpostun):        awk
102 Requires(triggerpostun):        sed >= 4.0
103 Requires:       %{db_pkg} >= %{ver_db}-%{ver_db_rel}
104 Requires:       %{name}-libs = %{version}-%{release}
105 Requires:       /bin/run-parts
106 Requires:       rpm >= %{ver_rpm}
107 Requires:       rpm-db-ver = %{ver_db}
108 Requires:       rpm-lib >= %{ver_rpm}
109 Requires:       sed
110 Conflicts:      etckeeper < 1.18-2
111 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
113 %define         _libexecdir     %{_prefix}/lib/%{name}
114
115 %description
116 poldek is an RPM package management tool which allows you to easily
117 perform package verification, installation (including system
118 installation from scratch), upgrading, and removal.
119
120 Program can be used in batch (like apt-get from Debian's APT) or
121 interactive mode. The interactive mode puts you into a readline
122 interface with command line autocompletion and history, similar to the
123 shell mode of Perl's CPAN.
124
125 %{?with_static:This version is statically linked.}
126
127 %{!?with_imode:This version hasn't got interactive mode.}
128 #'vim
129
130 %description -l hu.UTF-8
131 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
132 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
133 nulláról), frissítést és eltávolítást.
134
135 A program használható parancssorból (mint a Debian apt-get programja)
136 vagy interaktív módban. Az interaktív mód egy readline környezetet
137 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
138 shell módjához.
139
140 %{?with_static:Ez a verzió statikusan linkelt.}
141
142 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
143
144 %description -l pl.UTF-8
145 poldek jest narzędziem linii poleceń służącym do weryfikacji,
146 instalacji (włączając instalację systemu od zera), aktualizacji i
147 usuwania pakietów.
148
149 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
150 interaktywnym. Tryb interaktywny posiada interfejs readline z
151 dopełnianiem komend i historią, podobny do trybu shell perlowego
152 modułu CPAN.
153
154 %{?with_static:Ta wersja jest konsolidowana statycznie.}
155
156 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
157
158 %package libs
159 Summary:        poldek libraries
160 Summary(hu.UTF-8):      A poldek könyvtárai
161 Summary(pl.UTF-8):      Biblioteki poldka
162 Group:          Libraries
163
164 %description libs
165 poldek libraries.
166
167 %description libs -l hu.UTF-8
168 A poldek könyvtárai.
169
170 %description libs -l pl.UTF-8
171 Biblioteki poldka.
172
173 %package devel
174 Summary:        Header files for poldek libraries
175 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
176 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
177 Group:          Development/Libraries
178 Requires:       %{name}-libs = %{version}-%{release}
179 Requires:       rpm-devel >= %{ver_rpm}
180
181 %description devel
182 Header files for poldek libraries.
183
184 %description devel -l hu.UTF-8
185 A poldek könyvtár fejlesztői fájljai.
186
187 %description devel -l pl.UTF-8
188 Pliki nagłówkowe bibliotek poldka.
189
190 %package static
191 Summary:        poldek static libraries
192 Summary(hu.UTF-8):      poldek statikus könyvtárak
193 Summary(pl.UTF-8):      Biblioteki statyczne poldka
194 Group:          Development/Libraries
195 Requires:       %{name}-devel = %{version}-%{release}
196
197 %description static
198 poldek static libraries.
199
200 %description static -l hu.UTF-8
201 poldek statikus könyvtárak.
202
203 %description static -l pl.UTF-8
204 Biblioteki statyczne poldka.
205
206 %package -n python-poldek
207 Summary:        Python modules for poldek
208 Summary(hu.UTF-8):      Python modulok poldek-hez
209 Summary(pl.UTF-8):      Moduły języka Python dla poldka
210 Group:          Libraries/Python
211 Requires:       %{name}-libs = %{version}-%{release}
212 Requires:       python-libs
213
214 %description -n python-poldek
215 Python modules for poldek.
216
217 %description -n python-poldek -l hu.UTF-8
218 Python modulok poldek-hez.
219
220 %description -n python-poldek -l pl.UTF-8
221 Moduły języka Python dla poldka.
222
223 %prep
224 %setup -q
225 %patch0 -p1
226 %patch1 -p1
227 %patch2 -p1
228 %patch3 -p1
229 %patch4 -p1
230 %patch5 -p1
231 %patch6 -p1
232
233 %{__rm} m4/libtool.m4 m4/lt*.m4
234
235 # cleanup backups after patching
236 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
237 chmod u+x ./configure ./doc/conf-xml2.sh
238
239 %build
240 %{__gettextize}
241 %{__libtoolize}
242 %{__aclocal} -I m4
243 %{__autoheader}
244 %{__autoconf}
245 %{__automake}
246 cd tndb
247 %{__libtoolize}
248 %{__aclocal}
249 %{__autoheader}
250 %{__autoconf}
251 %{__automake}
252 cd ../trurlib
253 %{__libtoolize}
254 %{__aclocal}
255 %{__autoheader}
256 %{__autoconf}
257 %{__automake}
258 cd ..
259
260 CPPFLAGS="%{rpmcppflags} -std=gnu99 -fgnu89-inline"
261 %configure \
262         %{?with_static:--enable-static --disable-shared} \
263         %{!?with_imode:--disable-imode} \
264         --with-pkglibdir=%{_libexecdir} \
265         --enable-nls \
266         %{?with_python:--with-python}
267 %{__make} -j1
268 #       --enable-trace
269
270 %install
271 rm -rf $RPM_BUILD_ROOT
272 install -d $RPM_BUILD_ROOT/var/cache/%{name}
273
274 %{__make} install -j1 \
275         DESTDIR=$RPM_BUILD_ROOT
276
277 %if %{with python}
278 %{__make} -C python -j1 install \
279         DESTDIR=$RPM_BUILD_ROOT \
280         libdir=%{py_sitedir}
281 %endif
282
283 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
284
285 %ifarch i486 i686 ppc sparc alpha athlon
286         %define         ftp_arch        %{_target_cpu}
287 %endif
288 %ifarch %{x8664}
289         %define         ftp_arch        x86_64
290         %define         ftp_alt_arch    i686
291         %define         ftp_alt2_arch   x32
292 %endif
293 %ifarch x32
294         %define         ftp_arch        x32
295         %define         ftp_alt_arch    x86_64
296         %define         ftp_alt2_arch   i686
297 %endif
298 %ifarch i586
299         %define         ftp_arch        i486
300 %endif
301 %ifarch pentium2 pentium3 pentium4
302         %define         ftp_arch        i686
303 %endif
304 %ifarch sparcv9 sparc64
305         %define         ftp_arch        sparc
306         %define         ftp_arch        %{_target_cpu}
307         %ifarch sparc64
308                 %define         ftp_alt_arch    sparcv9
309         %endif
310 %endif
311
312 %define pld_conf %{SOURCE1}
313 %define pld_debuginfo_conf %{SOURCE8}
314 %define pld_archive_conf %{SOURCE11}
315
316 %ifarch %{x8664} x32
317         %define pld_multilib_conf %{SOURCE2}
318         %define pld_multilib2_conf %{SOURCE2}
319 %endif
320
321 # aidath
322 %ifarch sparcv9 sparc64
323         %define pld_conf %{SOURCE9}
324         %undefine pld_archive_conf
325 %endif
326 %ifarch sparc64
327         %define pld_multilib_conf %{SOURCE10}
328 %endif
329
330 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
331
332 %if 0%{?pld_multilib_conf:1}
333         %{__sed} 's|%%ARCH%%|%{ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
334 %endif
335
336 %if 0%{?pld_multilib2_conf:1}
337         %{__sed} 's|%%ARCH%%|%{ftp_alt2_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt2_arch}.conf
338 %endif
339
340 %if 0%{?pld_debuginfo_conf:1}
341 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
342 %endif
343
344 %if 0%{?pld_archive_conf:1}
345 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
346 %endif
347
348 # Always install snapshot configs
349 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
350         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
351 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
352         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
353 %ifarch %{x8664} x32
354         %{__sed} -e 's|%%ARCH%%|%{ftp_alt_arch}|g' \
355                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
356         %{__sed} -e 's|%%ARCH%%|%{ftp_alt2_arch}|g' \
357                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt2_arch}.conf
358 %endif
359
360 %if %{with snap}
361 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
362 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
363 %else
364 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
365 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
366 %endif
367
368 # create "all" meta repo
369 %if 0%{?ftp_alt_arch:1}%{?ftp_alt2_arch:1}
370 cat <<'EOF' >  $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-all.conf
371 # group source for referring th+th-multiarch sources together, i.e poldek -n th-all
372 [source]
373 type    = group
374 name    = th-all
375 sources = th %{?ftp_alt_arch:th-%{ftp_alt_arch}} %{?ftp_alt2_arch:th-%{ftp_alt2_arch}}
376 EOF
377 %endif
378
379 # th-2014 snap does not exist for x32 yet
380 %if "%{ftp_arch}" == "x32"
381 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
382 %endif
383 %if "%{ftp_alt2_arch}" == "x32"
384 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-x32.conf
385 %endif
386
387 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
388
389 %if %{with imode}
390 # add desktop file and icon
391 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
392 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
393 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
394 %endif
395
396 # sources we don't package
397 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
398 # include them in %doc
399 %{__rm} -rf configs
400 cp -a conf configs
401 %{__rm} -f configs/Makefile*
402
403 %if %{with python}
404 %py_postclean
405 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
406 %endif
407
408 %find_lang %{name}
409
410 %clean
411 rm -rf $RPM_BUILD_ROOT
412
413 %post
414 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
415 if [ "$1" = "1" ]; then
416         # remove ignore = vserver-packages inside vserver on first install
417         {
418                 while read f ctx; do
419                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
420                 done </proc/self/status
421         } 2>/dev/null
422         if [ -z "$ctx" -o "$ctx" = "0" ]; then
423                 VSERVER=no
424         else
425                 VSERVER=yes
426         fi
427         if [ "$VSERVER" = "yes" ]; then
428                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
429         fi
430 fi
431
432 %postun -p      /sbin/postshell
433 -/usr/sbin/fix-info-dir -c %{_infodir}
434
435 %post   libs -p /sbin/ldconfig
436 %postun libs -p /sbin/ldconfig
437
438 %triggerpostun -- poldek < 0.30-0.20080225.00.1
439 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
440         %{__sed} -i -e '/^%%include source.conf/{
441                 a
442                 a# /etc/poldek/repos.d/*.conf
443                 a%%includedir repos.d
444         }' %{_sysconfdir}/%{name}/poldek.conf
445 fi
446
447 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
448 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
449
450 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
451         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
452         %{__mv} -v %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
453 fi
454
455 %ifarch %{x8664}
456 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
457         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
458         %{__mv} -v %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
459 fi
460 %endif
461
462 %triggerpostun -- poldek < 0.30.1-3
463 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave ]; then
464         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf{,.rpmnew}
465         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
466 fi
467 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave ]; then
468         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf{,.rpmnew}
469         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
470 fi
471
472 %triggerpostun -- %{name} < 0.30.1-8
473 if [ $1 -le 1 ]; then
474         # revert change on  --downgrade
475         %{__sed} -i -re 's,^pm command = %{_libexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
476 else
477         # setup pm command
478         %{__sed} -i -re 's,#?(pm command =).*,\1 %{_libexecdir}/pm-command.sh,' %{_sysconfdir}/%{name}/%{name}.conf
479 fi
480
481 %files -f %{name}.lang
482 %defattr(644,root,root,755)
483 %doc ChangeLog README* NEWS TODO configs
484 %dir %{_sysconfdir}/%{name}
485 %dir %{_sysconfdir}/%{name}/pre-install.d
486 %{_sysconfdir}/%{name}/pre-install.d/README
487 %dir %{_sysconfdir}/%{name}/post-install.d
488 %{_sysconfdir}/%{name}/post-install.d/README
489 %dir %{_sysconfdir}/%{name}/repos.d
490 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
491 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
492 %attr(755,root,root) %{_bindir}/ipoldek
493 %attr(755,root,root) %{_bindir}/poldek
494 %attr(755,root,root) %{_bindir}/rpmvercmp
495 %dir %{_libexecdir}
496 %attr(755,root,root) %{_libexecdir}/pm-command.sh
497 %attr(755,root,root) %{_libexecdir}/poldekuser-setup.sh
498 %attr(755,root,root) %{_libexecdir}/vfcompr
499 %attr(755,root,root) %{_libexecdir}/vfjuggle
500 %attr(755,root,root) %{_libexecdir}/vfsmb
501 %attr(755,root,root) %{_libexecdir}/zlib-in-rpm.sh
502 %{_mandir}/man1/%{name}*.1*
503 %lang(pl) %{_mandir}/pl/man1/%{name}*
504 %{_infodir}/poldek.info*
505 %if %{with imode}
506 %{_desktopdir}/%{name}.desktop
507 %{_pixmapsdir}/%{name}.png
508 %endif
509 %dir /var/cache/%{name}
510
511 %if %{without static}
512 %files libs
513 %defattr(644,root,root,755)
514 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
515 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
516 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
517 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
518 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
519 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
520 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
521 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
522 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
523 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
524 %endif
525
526 %files devel
527 %defattr(644,root,root,755)
528 %if %{without static}
529 %attr(755,root,root) %{_libdir}/libpoclidek.so
530 %attr(755,root,root) %{_libdir}/libpoldek.so
531 %attr(755,root,root) %{_libdir}/libtndb.so
532 %attr(755,root,root) %{_libdir}/libtrurl.so
533 %attr(755,root,root) %{_libdir}/libvfile.so
534 %endif
535 %{_libdir}/libpoclidek.la
536 %{_libdir}/libpoldek.la
537 %{_libdir}/libtndb.la
538 %{_libdir}/libtrurl.la
539 %{_libdir}/libvfile.la
540 %{_includedir}/poldek
541 %{_includedir}/tndb
542 %{_includedir}/trurl
543 %{_includedir}/vfile
544 %{_pkgconfigdir}/tndb.pc
545 %{_pkgconfigdir}/trurlib.pc
546
547 %files static
548 %defattr(644,root,root,755)
549 %{_libdir}/libtndb.a
550 %{_libdir}/libtrurl.a
551
552 %if %{with python}
553 %files -n python-poldek
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
556 %{py_sitescriptdir}/poldek.py[co]
557 %{py_sitescriptdir}/poldekmod.py[co]
558 %endif
This page took 0.099018 seconds and 3 git commands to generate.