]> git.pld-linux.org Git - packages/pokerth.git/blob - pokerth.spec
- rebuild with protobuf 3.2
[packages/pokerth.git] / pokerth.spec
1 Summary:        The Open Source Texas-Holdem Poker Engine
2 Summary(pl.UTF-8):      Silnik gry Texas-Holdem poker
3 Name:           pokerth
4 Version:        1.1.1
5 Release:        3
6 License:        GPL v2+
7 Group:          X11/Applications/Games
8 Source0:        http://downloads.sourceforge.net/pokerth/PokerTH-%{version}-src.tar.bz2
9 # Source0-md5:  a7f76f95782099f966e5f2b6809f502a
10 Patch0:         x32.patch
11 Patch1:         boost-1.60.patch
12 Patch2:         ownerless.patch
13 Patch3:         cxx11-build.patch
14 Patch4:         cxx11-fixes.patch
15 Patch5:         system-qtsingleapp.patch
16 Patch6:         moc.patch
17 URL:            http://www.pokerth.net/
18 BuildRequires:  QtCore-devel >= 4.3.1
19 BuildRequires:  QtGui-devel >= 4.3.1
20 BuildRequires:  QtNetwork-devel
21 BuildRequires:  QtSingleApplication-devel
22 BuildRequires:  QtSql-devel
23 BuildRequires:  SDL_mixer-devel
24 BuildRequires:  boost-devel >= 1.37.0-3
25 BuildRequires:  curl-devel >= 7.16
26 BuildRequires:  gnutls-devel
27 BuildRequires:  gsasl-devel
28 BuildRequires:  libircclient-devel
29 BuildRequires:  protobuf-devel
30 BuildRequires:  qt4-build >= 4.3.1
31 BuildRequires:  qt4-qmake >= 4.3.1
32 BuildRequires:  sed >= 4.0
33 BuildRequires:  tinyxml-devel
34 BuildRequires:  zlib-devel >= 1.2.3
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 PokerTH is a poker game written in C++/Qt4. You can play the popular
39 "Texas Hold'em" poker variant against up to six computer-opponents or
40 play network games with people all over the world. This poker engine
41 is available for Linux, Windows, and MacOS X.
42
43 %description -l pl.UTF-8
44 PokerTH to komputerowa gra w pokera napisana w C++/Qt4. Umożliwia ona
45 grę w popularny wariant "Texas Hold'em" przeciwko maksymalnie sześciu
46 komputerowym przeciwnikom lub sieciową grę z innymi zawodnikami.
47 Silnik gry dostępny jest na platformy Linux, Windows oraz MacOS X.
48
49 %prep
50 %setup -q -n PokerTH-%{version}-src
51 %patch0 -p1
52 %patch1 -p1
53 %patch2 -p1
54 %patch3 -p1
55 %patch4 -p1
56 %patch5 -p1
57 %patch6 -p1
58
59 %{__rm} -r src/third_party/qtsingleapplication
60
61 %build
62 qmake-qt4 pokerth.pro \
63         QMAKE_CXX="%{__cxx}" \
64         QMAKE_CXXFLAGS_RELEASE="%{rpmcxxflags}"
65         QMAKE_LFLAGS_RELEASE="%{rpmldflags}"
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT%{_bindir}
71 %{__make} install \
72         INSTALL_ROOT=$RPM_BUILD_ROOT
73
74 install pokerth bin/pokerth_server $RPM_BUILD_ROOT%{_bindir}
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc COPYING ChangeLog TODO
82 %attr(755,root,root) %{_bindir}/pokerth*
83 %{_desktopdir}/%{name}.desktop
84 %{_pixmapsdir}/%{name}.png
85 %{_datadir}/%{name}
This page took 0.042893 seconds and 4 git commands to generate.