]> git.pld-linux.org Git - packages/podofo.git/blob - podofo.spec
- updated to 0.9.8 (new soname)
[packages/podofo.git] / podofo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4
5 Summary:        Library to work with PDF files
6 Summary(pl.UTF-8):      Biblioteka do obsługi PDF-ów
7 Name:           podofo
8 Version:        0.9.8
9 Release:        1
10 License:        LGPL with OpenSSL exception
11 Group:          Libraries
12 Source0:        https://downloads.sourceforge.net/podofo/%{name}-%{version}.tar.gz
13 # Source0-md5:  f6d3d5f917c7150c44fc6a15848442dd
14 URL:            https://podofo.sourceforge.net/
15 # for examples only, with -DWANT_BOOST=ON
16 #BuildRequires: boost-devel
17 BuildRequires:  cmake >= 2.6
18 BuildRequires:  cppunit-devel
19 %{?with_apidocs:BuildRequires:  doxygen}
20 BuildRequires:  fontconfig-devel
21 BuildRequires:  freetype-devel
22 BuildRequires:  libidn-devel
23 BuildRequires:  libjpeg-devel
24 BuildRequires:  libpng-devel
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtiff-devel
27 BuildRequires:  libunistring-devel
28 BuildRequires:  lua51-devel
29 BuildRequires:  openssl-devel
30 BuildRequires:  rpmbuild(macros) >= 1.605
31 BuildRequires:  texlive-pdftex
32 BuildRequires:  zlib-devel
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 The PoDoFo library is a free portable C++ library which includes
37 classes to parse a PDF file and modify its contents into memory. The
38 changes can be written back to disk easily. PoDoFo is designed to
39 avoid loading large PDF objects into memory until they are required
40 and can write large streams immediately to disk, so it is possible to
41 manipulate quite large files with it. PoDoFo uses and relies on
42 exceptions, so it must be built with them enabled.
43
44 %description -l pl.UTF-8
45 Biblioteka PoDoFo jest darmową przenośną biblioteką C++ dostarczjącą
46 klasy do parsowania plików PDF i modyfikowania ich w pamięci. Zmiany
47 mogą być ponownie łatwo zapisane na dysk. PoDoFo jest zaprojektowane w
48 sposób, który pozwala na unikanie ładowania dużych plików PDF do
49 pamięci, jeżeli nie jest to niezbędne. Pozwala również na zapisywanie
50 dużych strumieni natychmiast na dysk, co umożliwia manipulowanie
51 całkiem dużymi plikami. PoDoFo używa i zależne jest od wyjątków, więc
52 konieczna jest jego budowa z włączoną ich obsługą.
53
54 %package devel
55 Summary:        Header files for PoDoFo library
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki PodoFo
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       libstdc++-devel
60
61 %description devel
62 Header files for PoDoFo library.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe biblioteki PoDoFo.
66
67 %package static
68 Summary:        Static PoDoFo library
69 Summary(pl.UTF-8):      Statyczna biblioteka FOO
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static PoDoFo library.
75
76 %description static -l pl.UTF-8
77 Statyczna biblioteka PoDoFo.
78
79 %package apidocs
80 Summary:        PoDoFo API documentation
81 Summary(pl.UTF-8):      Dokumentacja API biblioteki PoDoFo
82 Group:          Documentation
83 BuildArch:      noarch
84
85 %description apidocs
86 API and internal documentation for PoDoFo library.
87
88 %description apidocs -l pl.UTF-8
89 Dokumentacja API biblioteki PoDoFo.
90
91 %package progs
92 Summary:        PoDoFo tools
93 Summary(pl.UTF-8):      Programy narzędziowe PodoFo
94 Group:          Applications
95 Requires:       %{name} = %{version}-%{release}
96
97 %description progs
98 Header files for PoDoFo library.
99
100 %description progs -l pl.UTF-8
101 Pliki nagłówkowe biblioteki PoDoFo.
102
103 %package examples
104 Summary:        PoDoFo examples
105 Summary(pl.UTF-8):      Przykłady do PoDoFo
106 Group:          Development/Tools
107 Requires:       %{name} = %{version}-%{release}
108
109 %description examples
110 PoDoFo examples.
111
112 %description examples -l pl.UTF-8
113 Programy przykładowe do PoDoFo.
114
115 %prep
116 %setup -q
117
118 %build
119 install -d build
120 cd build
121 %cmake .. \
122         -DPODOFO_BUILD_SHARED:BOOL=TRUE \
123         -DPODOFO_BUILD_STATIC:BOOL=TRUE \
124         -DINSTALL_LIBDATA_DIR=%{_libdir} \
125 %if "%{_lib}" == "lib64"
126         -DWANT_LIB64=TRUE
127 %endif
128
129 %{__make}
130 cd ..
131
132 %if %{with apidocs}
133 doxygen
134 %endif
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
139
140 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
141
142 %{__make} -C build install \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post   -p /sbin/ldconfig
149 %postun -p /sbin/ldconfig
150
151 %files
152 %defattr(644,root,root,755)
153 %doc AUTHORS CONTRIBUTIONS.txt COPYING.exception ChangeLog FAQ.html README.html TODO
154 %attr(755,root,root) %{_libdir}/libpodofo.so.*.*.*
155
156 %files devel
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_libdir}/libpodofo.so
159 %{_includedir}/podofo
160 %{_pkgconfigdir}/libpodofo.pc
161
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/libpodofo.a
165
166 %if %{with apidocs}
167 %files apidocs
168 %defattr(644,root,root,755)
169 %doc doc/html
170 %endif
171
172 %files progs
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_bindir}/podofo*
175 %{_mandir}/man1/podofo*.1*
176
177 %files examples
178 %defattr(644,root,root,755)
179 %{_examplesdir}/%{name}-%{version}
This page took 0.130756 seconds and 3 git commands to generate.