]> git.pld-linux.org Git - packages/podman.git/blob - podman.spec
d2b48e0bbf9fc215b4885c952b76043f8121b28b
[packages/podman.git] / podman.spec
1 Summary:        A tool for managing OCI containers and pods
2 Name:           podman
3 Version:        2.1.0
4 Release:        1
5 License:        Apache v2.0
6 Group:          Applications/System
7 #Source0Download: https://github.com/containers/podman/releases
8 Source0:        https://github.com/containers/podman/archive/v%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  30e6ad5fe7c4abfef3e07e2fa8e904dd
10 Source1:        policy.json
11 URL:            https://github.com/containers/podman
12 BuildRequires:  go-md2man
13 BuildRequires:  golang
14 BuildRequires:  golang-varlink
15 Requires:       conmon
16 Requires:       containernetworking-plugins
17 Requires:       crun
18 ExclusiveArch:  %{ix86} %{x8664} %{arm} aarch64 mips64 mips64le ppc64 ppc64le s390x
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Podman (the POD MANager) is a tool for managing containers and images,
23 volumes mounted into those containers, and pods made from groups of
24 containers. Podman is based on libpod, a library for container
25 lifecycle management that is also contained in this repository. The
26 libpod library provides APIs for managing containers, pods, container
27 images, and volumes.
28
29 %prep
30 %setup -q
31
32 %build
33 %{__make} \
34         GO=/usr/bin/go \
35         PREFIX=%{_prefix} \
36         BINDIR=%{_bindir} \
37         LIBEXECDIR=%{_libexecdir} \
38         MANDIR=%{_mandir} \
39         SHAREDIR_CONTAINERS=%{_datadir}/containers \
40         ETCDIR=%{_sysconfdir} \
41         TMPFILESDIR=%{systemdtmpfilesdir} \
42         SYSTEMDDIR=%{systemdunitdir} \
43         USERSYSTEMDDIR=%{systemduserunitdir} \
44         PYTHON=%{__python3}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 install -d $RPM_BUILD_ROOT%{_sysconfdir}/containers
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT \
53         PREFIX=%{_prefix} \
54         BINDIR=%{_bindir} \
55         LIBEXECDIR=%{_libexecdir} \
56         MANDIR=%{_mandir} \
57         SHAREDIR_CONTAINERS=%{_datadir}/containers \
58         ETCDIR=%{_sysconfdir} \
59         TMPFILESDIR=%{systemdtmpfilesdir} \
60         SYSTEMDDIR=%{systemdunitdir} \
61         USERSYSTEMDDIR=%{systemduserunitdir} \
62         PYTHON=%{__python3}
63
64 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/containers
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc README.md changelog.txt
72 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cni/net.d/87-podman-bridge.conflist
73 %dir %{_sysconfdir}/containers
74 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/containers/policy.json
75 %attr(755,root,root) %{_bindir}/podman
76 %attr(755,root,root) %{_bindir}/podman-remote
77 %{systemdunitdir}/podman.service
78 %{systemdunitdir}/podman.socket
79 %{systemdunitdir}/podman-auto-update.service
80 %{systemdunitdir}/podman-auto-update.timer
81 %{systemduserunitdir}/podman.service
82 %{systemduserunitdir}/podman.socket
83 %{systemduserunitdir}/podman-auto-update.service
84 %{systemduserunitdir}/podman-auto-update.timer
85 %{_mandir}/man1/podman*.1*
86 %{_mandir}/man5/containers-mounts.conf.5*
87 %{_mandir}/man5/oci-hooks.5*
This page took 0.050264 seconds and 2 git commands to generate.