]> git.pld-linux.org Git - packages/pnet.git/blob - pnet.spec
- updated to 0.8.0
[packages/pnet.git] / pnet.spec
1 Summary:        The DotGNU Portable .NET tools
2 Summary(pl.UTF-8):      Narzędzia Portable .NET z projektu DotGNU
3 Summary(pt_BR.UTF-8):   Ferramentas Portable .NET DotGNU
4 Name:           pnet
5 Version:        0.8.0
6 Release:        1
7 License:        GPL
8 Group:          Development/Languages
9 Source0:        http://download.savannah.gnu.org/releases/dotgnu-pnet/%{name}-%{version}.tar.gz
10 # Source0-md5:  84cb3612d7175bd9e476c88e66fe19f9
11 Patch0:         %{name}-systemffi.patch
12 Patch1:         %{name}-systemgc.patch
13 Patch2:         format-security.patch
14 Patch3:         no-regex_syntax.patch
15 URL:            http://www.gnu.org/software/dotgnu/pnet.html
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  bison
19 BuildRequires:  flex
20 BuildRequires:  gc-devel
21 BuildRequires:  libffi-devel
22 BuildRequires:  treecc >= 0.3.6
23 Requires:       %{name}-compiler = %{version}
24 Requires:       %{name}-tools = %{version}
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The goal of this project is to build a suite of Free Software tools to
29 build and execute portable executable (.NET, JavaTM, Parrot)
30 applications, including compilers, an assembler, a disassembler, and
31 runtime engine capable of executing multiple stack-based bytecode
32 formats.
33
34 This is metapackage including pnet-compiler, pnet-interpreter and
35 pnet-tools packages.
36
37 %description -l pl.UTF-8
38 Celem tego projektu jest stworzenie zestawu Wolnych narzędzi to
39 budowania i uruchamiania przenośnych plików wykonywalnych (.NET,
40 JavaTM, Parrot); aplikacji (włączając kompilatory, asembler,
41 disasembler; oraz silnika zdolnego wykonywać różne formaty dla maszyn
42 stosowych.
43
44 Jest to metapakiet zawierający pnet-compiler, pnet-interpreter i
45 pnet-tools.
46
47 %description -l pt_BR.UTF-8
48 A meta do projeto é construir um conjunto de ferramentas de software
49 livre para construit e executar aplicações .NET, incluindo um
50 compilador C#, assembler, disassembler, e runtime engine.
51
52 %package interpreter
53 Summary:        The DotGNU Portable .NET runtime engine
54 Summary(pl.UTF-8):      Silnik wykonawczy Portable .NET z projektu DotGNU
55 Summary(pt_BR.UTF-8):   A engine runtime da Portable .NET
56 Group:          Applications/Emulators
57
58 %description interpreter
59 The Converted Virtual Machine supports executing multiple kinds of
60 portable executables, including IL (".NET") and JavaTM classes.
61
62 Install it if you want to execute IL executables. You should also
63 install pnetlib.
64
65 %description interpreter -l pl.UTF-8
66 Konwertowana Maszyna Wirtualna wspiera uruchamiania wielu rodzaji
67 przenośnych plików wykonywalnych włączając IL (".NET") oraz klasy
68 JavaTM.
69
70 Zainstaluj jeżeli chcesz uruchamiać programy IL. Powinieneś także
71 zainstalować pnetlib
72
73 %description interpreter -l pt_BR.UTF-8
74 A enfine runtime executa os binários .NET. É uma máquina virtual para
75 o bytecode .NET
76
77 %package compiler
78 Summary:        The Portable .NET compiler collection
79 Summary(pl.UTF-8):      Zestaw kompilatorów Portable .NET
80 Summary(pt_BR.UTF-8):   A coleção de compiladores do Portable .NET
81 Group:          Development/Languages
82 Requires:       %{name}-compiler-bf = %{version}
83 Requires:       %{name}-compiler-c = %{version}
84 Requires:       %{name}-compiler-common = %{version}
85 Requires:       %{name}-compiler-csharp = %{version}
86 Requires:       %{name}-compiler-java = %{version}
87 Requires:       %{name}-compiler-visualbasic = %{version}
88
89 %description compiler
90 The cscc compiler collection allows multiple input languages and
91 multiple output bytecodes, much like GCC. Current languages include
92 C#, JavaTM, Brainf**k, VB, and C; current output formats include IL
93 assembly (".NET"), JavaTM assembly, and imcc (Parrot (Perl6)
94 high-level assembly).
95
96 Other common compiling tools are included, such as csant, a
97 replacement for make.
98
99 This is a virtual package that installs all compilers included with
100 the pnet distribution. If you only want some of them, get
101 `pnet-compiler-common' and `pnet-compiler-<insert language here>'.
102
103 %description compiler -l pl.UTF-8
104 Zestaw kompilatorów cscc tłumaczy wiele języków źródłowych na wiele
105 języków wynikowych, podobnie jak GCC. W chwili obecnej obsługuje C#,
106 JavaTM, Brainf**k, VB i C jako wejście oraz asembler IL (".NET"),
107 asembler JavaTM, oraz imcc (wysokopoziomowy asembler Parrot (Perl6)).
108
109 Są także załączone inne narzędzia do kompilacji takie jak csant -
110 zastępca make.
111
112 Jest to wirtualny pakiet który instaluje wszystkie kompilatory
113 załączone z dystrybucją pnet. Jeżeli chcesz tylko niektóre z nich weź
114 pnet-compiler-common i pnet-compiler-<język>
115
116 %description compiler -l pt_BR.UTF-8
117 Os compiladores para C# e C são incluídos neste pacote. O wrapper cscc
118 provê uma interface padrão de compilação
119
120 %package compiler-common
121 Summary:        Common files for Portable .NET compilers
122 Summary(pl.UTF-8):      Pliki wspólne dla kompilatorów Portable .NET
123 Group:          Development/Languages
124 Requires:       %{name}-interpreter = %{version}
125 Requires:       ilasm
126 Obsoletes:      pnet-libgc
127
128 %description compiler-common
129 The cscc compiler collection allows multiple input languages and
130 multiple output bytecodes, much like GCC. Current languages include
131 C#, JavaTM, Brainf**k, VB, and C; current output formats include IL
132 assembly (".NET"), JavaTM assembly, and imcc (Parrot (Perl6)
133 high-level assembly).
134
135 Other common compiling tools are included, such as csant, a
136 replacement for make.
137
138 You should install at least one of the specific language packages;
139 otherwise, this package is pretty useless.
140
141 %description compiler-common -l pl.UTF-8
142 Zestaw kompilatorów cscc tłumaczy wiele języków źródłowych na wiele
143 języków wynikowych, podobnie jak GCC. W chwili obecnej obsługuje C#,
144 JavaTM, Brainf**k, VB i C jako wejście oraz asembler IL (".NET"),
145 asembler JavaTM, oraz imcc (wysokopoziomowy asembler Parrot (Perl6)).
146
147 Są także załączone inne narzędzia do kompilacji takie jak csant -
148 zastępca make.
149
150 Powinieneś zainstalować co najmniej jeden z pakietów językowych pnet,
151 inaczej ten pakiet będzie bezużyteczny.
152
153 %package compiler-ilasm
154 Summary:        IL Assembler for Portable.NET
155 Summary(pl.UTF-8):      Assembler IL dla Portable.NET
156 Group:          Development/Languages
157 Provides:       ilasm
158 Obsoletes:      mono-ilasm
159
160 %description compiler-ilasm
161 IL Assembler from Portable.NET package.
162
163 %description compiler-ilasm -l pl.UTF-8
164 Assembler IL z pakietu Portable.NET.
165
166 %package compiler-csharp
167 Summary:        C# backend for cscc
168 Summary(pl.UTF-8):      Nakładka do C# na cscc
169 Group:          Development/Languages
170 Requires:       %{name}-compiler-common = %{version}
171
172 %description compiler-csharp
173 C# language backend for cscc. Install this if you want to compile C#
174 programs with cscc. It's pretty useless without package pnetlib,
175 however.
176
177 %description compiler-csharp -l pl.UTF-8
178 Nakładka języka C# dla cscc. Zainstaluj ją jeżeli chcesz kompilować
179 programy w cscc. Zazwyczaj jest bezużyteczna bez pnetlib.
180
181 %package compiler-java
182 Summary:        Java backend for cscc
183 Summary(pl.UTF-8):      Nakładka do Javy na cscc
184 Group:          Development/Languages
185 Requires:       %{name}-compiler-common = %{version}
186
187 %description compiler-java
188 Java language backend for cscc. Install this if you want to compile
189 Java programs with cscc. It's pretty useless until you manually
190 install something like classpath, however.
191
192 %description compiler-java -l pl.UTF-8
193 Nakładka języka Java dla cscc. Zainstaluj ją jeżeli chcesz kompilować
194 programy Java w cscc. Zazwyczaj jest bezużyteczna dopóki nie
195 zainstalujesz czegoś jak classpath.
196
197 %package compiler-bf
198 Summary:        Brainf**k backend for cscc
199 Summary(pl.UTF-8):      Nakładka do Brainf**k na cscc
200 Group:          Development/Languages
201 Requires:       %{name}-compiler-common = %{version}
202
203 %description compiler-bf
204 Brainf**k language backend for cscc. Install this if you want to
205 compile Brainf**k programs with cscc. Brainf**k is pretty useless,
206 however.
207
208 %description compiler-bf -l pl.UTF-8
209 Nakładka języka Brainf**k dla cscc. Zainstaluj ją jeżeli chcesz
210 kompilować programy Brainf**k w cscc. Zazwyczaj jest bezużyteczna.
211
212 %package compiler-visualbasic
213 Summary:        Visual Basic backend for cscc
214 Summary(pl.UTF-8):      Nakładka do Visual Basica na cscc
215 Group:          Development/Languages
216 Requires:       %{name}-compiler-common = %{version}
217
218 %description compiler-visualbasic
219 Visual Basic language backend for cscc. Install this if you want to
220 compile Visual Basic programs with cscc. Not as useless as
221 Brainf**k...probably.
222
223 %description compiler-visualbasic -l pl.UTF-8
224 Nakładka języka Brainf**k dla cscc. Zainstaluj ją jeżeli chcesz
225 kompilować programy Visual Basica w cscc. Nie aż tak bardzo
226 bezużyteczna jak Brainf**k, ale...
227
228 %package compiler-c
229 Summary:        C backend for cscc
230 Summary(pl.UTF-8):      Nakładka do C na cscc
231 Group:          Development/Languages
232 Requires:       %{name}-compiler-common = %{version}
233
234 %description compiler-c
235 C language backend for cscc. Install this if you want to compile C
236 programs with cscc.
237
238 C programs require a support library packaged in pnetlib called
239 `OpenSystem.C.dll'. It's like libgcc. Also, a minimal libc that
240 compiles with cscc-c-s is in pnetC.
241
242 %description compiler-c -l pl.UTF-8
243 Nakładka języka C dla cscc. Zainstaluj ją jeżeli chcesz kompilować
244 programy C w cscc.
245
246 %package tools
247 Summary:        Miscellaneous tools for DotGNU Portable .NET
248 Summary(pl.UTF-8):      Różne narzędzia Portable .NET z projektu DotGNU
249 Summary(pt_BR.UTF-8):   As ferramentas da Portable .NET
250 Group:          Development/Tools
251 Requires:       %{name}-interpreter = %{version}
252
253 %description tools
254 The general toolkit provided along with the pnet compiler and runtime
255 engines. This includes csant, a replacement for make, and various
256 tools to deal with IL binaries.
257
258 %description tools -l pl.UTF-8
259 Zestaw ogólnych narzędzi dostarczanych razem z kompilatorem i
260 środowiskiem wykonawczym. M. in. csant (zamiennik make) oraz różne
261 narzędzia do obsługi binarii IL.
262
263 %description tools -l pt_BR.UTF-8
264 O kit de ferramentas provido junto com o compilador e o runtime. Ele
265 include o csant, um substituto para make, e várias ferramentas para
266 lidar com binários IL
267
268 %package devel
269 Summary:        The Portable.Net devel headers
270 Summary(pl.UTF-8):      Pliki nagłówkowe Portable.Net
271 Summary(pt_BR.UTF-8):   Header de desenvolviemnto da Portable.Net
272 Group:          Development/Libraries
273
274 %description devel
275 The Portable .NET devel headers.
276
277 %description devel -l pl.UTF-8
278 Pliki nagłówkowe Portable.NET.
279
280 %description devel -l pt_BR.UTF-8
281 Header de desenvolviemnto da Portable .NET.
282
283 %prep
284 %setup -q
285 %patch0 -p1
286 # pnet uses gc incompatible with system lib and links statically to it
287 #%patch1 -p1
288 %patch2 -p1
289 %patch3 -p1
290
291 %{__rm} ilasm/ilasm_grammar.c
292
293 %build
294 %{__libtoolize}
295 %{__aclocal}
296 %{__autoconf}
297 %{__automake}
298 # "-O2 -march={i686|athlon} -fno-gcse" with gcc 3.x causes "no register to spill"
299 # (GNATS#10017 - qualified as "invalid user input", not a bug)
300 # -fomit-frame-pointer is needed on i686/athlon to recover one more register
301 # (which x86 have too less...)
302 CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer} -I/usr/include/ncurses"
303 CPPFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer} -I/usr/include/ncurses"
304 %configure \
305         --enable-threads=pthreads
306
307 %{__make} -j1
308
309 %install
310 rm -rf $RPM_BUILD_ROOT
311 %{__make} install \
312         DESTDIR=$RPM_BUILD_ROOT
313
314 # junk removal
315 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{al,cli-unknown-*}
316 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{al.1*,cli-unknown-*}
317 %{__mv} $RPM_BUILD_ROOT%{_bindir}/{,pnet-}resgen
318 %{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/{,pnet-}resgen.1
319
320 # don't distribute libgc
321 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/{gc*,leak_detector.h}
322 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gc
323 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgc.*
324
325 %clean
326 rm -rf $RPM_BUILD_ROOT
327
328 %post tools     -p      /sbin/postshell
329 -/usr/sbin/fix-info-dir -c %{_infodir}
330
331 %postun tools   -p      /sbin/postshell
332 -/usr/sbin/fix-info-dir -c %{_infodir}
333
334 %files
335 %defattr(644,root,root,755)
336
337 %files interpreter
338 %defattr(644,root,root,755)
339 %attr(755,root,root) %{_bindir}/ilrun
340 %attr(755,root,root) %{_bindir}/clrwrap
341 %dir %{_libdir}/cscc
342 %{_mandir}/man1/ilrun.1*
343 %{_mandir}/man1/clrwrap.1*
344
345 %files compiler
346 %defattr(644,root,root,755)
347
348 %files compiler-common
349 %defattr(644,root,root,755)
350 %doc AUTHORS ChangeLog NEWS README doc/cvmdoc
351 %attr(755,root,root) %{_bindir}/cscc
352 %attr(755,root,root) %{_bindir}/csant
353 %attr(755,root,root) %{_bindir}/ilalink
354 %attr(755,root,root) %{_bindir}/ilheader
355 %attr(755,root,root) %{_bindir}/ilgac
356 %attr(755,root,root) %{_bindir}/pnet-resgen
357 %dir %{_libdir}/cscc/plugins
358 %{_mandir}/man1/csant.1*
359 %{_mandir}/man1/cscc.1*
360 %{_mandir}/man1/ilalink.1*
361 %{_mandir}/man1/ilheader.1*
362 %{_mandir}/man1/ilgac.1*
363 %{_mandir}/man1/pnet-resgen.1*
364
365 %files compiler-ilasm
366 %defattr(644,root,root,755)
367 %attr(755,root,root) %{_bindir}/ilasm
368 %{_mandir}/man1/ilasm.1*
369
370 %files compiler-csharp
371 %defattr(644,root,root,755)
372 %attr(755,root,root) %{_libdir}/cscc/plugins/cscc-cs
373 %attr(755,root,root) %{_libdir}/cscc/plugins/cscc-csharp
374
375 %files compiler-java
376 %defattr(644,root,root,755)
377 %attr(755,root,root) %{_libdir}/cscc/plugins/cscc-java
378
379 %files compiler-bf
380 %defattr(644,root,root,755)
381 %attr(755,root,root) %{_libdir}/cscc/plugins/cscc-b
382 %attr(755,root,root) %{_libdir}/cscc/plugins/cscc-bf
383
384 %files compiler-visualbasic
385 %defattr(644,root,root,755)
386 %attr(755,root,root) %{_libdir}/cscc/plugins/cscc-vb
387
388 %files compiler-c
389 %defattr(644,root,root,755)
390 %attr(755,root,root) %{_libdir}/cscc/plugins/cscc-c-s
391 %attr(755,root,root) %{_bindir}/cscc-cpp
392 %{_mandir}/man1/cscc-cpp.1*
393
394 %files tools
395 %defattr(644,root,root,755)
396 %attr(755,root,root) %{_bindir}/ildasm
397 %attr(755,root,root) %{_bindir}/ildd
398 %attr(755,root,root) %{_bindir}/ilfind
399 %attr(755,root,root) %{_bindir}/ilsize
400 %attr(755,root,root) %{_bindir}/ilnative
401 %attr(755,root,root) %{_bindir}/ilverify
402 %attr(755,root,root) %{_bindir}/ilranlib
403 %attr(755,root,root) %{_bindir}/ilstrip
404 %attr(755,root,root) %{_bindir}/csdoc
405 %attr(755,root,root) %{_bindir}/csdoc2html
406 %attr(755,root,root) %{_bindir}/csdoc2hier
407 %attr(755,root,root) %{_bindir}/csdoc2texi
408 %attr(755,root,root) %{_bindir}/cssrc2html
409 %{_mandir}/man1/csdoc*
410 %{_mandir}/man1/cssrc2*
411 %{_mandir}/man1/ildd.1*
412 %{_mandir}/man1/ildasm.1*
413 %{_mandir}/man1/ilfind.1*
414 %{_mandir}/man1/ilnative.1*
415 %{_mandir}/man1/ilsize.1*
416 %{_mandir}/man1/ilranlib.1*
417 %{_mandir}/man1/ilstrip.1*
418 %{_mandir}/man1/ilverify.1*
419 %{_infodir}/pnettools.info*
420
421 %files devel
422 %defattr(644,root,root,755)
423 %{_includedir}/pnet
424 %{_libdir}/*.a
This page took 0.154456 seconds and 3 git commands to generate.