]> git.pld-linux.org Git - packages/pldcpan.git/blob - pldcpan.spec
rebuild with perl 5.32
[packages/pldcpan.git] / pldcpan.spec
1 Summary:        PLD Linux script to create RPMS from CPAN modules
2 Summary(pl.UTF-8):      Skrypt PLD tworzący pakiety RPM z modułów z CPAN
3 Name:           pldcpan
4 Version:        1.65
5 Release:        2
6 License:        GPL
7 Group:          Development/Languages/Perl
8 Source0:        %{name}.pl
9 BuildRequires:  perl-ExtUtils-MakeMaker
10 BuildRequires:  perl-tools-pod
11 BuildRequires:  rpm-perlprov >= 4.1-13
12 Requires:       perl-Data-Dump
13 Requires:       perl-Encode
14 Requires:       perl-LWP-Protocol-https
15 Requires:       perl-libwww
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 pldcpan creates RPMs from CPAN archives, automating the locating, spec
21 file creation.
22
23 %description -l pl.UTF-8
24 pldcpan tworzy pakiety RPM z archiwów CPAN automatyzując odnajdywanie
25 modułu i tworzenie pliku spec.
26
27 %prep
28 %setup -qcT
29 # make sure we have the version we claim to have, fail otherwise
30 ver=$(%{__perl} -MExtUtils::MM_Unix -e 'print ExtUtils::MM_Unix->parse_version(shift)' %{SOURCE0})
31 if [ "$ver" != "%{version}" ]; then
32         : Update Version to $ver, and retry
33         exit 1
34 fi
35 install -p %{SOURCE0} .
36
37 %build
38 pod2man -c "" pldcpan.pl > pldcpan.1
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
43 install -p pldcpan.pl $RPM_BUILD_ROOT%{_bindir}/pldcpan
44 cp -a pldcpan.1 $RPM_BUILD_ROOT%{_mandir}/man1
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %attr(755,root,root) %{_bindir}/pldcpan
52 %{_mandir}/man1/pldcpan.1*
This page took 0.055563 seconds and 3 git commands to generate.