]> git.pld-linux.org Git - packages/pldcpan.git/blob - pldcpan.spec
- pass CC to make
[packages/pldcpan.git] / pldcpan.spec
1 #
2 # Conditional build:
3 %bcond_with     autodeps        # BR packages needed only for resolving deps
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        PLD Linux script to create RPMS from CPAN modules
7 Summary(pl.UTF-8):      Skrypt PLD tworzący pakiety RPM z modułów z CPAN
8 Name:           pldcpan
9 Version:        1.50
10 Release:        1
11 License:        GPL
12 Group:          Development/Languages/Perl
13 Source0:        %{name}.pl
14 BuildRequires:  perl-ExtUtils-MakeMaker
15 BuildRequires:  rpm-perlprov
16 %if %{with autodeps}
17 BuildRequires:  perl-Archive-Any
18 BuildRequires:  perl-Digest-MD5
19 BuildRequires:  perl-File-Iterator
20 BuildRequires:  perl-IO-String
21 BuildRequires:  perl-IPC-Run
22 BuildRequires:  perl-Module-CoreList
23 BuildRequires:  perl-Pod-Tree
24 BuildRequires:  perl-Template-Toolkit
25 BuildRequires:  perl-YAML
26 %endif
27 Requires:       perl-Data-Dump
28 Requires:       perl-libwww
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 pldcpan creates RPMs from CPAN archives, automating the locating, spec
34 file creation.
35
36 %description -l pl.UTF-8
37 pldcpan tworzy pakiety RPM z archiwów CPAN automatyzując odnajdywanie
38 modułu i tworzenie pliku spec.
39
40 %prep
41 # make sure we have the version we claim to have, fail otherwise
42 ver=$(%{__perl} -MExtUtils::MM_Unix -e 'print ExtUtils::MM_Unix->parse_version(shift)' %{SOURCE0})
43 if [ "$ver" != "%{version}" ]; then
44         : Update Version to $ver, and retry
45         exit 1
46 fi
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 install -D %{SOURCE0} $RPM_BUILD_ROOT%{_bindir}/pldcpan
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %attr(755,root,root) %{_bindir}/pldcpan
This page took 0.048529 seconds and 3 git commands to generate.