]> git.pld-linux.org Git - packages/pinetd.git/blob - pinetd.spec
f88856b08a946d6652b35f161eeae3862c503ed7
[packages/pinetd.git] / pinetd.spec
1 # TODO
2 # - package it, initscript
3 Summary:        Portable INET Daemon Framework
4 Name:           pinetd
5 Version:        0.0.328
6 Release:        0.3
7 License:        GPL v2
8 Group:          Applications
9 Source0:        %{name}.tar.bz2
10 # Source0-md5:  94e4cdfdaefeceb4b89e0654daf443c8
11 URL:            http://www.pinetd.net/
12 Requires:       /usr/bin/php
13 #Requires:      php-common >= 4:5.3
14 Requires:       php-dom
15 Requires:       php-filter
16 Requires:       php-ftp
17 Requires:       php-gd
18 Requires:       php-hash
19 Requires:       php-iconv
20 Requires:       php-mbstring
21 Requires:       php-mhash
22 Requires:       php-mysqli
23 Requires:       php-pcre
24 Requires:       php-pecl-proctitle
25 Requires:       php-sockets
26 Requires:       php-sqlite
27 Requires:       php-tokenizer
28 Requires:       php-xml
29 Requires:       php-zlib
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _appdir %{_datadir}/%{name}
34
35 %description
36 PInetd (Portable INET Daemon) is an Open Source server framework &
37 daemon written in PHP, allowing anyone to easily create a TCP server,
38 daemon, etc. You can either use it as a developper, and build your own
39 application.
40
41 %prep
42 %setup -q -n %{name}
43 cat > %{name}.sh <<'EOF'
44 #!/bin/sh
45 exec /usr/bin/php -d date.timezone=$(date +%Z) %{_appdir}/code/root.php ${1:+"$@"}
46 EOF
47
48 find -name .svn | xargs rm -rf
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_appdir},%{_sysconfdir}/%{name}}
53 install %{name}.sh $RPM_BUILD_ROOT%{_sbindir}/%{name}
54 cp -a code $RPM_BUILD_ROOT%{_appdir}
55 cp -a etc/* $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc doc/*
63 %dir %{_sysconfdir}/pinetd
64 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pinetd/default_config.xml
65 %attr(755,root,root) %{_sbindir}/pinetd
66 %{_appdir}
This page took 0.052314 seconds and 2 git commands to generate.