]> git.pld-linux.org Git - packages/pimpmychangelog.git/blob - pimpmychangelog.spec
new, version 0.1.2
[packages/pimpmychangelog.git] / pimpmychangelog.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 Summary:        Pimp your CHANGELOG.md
6 Name:           pimpmychangelog
7 Version:        0.1.2
8 Release:        1
9 License:        GPL v2+ or Ruby
10 Group:          Applications/Text
11 Source0:        http://rubygems.org/downloads/%{name}-%{version}.gem
12 # Source0-md5:  0359fcd357bc127fe58a5762e07b70c4
13 Patch0:         require.patch
14 URL:            https://github.com/pcreux/pimpmychangelog
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 BuildRequires:  sed >= 4.0
18 %if %{with tests}
19 BuildRequires:  ruby-guard-rspec
20 BuildRequires:  ruby-rake
21 BuildRequires:  ruby-rspec
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Linkify issue numbers (#123) and github users (@gregbell) in markdown
28 changelogs.
29
30 %prep
31 %setup -q
32 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
33 %patch0 -p1
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
38 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
39 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %attr(755,root,root) %{_bindir}/pimpmychangelog
47 %{ruby_vendorlibdir}/%{name}.rb
48 %{ruby_vendorlibdir}/%{name}
This page took 0.059387 seconds and 3 git commands to generate.