]> git.pld-linux.org Git - packages/physfs.git/blob - physfs.spec
- Updated to 1.0.0
[packages/physfs.git] / physfs.spec
1 #
2 # TODO: correct %%patch0 (autoXXX thing)
3 #
4 Summary:        PhysicsFS file abstraction layer for games
5 Summary(pl):    PhysicsFS - warstwa abstrakcji plików dla gier
6 Name:           physfs
7 Version:        1.0.0
8 Release:        0.1
9 License:        BSD-like (see LICENSE)
10 Group:          Libraries
11 Source0:        http://www.icculus.org/physfs/downloads/%{name}-%{version}.tar.gz
12 # Source0-md5:  d02a8543a95d0550490cf4f96e0ddebf
13 Patch0:         %{name}-link.patch
14 URL:            http://www.icculus.org/physfs/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  doxygen
18 BuildRequires:  libtool
19 BuildRequires:  ncurses-devel
20 BuildRequires:  readline-devel
21 BuildRequires:  zlib-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 PhysicsFS is a library to provide abstract access to various archives.
26 It is intended for use in video games, and the design was somewhat
27 inspired by Quake 3's file subsystem. The programmer defines a "write
28 directory" on the physical filesystem. No file writing done through
29 the PhysicsFS API can leave that write directory, for security. For
30 example, an embedded scripting language cannot write outside of this
31 path if it uses PhysFS for all of its I/O, which means that untrusted
32 scripts can run more safely. Symbolic links can be disabled as well,
33 for added safety. For file reading, the programmer lists directories
34 and archives that form a "search path". Once the search path is
35 defined, it becomes a single, transparent hierarchical filesystem.
36 This makes for easy access to ZIP files in the same way as you access
37 a file directly on the disk, and it makes it easy to ship a new
38 archive that will override a previous archive on a per-file basis.
39 Finally, PhysicsFS gives you platform-abstracted means to determine if
40 CD-ROMs are available, the user's home directory, where in the real
41 filesystem your program is running, etc.
42
43 %description -l pl
44 PhysicsFS to biblioteka udostêpniaj±ca abstrakcyjny dostêp do ró¿nych
45 archiwów. Zosta³a stworzona z my¶l± o grach video, a projekt by³
46 trochê wzorowany na podsystemie plików z Quake 3. Programista
47 definiuje "katalog zapisu" w fizycznym systemie plików. ¯aden zapis do
48 pliku poprzez API PhysicsFS nie mo¿e wyj¶æ poza ten katalog - ze
49 wzglêdu na bezpieczeñstwo. Na przyk³ad, wbudowany jêzyk skryptowy nie
50 mo¿e zapisywaæ poza t± ¶cie¿k±, je¿eli u¿ywa PhysicsFS do wszystkich
51 operacji wej¶cia/wyj¶cia, dziêki czemu mo¿na bezpiecznie uruchamiaæ
52 nie zaufane skrypty. Dowi±zania symboliczne tak¿e mog± byæ wy³±czone
53 dla poprawy bezpieczeñstwa. Do odczytu pliku programista podaje
54 katalogi i archiwa, które sk³adaj± siê na "¶cie¿kê poszukiwañ". Po
55 zdefiniowaniu tej ¶cie¿ki, staje siê ona pojedynczym, przezroczystym
56 hierarchicznym systemem plików. Pozwala to na ³atwy dostêp do plików
57 ZIP w taki sam sposób, jak do plików na dysku, a tak¿e u³atwia
58 dostarczenie nowego archiwum, które przykryje poprzednie na poziomie
59 plików. Ponadto PhysicsFS daje wyabstrahowane od platformy sposoby na
60 okre¶lenie, czy dostêpne s± CD-ROMy, katalog domowy u¿ytkownika, gdzie
61 w prawdziwym systemie plików dzia³a program itp.
62
63 %package devel
64 Summary:        Header files for PhysicsFS development
65 Summary(pl):    Pliki nag³ówkowe do programowania z u¿yciem PhysicsFS
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}
68 Requires:       zlib-devel
69
70 %description devel
71 PhysicsFS is a library to provide abstract access to various archives.
72 This package contains the development headers and documentaion to
73 build programs using PhysicsFS.
74
75 %description devel -l pl
76 PhysicsFS to biblioteka udostêpniaj±ca abstrakcyjny dostêp do ró¿nych
77 archiwów. Ten pakiet zawiera pliki nag³ówkowe i dokumentacjê do
78 budowania programów z u¿yciem PhysicsFS.
79
80 %package static
81 Summary:        Static PhysicsFS libraries
82 Summary(pl):    Statyczne biblioteki PhysicsFS
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}
85
86 %description static
87 PhysicsFS is a library to provide abstract access to various archives.
88 This package contains the static PhysicsFS libraries.
89
90 %description static -l pl
91 PhysicsFS to biblioteka udostêpniaj±ca abstrakcyjny dostêp do ró¿nych
92 archiwów. Ten pakiet zawiera statyczne biblioteki PhysicsFS.
93
94 %package programs
95 Summary:        Program for testing PhysicsFS archives
96 Summary(pl):    Program do testowania archiwów PhysicsFS
97 Group:          Development/Libraries
98 Requires:       %{name} = %{version}
99
100 %description programs
101 PhysicsFS is a library to provide abstract access to various archives.
102 This package contains the programs using for PhysicsFS archives
103 testing.
104
105 %description programs -l pl
106 PhysicsFS to biblioteka udostêpniaj±ca abstrakcyjny dostêp do ró¿nych
107 archiwów. Ten pakiet zawiera program u¿ywany do testowania archiwów
108 PhysicsFS.
109
110 %prep
111 %setup -q
112 #%%patch -p1
113
114 %build
115 %{__libtoolize}
116 %{__aclocal}
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120 %configure
121 # unused beos.cpp causes unnecessary using CXXLINK... workaround
122 %{__make} \
123         CXXLINK="\$(LINK)"
124
125 doxygen
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT%{_mandir}/man3
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 install docs/man/man3/{PHYS*,phys*} $RPM_BUILD_ROOT%{_mandir}/man3
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files
143 %defattr(644,root,root,755)
144 %doc CHANGELOG CREDITS LICENSE TODO
145 %attr(755,root,root) %{_libdir}/lib*.so.*.*
146
147 %files devel
148 %defattr(644,root,root,755)
149 %doc docs/html
150 %attr(755,root,root) %{_libdir}/lib*.so
151 %{_libdir}/lib*.la
152 %{_includedir}/physfs.h
153 %{_mandir}/man3/*
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/lib*.a
158
159 %files programs
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_bindir}/test_physfs
This page took 0.588683 seconds and 4 git commands to generate.