]> git.pld-linux.org Git - packages/physfs.git/blob - physfs.spec
- up to 0.1.9, updated License
[packages/physfs.git] / physfs.spec
1 Summary:        PhysicsFS file abstraction layer for games
2 Summary(pl):    PhysicsFS - warstwa abstrakcji plików dla gier
3 Name:           physfs
4 Version:        0.1.9
5 Release:        1
6 License:        BSD-like (see LICENSE)
7 Group:          Libraries
8 Source0:        http://www.icculus.org/physfs/downloads/%{name}-%{version}.tar.gz
9 # Source0-md5:  ee61f31d15563a3f785adbd800933631
10 Patch0:         %{name}-link.patch
11 URL:            http://www.icculus.org/physfs/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  doxygen
15 BuildRequires:  libtool
16 BuildRequires:  ncurses-devel
17 BuildRequires:  readline-devel
18 BuildRequires:  zlib-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 PhysicsFS is a library to provide abstract access to various archives.
23 It is intended for use in video games, and the design was somewhat
24 inspired by Quake 3's file subsystem. The programmer defines a "write
25 directory" on the physical filesystem. No file writing done through
26 the PhysicsFS API can leave that write directory, for security. For
27 example, an embedded scripting language cannot write outside of this
28 path if it uses PhysFS for all of its I/O, which means that untrusted
29 scripts can run more safely. Symbolic links can be disabled as well,
30 for added safety. For file reading, the programmer lists directories
31 and archives that form a "search path". Once the search path is
32 defined, it becomes a single, transparent hierarchical filesystem.
33 This makes for easy access to ZIP files in the same way as you access
34 a file directly on the disk, and it makes it easy to ship a new
35 archive that will override a previous archive on a per-file basis.
36 Finally, PhysicsFS gives you platform-abstracted means to determine if
37 CD-ROMs are available, the user's home directory, where in the real
38 filesystem your program is running, etc.
39
40 %description -l pl
41 PhysicsFS to biblioteka udostêpniaj±ca abstrakcyjny dostêp do ró¿nych
42 archiwów. Zosta³a stworzona z my¶l± o grach video, a projekt by³
43 trochê wzorowany na podsystemie plików z Quake 3. Programista
44 definiuje "katalog zapisu" w fizycznym systemie plików. ¯aden zapis do
45 pliku poprzez API PhysicsFS nie mo¿e wyj¶æ poza ten katalog - ze
46 wzglêdu na bezpieczeñstwo. Na przyk³ad, wbudowany jêzyk skryptowy nie
47 mo¿e zapisywaæ poza t± ¶cie¿k±, je¿eli u¿ywa PhysicsFS do wszystkich
48 operacji wej¶cia/wyj¶cia, dziêki czemu mo¿na bezpiecznie uruchamiaæ
49 nie zaufane skrypty. Dowi±zania symboliczne tak¿e mog± byæ wy³±czone
50 dla poprawy bezpieczeñstwa. Do odczytu pliku programista podaje
51 katalogi i archiwa, które sk³adaj± siê na "¶cie¿kê poszukiwañ". Po
52 zdefiniowaniu tej ¶cie¿ki, staje siê ona pojedynczym, przezroczystym
53 hierarchicznym systemem plików. Pozwala to na ³atwy dostêp do plików
54 ZIP w taki sam sposób, jak do plików na dysku, a tak¿e u³atwia
55 dostarczenie nowego archiwum, które przykryje poprzednie na poziomie
56 plików. Ponadto PhysicsFS daje wyabstrahowane od platformy sposoby na
57 okre¶lenie, czy dostêpne s± CD-ROMy, katalog domowy u¿ytkownika, gdzie
58 w prawdziwym systemie plików dzia³a program itp.
59
60 %package devel
61 Summary:        Header files for PhysicsFS development
62 Summary(pl):    Pliki nag³ówkowe do programowania z u¿yciem PhysicsFS
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}
65 Requires:       zlib-devel
66
67 %description devel
68 PhysicsFS is a library to provide abstract access to various archives.
69 This package contains the development headers and documentaion to
70 build programs using PhysicsFS.
71
72 %description devel -l pl
73 PhysicsFS to biblioteka udostêpniaj±ca abstrakcyjny dostêp do ró¿nych
74 archiwów. Ten pakiet zawiera pliki nag³ówkowe i dokumentacjê do
75 budowania programów z u¿yciem PhysicsFS.
76
77 %package static
78 Summary:        Static PhysicsFS libraries
79 Summary(pl):    Statyczne biblioteki PhysicsFS
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}
82
83 %description static
84 PhysicsFS is a library to provide abstract access to various archives.
85 This package contains the static PhysicsFS libraries.
86
87 %description static -l pl
88 PhysicsFS to biblioteka udostêpniaj±ca abstrakcyjny dostêp do ró¿nych
89 archiwów. Ten pakiet zawiera statyczne biblioteki PhysicsFS.
90
91 %package programs
92 Summary:        Program for testing PhysicsFS archives
93 Summary(pl):    Program do testowania archiwów PhysicsFS
94 Group:          Development/Libraries
95 Requires:       %{name} = %{version}
96
97 %description programs
98 PhysicsFS is a library to provide abstract access to various archives.
99 This package contains the programs using for PhysicsFS archives
100 testing.
101
102 %description programs -l pl
103 PhysicsFS to biblioteka udostêpniaj±ca abstrakcyjny dostêp do ró¿nych
104 archiwów. Ten pakiet zawiera program u¿ywany do testowania archiwów
105 PhysicsFS.
106
107 %prep
108 %setup -q
109 %patch -p1
110
111 %build
112 %{__libtoolize}
113 %{__aclocal}
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117 %configure
118 # unused beos.cpp causes unnecessary using CXXLINK... workaround
119 %{__make} \
120         CXXLINK="\$(LINK)"
121
122 doxygen
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT%{_mandir}/man3
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 install docs/man/man3/{PHYS*,phys*} $RPM_BUILD_ROOT%{_mandir}/man3
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post   -p /sbin/ldconfig
137 %postun -p /sbin/ldconfig
138
139 %files
140 %defattr(644,root,root,755)
141 %doc CHANGELOG CREDITS LICENSE TODO
142 %attr(755,root,root) %{_libdir}/lib*.so.*.*
143
144 %files devel
145 %defattr(644,root,root,755)
146 %doc docs/html
147 %attr(755,root,root) %{_libdir}/lib*.so
148 %{_libdir}/lib*.la
149 %{_includedir}/physfs.h
150 %{_mandir}/man3/*
151
152 %files static
153 %defattr(644,root,root,755)
154 %{_libdir}/lib*.a
155
156 %files programs
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_bindir}/test_physfs
This page took 0.076565 seconds and 4 git commands to generate.